Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-03-2009, 02:19 PM   #1
Senior Member
jacksonpritt's Avatar

Join Date: Jul 2008
Location: Berkeley, CA
Posts: 124
K10D suddenly won't turn on (wasn't dropped)

Hey guys, just wondering if anyone has any insight on the sudden death of my K10D.

Here's the basic history:
1.) Bought the camera about 1.5 years ago, used, from a professional who was upgrading to the K20D.

2.) Treated it pretty well (first DSLR) accidentally dropped it about 6 months ago (2 feet from my lap onto the floor) but it's worked fine ever since.

3.) Was off on a two-day trip. Camera worked absolutely perfectly all day. Shot a bunch of photos the first day, changed lenses a bunch, at the end of the day reviewed the photos to delete the bad ones and took the battery out to charge it overnight.

4.) Put the battery in the camera the next morning, put the camera in my bag, put the bag in the trunk, and drove up to a scenic overlook. Pulled the camera out, and it wouldn't turn on. No activity on the LCDs, no activity on the LEDs, nothing when I put the battery in or out, put the memory card in or out, or anything else. Pushed every button I could think of, and just totally dead. Took the battery back to my hotel room, but it was fully charged.


At this point I'm at a total loss. Nothing I do seems to generate any response from either of the LCD screens or the indicator lights. Is there some sort of button lock I might have turned on accidentally? Or some sort of internal battery that needs to be replaced (to keep the internal clock or something)?

Anything you can suggest would be awesome.
I was planning on upgrading to the K7 soon anyway, but I was hoping to keep my K10D as a backup body, and I wanted to get another 6-9 months out of it before I upgraded.

Thanks!

06-03-2009, 02:35 PM   #2
Site Supporter
Mallee Boy's Avatar

Join Date: Sep 2006
Location: Hindmarsh Isl. Sth Australia
Photos: Gallery | Albums
Posts: 3,488
I dont have the K10, but do have a K20, K200 & DS.
My first thought is:
Do you have more than one battery? if so I would assume you have tried them all.
If not, perhaps get your battery checked for a possible fault or try a new one, I dont know how many charges a Li-on can take but there would be a limit, as with any battery.

Enjoy the K7.
Cheers
Grant
06-03-2009, 04:58 PM   #3
Pentaxian
jimH's Avatar

Join Date: Apr 2009
Location: South Central Nebraska - USA
Photos: Gallery | Albums
Posts: 1,422
I'm guessing the battery might have died. Before you ditch the camera, try a different battery. I know that with my K10 if the battery is weak, the camera's dead. Also, charging the battery may have killed it, or the battery was dead and didn't get recharged.

jimH
06-03-2009, 07:45 PM   #4
Veteran Member
Jewelltrail's Avatar

Join Date: May 2008
Location: Rhode Island
Photos: Albums
Posts: 4,180
My K20 did this when brand new--I nearly flipped. It turned out the brand new battery was no good. Make sure you try another battery.

I really doubt the fall it took some while back has anything to do with it. Let us know how you make out.

06-03-2009, 10:25 PM   #5
Veteran Member
mithrandir's Avatar

Join Date: Nov 2007
Location: Maryland
Photos: Gallery
Posts: 1,890
While you are checking the battery, also check the contacts (battery, camera, and charger) for corrosion. Make sure the charger is actually working as well.
06-04-2009, 12:25 PM   #6
Senior Member
jacksonpritt's Avatar

Join Date: Jul 2008
Location: Berkeley, CA
Posts: 124
Original Poster
Thanks for the suggestions guys!

I only have one battery, so I'll get another one and see if it works.
I didn't see any corrosion anywhere, but the battery is pretty old. I'm sure the guy who had the K10D before me bought the camera immediately when it came out, and I am still using the original battery it came with.

The reason I thought it wasn't the battery is that it appears to charge when I put it in the charger (light comes on, stays on long enough to "top off" the charge, and then goes off) and I haven't noticed the battery live getting shorter or anything.

I will buy a new battery and then come back to update this thread to let you guys know what happens.
06-04-2009, 12:37 PM   #7
Site Supporter
Driver3's Avatar

Join Date: Sep 2006
Location: Florida
Posts: 188
Typically, if the battery is full and you put it back in the charger, the light stays on for like a blink. Sounds like the battery isn't well.
06-04-2009, 01:32 PM   #8
Veteran Member




Join Date: Aug 2007
Photos: Gallery
Posts: 1,563
One more reason for the camera to not respond is an open SD card door.
If the door is closed and the slot contains a card, perhaps the switch malfunctions.

- Bert

06-05-2009, 06:43 AM   #9
Pentaxian
jimH's Avatar

Join Date: Apr 2009
Location: South Central Nebraska - USA
Photos: Gallery | Albums
Posts: 1,422
QuoteOriginally posted by bymy141 Quote
One more reason for the camera to not respond is an open SD card door.
If the door is closed and the slot contains a card, perhaps the switch malfunctions.

- Bert

Camera won't turn on without an SD card in the slot. Could be a bad SD card and the camera isn't recognizing that a card is in the slot. Just a thought.

jimH
06-05-2009, 09:32 PM   #10
Pentaxian
reeftool's Avatar

Join Date: Dec 2007
Location: Upstate New York
Photos: Gallery | Albums
Posts: 8,139
QuoteOriginally posted by jimH Quote
Camera won't turn on without an SD card in the slot. Could be a bad SD card and the camera isn't recognizing that a card is in the slot. Just a thought.

jimH
It won't turn on but will display a "no card " message on the screen.
07-01-2009, 04:47 PM   #11
Senior Member
jacksonpritt's Avatar

Join Date: Jul 2008
Location: Berkeley, CA
Posts: 124
Original Poster
So just as randomly as it stopped working, my K10D suddenly started working again.
Didn't change the battery, SD card, or anything else.

All I can figure is that water somehow got inside the camera overnight (I took some up close shots of a waterfall the day it died) and it wouldn't start because of moisture in the camera.

But it could be an SD card problem too, since some of the images (8 or so) on the card came out corrupt. Hopefully reformatting the SD cards will help prevent this from happening again.
08-17-2009, 11:07 PM   #12
Senior Member
jacksonpritt's Avatar

Join Date: Jul 2008
Location: Berkeley, CA
Posts: 124
Original Poster
...aaaand suddenly it won't work again!

It worked just fine for about a month or so, and I took it on another trip.
It worked great the entire time, no problems.

Got it home, got the images off the card, and then set the camera on a shelf for a week and didn't touch it.

Picked it up today to attach the new battery grip I just got, and when I go to turn it on, NOTHING.

So I fully charged both batteries, put them in, and still nothing. It won't turn on and the activity light for the CF card won't come on either with or without the grip.


I'm really, really frustrated right now.
I've been patiently trying to wait for the K7 to drop in price and hoping that my K10D will stop acting up, but now I'm fed up with having an unreliable camera. I'd buy a K20D, but Amazon stopped selling the body only kit and I don't need or want any lenses right now. Not to mention that the lowest price for it has already passed and it's starting to go back up.

Not to mention that I JUST bought the grip for the K10/K20 and got it in the mail today...

I guess you never really know how much you rely on something until it breaks.
08-19-2009, 07:24 AM   #13
Senior Member




Join Date: May 2009
Location: Atlanta
Posts: 110
Always check B&H!

Their price on K20D body only is $619.95.

Pentax | K20D SLR Digital Camera (Camera Body) | 19381 | B&H

I was about to buy the battery grip from Amazon @ $123. Now it's $131+. What's with that??
08-19-2009, 07:46 AM   #14
Veteran Member
GerryL's Avatar

Join Date: Jan 2009
Location: CA
Posts: 2,731
QuoteOriginally posted by jacksonpritt Quote
...aaaand suddenly it won't work again!

It worked just fine for about a month or so, and I took it on another trip.
It worked great the entire time, no problems.

Got it home, got the images off the card, and then set the camera on a shelf for a week and didn't touch it.

Picked it up today to attach the new battery grip I just got, and when I go to turn it on, NOTHING.

So I fully charged both batteries, put them in, and still nothing. It won't turn on and the activity light for the CF card won't come on either with or without the grip.


I'm really, really frustrated right now.
I've been patiently trying to wait for the K7 to drop in price and hoping that my K10D will stop acting up, but now I'm fed up with having an unreliable camera. I'd buy a K20D, but Amazon stopped selling the body only kit and I don't need or want any lenses right now. Not to mention that the lowest price for it has already passed and it's starting to go back up.

Not to mention that I JUST bought the grip for the K10/K20 and got it in the mail today...

I guess you never really know how much you rely on something until it breaks.
Hey, don't throw it away.
I'm willing to accept the generous donation..working or not.
08-19-2009, 07:49 AM   #15
Pentaxian
reeftool's Avatar

Join Date: Dec 2007
Location: Upstate New York
Photos: Gallery | Albums
Posts: 8,139
It may be fixable. I would send it in and have them give you an estimate before repairing.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
activity, battery, bunch, button, camera, day, dslr, k10d, months, photography, photos, sort
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rear screen won't turn off? Todd Adamson Troubleshooting and Beginner Help 3 10-30-2010 09:37 PM
Dropped K10D - any self help available? Stringmike Pentax DSLR Discussion 4 07-29-2009 08:57 AM
Dropped it, now K10D won't turn on feralryan Pentax DSLR Discussion 6 05-15-2009 07:39 PM
To turn right or to turn left spura Pentax SLR Lens Discussion 14 04-15-2009 11:29 AM
Oops. I dropped my K10D pentaxshooter Pentax DSLR Discussion 1 04-04-2007 01:06 PM



All times are GMT -7. The time now is 07:42 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top