Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-03-2009, 06:56 PM   #1
New Member




Join Date: Dec 2008
Location: Brandon, MS
Posts: 7
K20D - Not working

AutoFocus, Metering through view finder, Live View, etc... not working. The other functions of the camera work such as preview, menu, functions, etc but I can't take pictures, focus, etc.... Any suggestions as what to try? I've already tried different lens, removed battery, dust cleaning, and nothing works.


Last edited by Rusty27; 06-03-2009 at 07:02 PM.
06-03-2009, 07:58 PM   #2
Site Supporter
Mallee Boy's Avatar

Join Date: Sep 2006
Location: Hindmarsh Isl. Sth Australia
Photos: Gallery | Albums
Posts: 3,488
G'day Rusty,
I assume you have done this, but just in case you have missed it have a look at page 237 of the manual (re set function).
Cheers
Grant
06-03-2009, 08:17 PM   #3
New Member




Join Date: Dec 2008
Location: Brandon, MS
Posts: 7
Original Poster
Yeah. Tried the reset but nothing. Sensor cleaning piece works. I can get the mirror to go up. Wish it would give some type of error or something.
06-03-2009, 08:31 PM   #4
Ole
Administrator
Ole's Avatar

Join Date: Sep 2006
Location: Copenhagen, Denmark
Photos: Gallery | Albums
Posts: 3,862
Bad SD card?

06-03-2009, 08:49 PM   #5
New Member




Join Date: Dec 2008
Location: Brandon, MS
Posts: 7
Original Poster
Nah. I'm able to view all pictures via preview on the camera. I did try resetting the SD card as test.

It appears to be something wrong with the sensor maybe. When looking through the viewfinder none of the readings show up. Almost like the camera is off.
06-04-2009, 06:43 AM   #6
Site Supporter
skid2964's Avatar

Join Date: May 2008
Location: USA
Posts: 603
That sucks! Hope you get it fixed!

What does Pentax say about it? Have you contacted them yet?
06-04-2009, 07:12 AM   #7
New Member




Join Date: Dec 2008
Location: Brandon, MS
Posts: 7
Original Poster
I'm going to contact them this morning. Hopefully they can give good news.
06-04-2009, 08:58 AM   #8
New Member




Join Date: Dec 2008
Location: Brandon, MS
Posts: 7
Original Poster
Talked to Pentax support and they just recommend sending it in for repair. It is still under the 1 year warranty but just sucks I'll loose the camera for 15-20 business days plus shipping.

06-04-2009, 09:20 AM   #9
Veteran Member
AndrewG NY's Avatar

Join Date: Dec 2006
Location: Chappaqua, NY
Photos: Gallery
Posts: 679
It's not the shutter button is it? Does the AF button trigger autofocus? Do you have a cable-release? If so you can try it.
06-04-2009, 10:20 AM   #10
New Member




Join Date: Dec 2008
Location: Brandon, MS
Posts: 7
Original Poster
Good idea!!!! Just tried using my wireless remote to take a picture and nothing happens with it either. Good thought though.
12-02-2009, 06:14 AM   #11
Site Supporter
skid2964's Avatar

Join Date: May 2008
Location: USA
Posts: 603
Did you ever get this fixed? Did Pentax provide good service?
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, functions, photography, view
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K20D Shutter Not Working!!! Murdoughnut Pentax DSLR Discussion 8 09-06-2010 11:40 PM
rear e-dial on K20D stops working WMBP Pentax DSLR Discussion 12 04-13-2010 12:32 PM
K20D AF not working properly dgaies Pentax DSLR Discussion 18 03-09-2010 01:15 AM
K20D Problem: Manual and Menu not working anamnezis Pentax DSLR Discussion 5 01-05-2010 02:48 PM



All times are GMT -7. The time now is 06:27 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top