Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-25-2007, 11:00 PM   #1
Senior Member
skaktuss's Avatar

Join Date: Feb 2007
Location: Latvia
Photos: Gallery
Posts: 259
Memory card error

I just bought a new Transcend 2gb 150x SD card. But my K100D doesn't work with it! At first I thought maybe firmware update 1.02 would help. But after update I got only "Memory card error" on the screen. Card is ok and it works in my card reader without issues. I tried an old 128mb card from a gps device and it worked!
I know that Alvin has this SD card too and he has no problems with it!

04-25-2007, 11:28 PM   #2
Inactive Account




Join Date: Feb 2007
Location: Adelaide, South Australia, Australia
Photos: Gallery
Posts: 364
It could be that the card has a bad sector or something similar, and the camera is trying to write to that, while that card reader ignores it, try running a disk check utility on the card, if you can, or find some one near by with either a pentax similar to yours or a D80 or D40, so you can check it to see if your cad works in their cameras.

Last edited by Cideway; 04-25-2007 at 11:30 PM. Reason: spelling error that changed the meaning
04-25-2007, 11:36 PM   #3
Veteran Member
WMBP's Avatar

Join Date: Dec 2006
Location: Dallas, Texas
Photos: Gallery
Posts: 2,496
QuoteOriginally posted by skaktuss Quote
I just bought a new Transcend 2gb 150x SD card. But my K100D doesn't work with it! At first I thought maybe firmware update 1.02 would help. But after update I got only "Memory card error" on the screen. Card is ok and it works in my card reader without issues. I tried an old 128mb card from a gps device and it worked!
I know that Alvin has this SD card too and he has no problems with it!
I have one of these cards, too. I bought it mainly because it was inexpensive - and because some other users in this forum and elsewhere recommended it. At first, I thought it was working fine. But now I'm beginning to wonder. I've noticed two problems.

First, quite frequently lately, when I import photos from the card, one or two photos won't import because the files can't be read or are said to be damaged. NOTE that I never fill the card completely - I always stop shooting when the camera says there's space for at least 10 images. (And if I understand something that I read here recently, that "10" probably means far more than 10, but that's another subject.) I reformatted the card the other day in the camera and I'm waiting to see if I have another problem.

The other problem is that, when I'm using the Transcend 2GB 150x card, continuous shooting just doesn't work as it should with a K10D. Instead of being able to rattle off at least five shots, I might get one or two off, then the camera stalls, then it lets me shoot a couple more, and so on. Don't have this problem using the 2GB SanDisk card or a 1 GB Kingston card.

I should say, to be fair, that I do not have the problem you have. My Transcend card is accepted by the camera and does record the vast majority of my photos fine. And I'm not 100% sure that EITHER of the two problems I describe above is the fault of the card, although the fact that I haven't had either problem when using another card does point in that direction.

Will
04-26-2007, 01:01 AM   #4
Senior Member
skaktuss's Avatar

Join Date: Feb 2007
Location: Latvia
Photos: Gallery
Posts: 259
Original Poster
Thanks for replies! I have to find some other camera to test the card.

04-26-2007, 02:24 AM   #5
Veteran Member




Join Date: Sep 2006
Location: Virginia Beach VA USA
Photos: Gallery
Posts: 1,364
I have 2 of these cards, and so far they work flawlessly. Have you tried reformatting the card?

If that does not work, the card has a 1 year warranty, I'd have them replace it.
04-26-2007, 02:52 AM   #6
Veteran Member
stewart_photo's Avatar

Join Date: Apr 2007
Location: Heidelberg, Germany
Posts: 1,864
QuoteOriginally posted by skaktuss Quote
I just bought a new Transcend 2gb 150x SD card. But my K100D doesn't work with it! At first I thought maybe firmware update 1.02 would help. But after update I got only "Memory card error" on the screen. Card is ok and it works in my card reader without issues. I tried an old 128mb card from a gps device and it worked!
I know that Alvin has this SD card too and he has no problems with it!

What you're describing is not all that unusual. Because of slight differences in manufacturing, and slight differences in formating between devices, a card may indeed work in one device and not in another. With six devices using SD cards (two cameras, PDA, card reader, etc), I run into this all the time. Try formating the card using the device it currently doesn't work with (your camera in this case). If that works, then try the card in your card reader. If it now works in both, you're good to go. However, you may find this card simply refuses to work with both devices (card reader and camera). Your only choice at that point is to return it and try another brand, as I've had to do several times.

stewart
04-26-2007, 02:53 AM   #7
Veteran Member
benjikan's Avatar

Join Date: Jan 2007
Location: Paris, France
Photos: Gallery
Posts: 4,309
Trnascend 2 GB

QuoteOriginally posted by skaktuss Quote
I just bought a new Transcend 2gb 150x SD card. But my K100D doesn't work with it! At first I thought maybe firmware update 1.02 would help. But after update I got only "Memory card error" on the screen. Card is ok and it works in my card reader without issues. I tried an old 128mb card from a gps device and it worked!
I know that Alvin has this SD card too and he has no problems with it!
I have two Transcend 2 gb 150x cards...No problem what so ever...
04-26-2007, 05:32 AM   #8
Forum Member




Join Date: Mar 2007
Location: Connecticut USA
Posts: 73
If you will search this forum for card reformat, you will find two threads that may help. As I noted in the before and after thread, I never delete images or reformat the card via the computer; only in the camera. I also keep my cards dedicated to the specific camera in which the card was first formatted.

04-26-2007, 06:03 AM   #9
Senior Member
skaktuss's Avatar

Join Date: Feb 2007
Location: Latvia
Photos: Gallery
Posts: 259
Original Poster
I've formatted it in all the possible ways. I'll try to return it!
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, card, dslr, memory card, photography, sd
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Memory card error jaysee15 Pentax DSLR Discussion 5 08-18-2011 09:26 AM
Memory card error chuckdua Troubleshooting and Beginner Help 10 09-29-2010 02:15 PM
memory card error problem cdm807 Troubleshooting and Beginner Help 15 10-17-2009 07:22 PM
Memory Card Error soundview Pentax DSLR Discussion 5 07-23-2008 09:08 AM
Sandisk Memory Card Error- HELP!!!! tasha_22 Pentax Camera and Field Accessories 0 06-30-2007 03:23 AM



All times are GMT -7. The time now is 02:43 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top