Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-16-2009, 11:15 AM   #1
Veteran Member




Join Date: Aug 2008
Location: California
Posts: 851
battery grip causing K20 problem

The problem began a while ago but I could not pin-point the source. The rear wheel on my k20 would stop working. At first my solution was to take all the batteries out (which involved taking the BG-2 off) and then putting everything back together and then things would work fine.

Now, however, the rear wheel will not work at all if the BG-2 is attached to the camera. Has anyone else encountered this?

Thanks... Chris

06-16-2009, 11:29 AM   #2
Veteran Member
blende8's Avatar

Join Date: Feb 2007
Location: Bremen, Germany
Photos: Albums
Posts: 1,484
This happens when a dial on the grip is between two positions.
Just turn the dials on the grip back and forth.
It should work then again, I hope.
06-16-2009, 12:16 PM   #3
Site Supporter
Nowhere Matt's Avatar

Join Date: Nov 2007
Location: Nowhere Land
Photos: Gallery | Albums
Posts: 2,312
Are you stating that the rear wheel of the camera body will not function when a battery grip is connected? That would be strange.
I have had instances where I was certain that exposures were incorrect because of not properly connected grip but for the rear e-dial doo hickie to malfunction does seem odd. Just as possible; but odd nonetheless.

And again I add nothing to the thread but an increase in traffic. So there ya go.
06-16-2009, 01:37 PM   #4
Loyal Site Supporter
imtheguy's Avatar

Join Date: Mar 2009
Location: Virginia Beach
Photos: Gallery | Albums
Posts: 2,950
No, thats not the case. He is referring to a known issue whereby if a wheel on the grip is only PARTIALLY turned and is BETWEEN click positions, that will affect or disable the camera body wheel. Simply check the grip wheels to make sure they did not catch on your sleve and get rotated slightly. It should not be something that happens everyday. My grip has not come off in 2 weeks and i use the camera every day but have yet to encounter the dreaded partial-click problem.

06-16-2009, 01:42 PM   #5
Veteran Member
Jodokast96's Avatar

Join Date: Oct 2007
Location: Erial, NJ USA
Photos: Gallery | Albums
Posts: 2,133
Also, check the electrical contacts between the grip and the body. One pin should be slightly shorter than the rest, but if there is more than one, that could be the problem. Also check that they depress and return freely.
06-16-2009, 02:11 PM   #6
Veteran Member




Join Date: Aug 2008
Location: California
Posts: 851
Original Poster
QuoteOriginally posted by blende8 Quote
This happens when a dial on the grip is between two positions.
Just turn the dials on the grip back and forth.
It should work then again, I hope.
tah dah... thanks man. That was exactly the problem.
06-16-2009, 09:16 PM   #7
Senior Member
allill's Avatar

Join Date: Aug 2008
Location: San Francisco, California
Posts: 267
QuoteOriginally posted by kunik Quote
tah dah... thanks man. That was exactly the problem.
The half click thing can get annoying with the bg2.
06-16-2009, 09:21 PM   #8
Loyal Site Supporter
imtheguy's Avatar

Join Date: Mar 2009
Location: Virginia Beach
Photos: Gallery | Albums
Posts: 2,950
Is it a Pentax or a knock-off brand? just wondering if all of them are susceptable.

06-16-2009, 11:19 PM   #9
Junior Member
digitalphil's Avatar

Join Date: Dec 2007
Location: Victoria BC
Photos: Gallery
Posts: 35
I had the front dial stop working...

What happened was some pins bent ever so slightly and that by placing the grip in my gadget bag or by attaching the grip, a couple of pins had remained in the depressed position. I had to carefully coax them out. All is fine...now you know.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
battery grip, bg-2, camera, dslr, k20, photography, wheel
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K20 and the Battery Grip kshapero Pentax DSLR Discussion 17 01-07-2009 05:32 AM
Third-party battery grip for K10/K20 deepbluish Pentax Camera and Field Accessories 5 07-14-2008 05:25 PM
AA Battery grip for k10 / k20 / k100 philmorley Pentax Camera and Field Accessories 3 07-14-2008 04:29 PM
Battery grip causing weird readings? Inspection Guy Pentax Camera and Field Accessories 3 02-02-2008 09:25 AM



All times are GMT -7. The time now is 03:38 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top