Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-01-2009, 10:38 AM   #1
Senior Member




Join Date: May 2008
Location: New Westminster, Canada
Photos: Gallery
Posts: 280
Pentax Techs Bad Experience...

So I had a e-dial squeak and sent the unit back for repairs, it took them roughly 4 weeks to repair. So today, playing around with the camera I noticed a soft spot which makes a sound when I pressed on it. It's around the bottom right of the LCD to where the Fn and SR switch are. I also noticed that they forgot to put a screw back in on the bottom! Now I have to wait another 4 weeks possibly to get this repaired again.

In the meantime, can someone confirm that there shouldn't be a soft spot in the area I mentioned. Thanks.

07-01-2009, 12:23 PM   #2
New Member




Join Date: Jun 2008
Location: Drexel Hill, PA
Posts: 3
What camera are you asking about?
07-01-2009, 12:27 PM   #3
nah
Senior Member




Join Date: May 2008
Location: New Westminster, Canada
Photos: Gallery
Posts: 280
Original Poster
Whoops totally forgot to mention the camera, it's a K20D.
07-01-2009, 05:29 PM   #4
Senior Member
jacksonpritt's Avatar

Join Date: Jul 2008
Location: Berkeley, CA
Posts: 124
What do you mean "soft spot"?

Like, the plastic of the camera is soft?

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
bottom, camera, dslr, photography, spot, weeks
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
My Pentax K1000 experience. jgredline Pentax Film SLR Discussion 29 08-29-2010 04:44 PM
FA 31mm Limited assembled in Vietnam - bad QC or bad luck. Voe Pentax SLR Lens Discussion 64 03-03-2010 05:44 PM
petax da 16-50 experience (pentax k-m) roy4core Pentax SLR Lens Discussion 3 04-06-2009 09:17 AM
Really Bad eBay and Paypal Experience Abbazz General Talk 14 07-02-2008 08:04 AM
Tamron Adaptall... Bad lens or bad adapter Okami Pentax SLR Lens Discussion 6 05-01-2008 06:52 PM



All times are GMT -7. The time now is 08:03 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top