Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-08-2009, 02:20 AM   #31
Pentaxian
Arpe's Avatar

Join Date: Sep 2006
Location: New Zealand
Photos: Gallery | Albums
Posts: 4,331
I'm pretty sure (but not certain) the flash did not assist focus in AFC ages ago, pre 1.03. I remember panicing at the time.

07-08-2009, 06:04 AM   #32
Loyal Site Supporter
imtheguy's Avatar

Join Date: Mar 2009
Location: Virginia Beach
Photos: Gallery | Albums
Posts: 2,950
One more data (datum?) point with firmware 1.03 since upgraded first day available.


Testing with a 55-300mm lens (you never know if these things are lens dependent), I get:

on-board flash assist - yes

on-board flash sync - yes

live view AF - only by pressing the AF button, not by half-press shutter (don't think that worked under 1.01 for me either)
07-08-2009, 06:07 AM   #33
Senior Member




Join Date: Jun 2009
Location: LAKE PLACID,FL
Photos: Albums
Posts: 110
Ver 1.03 is at pentax's usa site!!!

Yoy will find version 1.03 ready for download in the support section of pentax's usa site!!!
Thanks and have a great day!!!
07-08-2009, 01:45 PM   #34
Veteran Member




Join Date: Jun 2009
Photos: Albums
Posts: 1,679
QuoteOriginally posted by COULDBE2 Quote
Yoy will find version 1.03 ready for download in the support section of pentax's usa site!!!
Thanks and have a great day!!!


07-08-2009, 01:54 PM   #35
Veteran Member




Join Date: Jun 2009
Photos: Albums
Posts: 1,679
QuoteOriginally posted by Damn Brit Quote
Unfortunately it seems isolated at the moment to the extent that it would be hard to prove it's the firmware, we only have suspicion.
I am still danged curious what happened. I actually posted a comment a couple weeks back, you know when I first found this place, over on Ned Brunnell's blog that it sure would be nice if Pentax took a lead on other camera mfg's and added a feature to do a complete dump of settings to an SD card as nobody does that...I bet not many of us actually keep a settings log at all. I would sense they would also do a pre-flash dump to the card automagically as part of the flashing process. It is all just code and heck, might even be possible if run from the SD card itself rather than the camera. but it could run from the camera.

I just sense it's the sort of belt and suspenders thing which would help troubleshoot an issue such as this. Even better if the backup could grab the current internal config info to send to Pentax. Might even save on a bunch of returns.

I just hope the flash did not brick your body.

Keeping fingers crossed down here where the sewer meets the sea...in the wonderful town of 'Lompton'.
07-08-2009, 02:27 PM   #36
Pentaxian
philbaum's Avatar

Join Date: Oct 2007
Location: Port Townsend, Washington State, USA
Posts: 3,659
Not having any problem with focus assist and 1.03

Guys,
I just bought my K20D about 2 months ago, and upgraded it to V1.3 right after purchase.

I don't AF on half press shutter button anymore, just use the AF button. so in a dark room, i press the AF button with the onboard flash up, and it did the focus assist thing, and thereafter i hit the shutter and it fired with the flash just fine. Then i turned on the half press AF, and again the AF assist flash worked just fine and the flash picture was successful.

All this was done with the AF key enabled in Customs menu. I didn't have to go to AFC as someone mentioned, just AFS.

I doubled checked my camera and it still says 1.03

best of luck,
07-08-2009, 03:02 PM   #37
Veteran Member




Join Date: Jun 2009
Photos: Albums
Posts: 1,679
QuoteOriginally posted by philbaum Quote
Guys,
I just bought my K20D about 2 months ago, and upgraded it to V1.3 right after purchase.

I don't AF on half press shutter button anymore, just use the AF button. so in a dark room, i press the AF button with the onboard flash up, and it did the focus assist thing, and thereafter i hit the shutter and it fired with the flash just fine. Then i turned on the half press AF, and again the AF assist flash worked just fine and the flash picture was successful.

All this was done with the AF key enabled in Customs menu. I didn't have to go to AFC as someone mentioned, just AFS.

I doubled checked my camera and it still says 1.03

best of luck,
Interesting and thanks for the confirmation it should work in either AF.C or AF.S...mine still only will flash assist in AF.S
07-08-2009, 03:28 PM   #38
Veteran Member
Venturi's Avatar

Join Date: Mar 2008
Location: Tulsa, OK
Photos: Gallery
Posts: 2,639
I just did another test - K20 + "original" v1.03 firmware installed 06/2008.

It in fact does not fire the AF assist lamp in AF.C mode.
For the record, I believe this is the correct behavior.

In my "closed bathroom" test it fired the lamp 3 times to get a lock with the DA*50-135.
Now imagine if the camera were attempting to lock focus on a moving object (which it can not "see" without AF assist) in AF.C mode.

a) AF.C is intended for subjects which need constant adjustment in order to achieve a relatively well focused exposure.
b) AF needs adequate light in order to be effective.
c) Constant AF needs constantly adequate light to be effective.
d) The onboard flash is not intended to be used for providing ambient light.

There is no bug in v1.03 - at least in regards to AF assist lamp. If AF assist does not work for you in AF.S mode then contact Pentax Support for troubleshooting.

07-08-2009, 03:55 PM   #39
Veteran Member




Join Date: Jun 2009
Photos: Albums
Posts: 1,679
Jim,

Thanks for input here...but your results are exactly opposite of what philbaum reported in post #36. Both you you cannot be correct. I wish I could recall if I had tried it before updating the firmware. My body came with 1.01 so it would have been the ideal reference point.

The biggest problem is I have tried to scour the user manual and I only find one reference to something called "AF Illuminator" on pg. 143 where they are discussing using and external flash but the table indicates that the onboard flash AF Illuminator functions....??? But there isn't and mention that I have been able to find elsewhere in the manual. I have no doubt I missed it, but also given the conflicting reports I can't accept one over the other. I realize you believe it is correct not working in AF-C mode. But there there is the other report. If someone with a pristine install of v1.00 or v1.01 could test it that would help.

BTW, I have a sense it should not work in AF-C mode but again conflicting reports as well as the absence of info in the manual cloud the issue. Hopefully Gary was able to get with someone at Pentax today because his camera is really foobar'd based on his comments from last night.

===============================
EDIT: I found a reference to the flash assist on pg. 105 where the manul clearly states that the flash fires to assist focus in dark areas in AF-S mode. It says nothing about it not firing in AF-C mode which I would say means it should not fire in AF-C mode...yes?

Last edited by brecklundin; 07-08-2009 at 04:09 PM.
07-08-2009, 04:16 PM   #40
Senior Member
dnaseigel's Avatar

Join Date: Jan 2008
Location: Rockford, IL
Photos: Gallery
Posts: 179
QuoteOriginally posted by brecklundin Quote
Jim,

Thanks for input here...but your results are exactly opposite of what philbaum reported in post #36. Both you you cannot be correct. I wish I could recall if I had tried it before updating the firmware. My body came with 1.01 so it would have been the ideal reference point.
With the benefit of having a K20D that has never had a firmware upgrade added to it and one that has ver. 1.0.3, I tested the focus assist with the on camera flash on both. In the AF-S both cameras fired the AF assist. In AF-C neither camera fired the AF assist.

After rereading post #36 and 38 there is nothing really contradictory written. philbaum simply stated that he did not have to go to AFC without stating if he had infact tried the AF assist with the camera switched to AF-C .

As far as the noise that Damn Brit was getting, I also had a very conspicuous noise until I turned off the shake reduction. Then the camera was quiet as a mouse. Hope this is a useful addition.

David
07-08-2009, 04:23 PM   #41
Veteran Member
octavmandru's Avatar

Join Date: Jan 2009
Location: somewhere around
Posts: 615
True, I was going to state the same thing.
AF-C is not AF assisted either on my k20 or k200.
Firmware 1.0.3 refers specifically to improved SR. Some say the AF is faster, I would not know since K20 came with the latest firmware. I am perfectly happy with k20
07-08-2009, 04:32 PM   #42
Senior Member
dnaseigel's Avatar

Join Date: Jan 2008
Location: Rockford, IL
Photos: Gallery
Posts: 179
After referring to my handy-dandy Magic Lantern Guide to the K20D, on page 139 in the second paragraph regarding AF-C it clearly states "When AF.C is selected, a flash unit's focus-assist feature will not operate."
07-08-2009, 05:00 PM   #43
Veteran Member




Join Date: Jun 2009
Photos: Albums
Posts: 1,679
cool, guys...I just re-read phil's comment and, yup, I originally read it bassawkards...D'oh!! So then mine is working as it should be. I sort of figured if there was a bug in the firmware it would have been found by now, but with the confusion over the manual and not being completely familar with the system...I was not sure.

Thanks for clearing it up for me...now about Gary's prob...hope he reads this about the AF noise sort of resetting itself. But I wonder what is up with the flash sync. I did not read it too closely last night but has anyone run into the issues he is having after the flash?
07-08-2009, 05:10 PM   #44
Senior Member
dnaseigel's Avatar

Join Date: Jan 2008
Location: Rockford, IL
Photos: Gallery
Posts: 179
QuoteQuote:
now about Gary's prob...hope he reads this about the AF noise sort of resetting itself. But I wonder what is up with the flash sync. I did not read it too closely last night but has anyone run into the issues he is having after the flash?
It sounds like Gary may have an issue with his particular camera which is a true bummer. I offer the motion that Pentax give him a K-7 as a replacement as he is going to be needing to do some heavy duty shooting here soon amongst a group of young, soon to be photgraphers. Wouldn't that be great thing to take into that sort of envrionment. If anyone wishes to second that motion even if it's just for moderating this forum, then we should send our collective opinion to Pentax.

...sort of got of topic here...sorry.

DS
07-08-2009, 05:28 PM   #45
Veteran Member




Join Date: Jun 2009
Photos: Albums
Posts: 1,679
works for me...he's been super cool with me...a swap seems more than fair!! The folks who man the boards really do a nice thing for the rest of us as they deal with all the HS on a daily basis.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, firmware, k20d, k20d firmware, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
k20d v1.04 firmware barn154 Pentax DSLR Discussion 4 08-21-2010 02:32 AM
K20D Firmware v1.04 nanhi Pentax DSLR Discussion 5 05-13-2010 08:17 AM
K20d firmware VincenTC Troubleshooting and Beginner Help 4 12-04-2009 12:46 AM
K20D v1.03 Firmware bobrapp Pentax News and Rumors 124 07-03-2009 01:18 AM
K20D Firmware 2.0? morfic Pentax DSLR Discussion 1 11-01-2008 02:37 PM



All times are GMT -7. The time now is 02:41 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top