Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-05-2009, 06:49 PM   #1
Junior Member
vincentgargano's Avatar

Join Date: May 2008
Location: florida
Photos: Gallery
Posts: 33
K20d Firmware 1.03 !!!!!!!!!

anyone having any problems with the 1.03 version...also pentax no longer has it in the firmware upgrade section for the 20d ...all there is is the 1.01 version...anyone know why? are there bugs in the 1.03?

p.s. just got a second k20d last week sending it back because it keeps locking up...i guess a few other people are having this problem

07-05-2009, 07:16 PM   #2
Veteran Member




Join Date: Jun 2009
Photos: Albums
Posts: 1,679
QuoteOriginally posted by vincentgargano Quote
anyone having any problems with the 1.03 version...also pentax no longer has it in the firmware upgrade section for the 20d ...all there is is the 1.01 version...anyone know why? are there bugs in the 1.03?

p.s. just got a second k20d last week sending it back because it keeps locking up...i guess a few other people are having this problem
awwww...crap...does this mean there is something buggy with v1.03? I have not found anything but I dunno now...maybe someone can sleuth out the details.

In the mean time, if you need a copy send my a PM with your email and I can send you a private link on one of my servers since your email server might not allow attachments this big. The file is ~7.4MB
07-05-2009, 07:18 PM   #3
Veteran Member




Join Date: Jun 2009
Photos: Albums
Posts: 1,679
Here are some bug links using google.

pentax k20d firmware 1.03 bug - Google Search

Here is a download link for the English version for v1.03
http://www.pentax.jp/english/support/digital/k20d_s.html
07-05-2009, 09:22 PM   #4
Veteran Member
Venturi's Avatar

Join Date: Mar 2008
Location: Tulsa, OK
Photos: Gallery
Posts: 2,639
I'm unaware of any bugs introduced by v1.03. I've been running it since I bought my K20D last June and I have made over 10,000 exposures since.

07-05-2009, 09:27 PM   #5
Veteran Member
FotoPete's Avatar

Join Date: Feb 2007
Location: Toronto
Photos: Gallery
Posts: 1,710
My K20D (new over eekbay) came with 1.03 already loaded. Not problems yet.
07-05-2009, 09:28 PM   #6
Veteran Member




Join Date: Jun 2009
Photos: Albums
Posts: 1,679
that's kinda what I had found...no real bugs were talked about so far. Weird they would pull it from the US site. Though, I have run across such things with drivers of other devices.

At least there is still the Pentax Japan download for the new version.
07-05-2009, 10:53 PM   #7
Veteran Member
enoxatnep's Avatar

Join Date: Nov 2008
Location: The edge of nowhere, Alberta, Canada
Photos: Gallery | Albums
Posts: 467
No problems with 1.03 for me.
07-07-2009, 10:31 PM   #8
Damn Brit
Guest




I realised this evening that when attempting to use the onboard flash;
a) There was no focus assist light.
b) I could not get a picture. It seems as if the flash is not synching.

Now if there truly is a problem, it pisses me off that Pentax doesn't have the balls to come out and admit it.

07-07-2009, 10:49 PM   #9
Veteran Member




Join Date: Jun 2009
Photos: Albums
Posts: 1,679
QuoteOriginally posted by Damn Brit Quote
I realised this evening that when attempting to use the onboard flash;
a) There was no focus assist light.
b) I could not get a picture. It seems as if the flash is not synching.

Now if there truly is a problem, it pisses me off that Pentax doesn't have the balls to come out and admit it.
Gary,

Dang it...I just tested mine and yup not flash assist at all...in total darkness. It was working the other day. I was not paying attention since the update.

Anyone game for reflashing back to v1.01?
07-07-2009, 10:57 PM   #10
Veteran Member




Join Date: Mar 2009
Location: Midwest
Photos: Gallery
Posts: 1,407
I can add my voice to the song... No flash focus assist with 1.03. Although the IR assist on my Metz flash still works fine.
07-07-2009, 11:11 PM   #11
Veteran Member




Join Date: Jun 2009
Photos: Albums
Posts: 1,679
Well, I flashed back to v1.01 and still no flash focus assist. Something got smoked by v1.03 it seems. Oh, joy.
07-07-2009, 11:14 PM   #12
Damn Brit
Guest




QuoteOriginally posted by brecklundin Quote
Well, I flashed back to v1.01 and still no flash focus assist. Something got smoked by v1.03 it seems. Oh, joy.
Were you at least able to get a visible picture? I just get black.

I also noticed the camera making a not very nice noise while using Live View. I'm pretty sure it didn't before the firmware upgrade.
07-07-2009, 11:14 PM   #13
Forum Member
ohfrankyboy's Avatar

Join Date: Feb 2009
Location: Quebec, Canada
Posts: 71
The only problem I see is it would be great for the K20D to have another firmware update
07-07-2009, 11:15 PM   #14
Veteran Member




Join Date: Jun 2009
Photos: Albums
Posts: 1,679
ummmm...guys:

https://www.pentaxforums.com/forums/pentax-dslr-discussion/58545-k20d-firmwar...360-flash.html

Dated in freaking April...
07-07-2009, 11:16 PM   #15
Veteran Member




Join Date: Jun 2009
Photos: Albums
Posts: 1,679
QuoteOriginally posted by Damn Brit Quote
Were you at least able to get a visible picture? I just get black.

I also noticed the camera making a not very nice noise while using Live View. I'm pretty sure it didn't before the firmware upgrade.
awwww...crappola...
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, firmware, k20d, k20d firmware, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
k20d v1.04 firmware barn154 Pentax DSLR Discussion 4 08-21-2010 02:32 AM
K20D Firmware v1.04 nanhi Pentax DSLR Discussion 5 05-13-2010 08:17 AM
K20d firmware VincenTC Troubleshooting and Beginner Help 4 12-04-2009 12:46 AM
K20D v1.03 Firmware bobrapp Pentax News and Rumors 124 07-03-2009 01:18 AM
K20D Firmware 2.0? morfic Pentax DSLR Discussion 1 11-01-2008 02:37 PM



All times are GMT -7. The time now is 03:43 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top