Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-30-2009, 02:46 PM   #1
New Member




Join Date: Jul 2009
Location: Long Island, NY
Posts: 2
Pentax K100D Powers down immediately

I have a Pentax K100D that I have been shooting with for years. Last night, I put new batteries into, powered it up. The battery full symbol goes on along with the '----" and them immediately shuts down. I tried several different sets of batteries.

Any clue as to what might be going on?

Thanks in advance

Paul

07-30-2009, 07:59 PM   #2
Veteran Member




Join Date: Jun 2009
Location: Bridgetown West Australia
Photos: Gallery | Albums
Posts: 881
Are you talking about rechargable batteries? If so I had the same thing happen with my K100..it is a common problem...something to do with voltage (all beyond me) but what happens is the camera refuses to reconize that the batteries are charged. It happebed to mine after a year or more of use. Solution? I switched to lithium and one set lasted for 12 months.
07-30-2009, 08:04 PM   #3
Veteran Member
code4code5's Avatar

Join Date: Oct 2007
Location: Denver, CO
Photos: Gallery
Posts: 438
QuoteOriginally posted by ozlizard Quote
Are you talking about rechargable batteries? If so I had the same thing happen with my K100..it is a common problem...something to do with voltage (all beyond me) but what happens is the camera refuses to reconize that the batteries are charged. It happebed to mine after a year or more of use. Solution? I switched to lithium and one set lasted for 12 months.
I can second a recommendation for Energizer E2 lithium batteries. They seem to last forever in a K100d body and are more versitile for use in extreme cold. (Although, not much of an issue in July.)
07-30-2009, 10:38 PM   #4
Ash
Community Manager
Loyal Site Supporter
Ash's Avatar

Join Date: Mar 2007
Location: Toowoomba, Queensland
Photos: Gallery | Albums
Posts: 22,695
By 'new' batteries, what type do you mean?
If rechargeables, I wouldn't go for cheap brands as they run out of juics-carrying ability real quick - and the K100D is *really* power-hungry.
If you use once-only batteries, I second the high-powered lithium batteries suggestion like the E2s.

07-31-2009, 01:34 PM   #5
New Member




Join Date: Jul 2009
Location: Long Island, NY
Posts: 2
Original Poster
I am using E2 batteries

I am using the Energizer E2 lithium batteries.

I have purchased 2 different sets at different stores, same thing happens

Any other ideas?
07-31-2009, 05:22 PM   #6
Veteran Member




Join Date: Nov 2008
Location: New York, NY
Posts: 387
Try different SD card? Make sure the SD card slot door is closed?

I had a similiar problem when I was playing around with the SD card door open...maybe this relates to your problem?
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
batteries, camera, dslr, k100d, pentax, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to stop Dust alert. Please help immediately. sashe3320 Pentax DSLR Discussion 4 10-29-2010 10:46 PM
K-7 starts then immediately turns off wjax Pentax DSLR Discussion 9 09-19-2010 03:47 PM
Flash firing immediately on "2s delay" drive mode oguzgel Pentax DSLR Discussion 5 03-30-2008 01:20 PM



All times are GMT -7. The time now is 03:44 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top