Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-30-2009, 11:35 PM   #1
Loyal Site Supporter
SteveM's Avatar

Join Date: Jan 2009
Location: Vancouver Island, BC, Canada
Photos: Gallery
Posts: 3,295
God help me!!....I'm at my wits end :(

I bought a K-7 and have tried everything....shooting movie mode....rapid shots....manual mode....everything...and it still hasn't screwed up. I'm not sure what I am doing wrong....I thought I could drop it...but that might leaves some kind of ugly mark. I tried shaking the crap out of it and banging it against a pillow..using my car battery...lending it to Mabel...but it still won't show me any lines in my pics...split screen image......anything!

Crap...what am I doing wrong!

07-30-2009, 11:41 PM   #2
Veteran Member
GLXLR's Avatar

Join Date: Feb 2009
Location: Sugar Land, TX
Photos: Gallery
Posts: 686
QuoteOriginally posted by smc Quote
I bought a K-7 and have tried everything....shooting movie mode....rapid shots....manual mode....everything...and it still hasn't screwed up. I'm not sure what I am doing wrong....I thought I could drop it...but that might leaves some kind of ugly mark. I tried shaking the crap out of it and banging it against a pillow..using my car battery...lending it to Mabel...but it still won't show me any lines in my pics...split screen image......anything!

Crap...what am I doing wrong!
LOLOLOL!!!
i think the line is just a select few of individuals, although you should stop banging it for your sake
07-30-2009, 11:49 PM   #3
Igilligan
Guest




Mocking those who have issues...

Just never reads well to me.

I had an known issue with a pentax camera, and to have other folks in the forums taunting because they lucked and got a good copy... well it did not feel good and actually seemed downright mean.

There are quite a few green line issues popping up. And even more sensor temp issues being reported...
Be happy you got a good one. As with any complicated electronic gizmo, you should count yourself lucky. No need to dance quite yet.
07-30-2009, 11:52 PM   #4
Loyal Site Supporter
SteveM's Avatar

Join Date: Jan 2009
Location: Vancouver Island, BC, Canada
Photos: Gallery
Posts: 3,295
Original Poster
QuoteOriginally posted by GLXLR Quote
LOLOLOL!!!
i think the line is just a select few of individuals, although you should stop banging it for your sake
It's in the back room now...and I hear noises......I peeked in and I swear...the flash was up...and it wasn't when I put it there....and worse yet...I think it was pointed BACKWARDS.......straight at me!!!!!

07-30-2009, 11:53 PM   #5
Veteran Member




Join Date: Sep 2006
Photos: Gallery
Posts: 5,713
QuoteOriginally posted by smc Quote
I bought a K-7 and have tried everything....shooting movie mode....rapid shots....manual mode....everything...and it still hasn't screwed up. I'm not sure what I am doing wrong....I thought I could drop it...but that might leaves some kind of ugly mark. I tried shaking the crap out of it and banging it against a pillow..using my car battery...lending it to Mabel...but it still won't show me any lines in my pics...split screen image......anything!

Crap...what am I doing wrong!
I've heard that the K7 makes an incredible Underwater camera, as long as you leave the lens off. Have you tried that yet
Rumor has it that Salt Water, or Muddy Water works best.
07-30-2009, 11:54 PM   #6
Veteran Member
nostatic's Avatar

Join Date: Feb 2008
Location: socal
Photos: Gallery
Posts: 1,576
QuoteOriginally posted by Igilligan Quote
No need to dance quite yet.
Even if he lets you lead? Come on Gus...just take a few more pain killers and trip the light fantastic. It'll be good for you.

SPeaking of that my ambien is kicking in. I better to sleep. Last time I took ambien I managed to calculate purchase price and tax on a lens and adapter from Cameraquest and sent him paypal. I remembered none of it when I woke up. Only knew when I saw the email response from Steve saying he was shipping it. Doh!
07-30-2009, 11:57 PM   #7
Loyal Site Supporter
SteveM's Avatar

Join Date: Jan 2009
Location: Vancouver Island, BC, Canada
Photos: Gallery
Posts: 3,295
Original Poster
QuoteOriginally posted by Igilligan Quote
Just never reads well to me.

I had an known issue with a pentax camera, and to have other folks in the forums taunting because they lucked and got a good copy... well it did not feel good and actually seemed downright mean.

There are quite a few green line issues popping up. And even more sensor temp issues being reported...
Be happy you got a good one. As with any complicated electronic gizmo, you should count yourself lucky. No need to dance quite yet.
Good point...I might not be out of the woods yet....and I don't mean any disrespect to those that have the hassle....I know some of the issues are true. I can't help but have a bit of fun to put things in perspective. I stayed away from the k20d because it was crap.....until I heard later (and found out for myself) that it wasn't.
07-31-2009, 12:22 AM   #8
Veteran Member
nulla's Avatar

Join Date: Jul 2008
Location: Melbourne Australia
Posts: 1,560
QuoteOriginally posted by smc Quote
Good point...I might not be out of the woods yet....and I don't mean any disrespect to those that have the hassle....I know some of the issues are true. I can't help but have a bit of fun to put things in perspective. I stayed away from the k20d because it was crap.....until I heard later (and found out for myself) that it wasn't.
You are correct in what you say about hearing the K20 was crap.

I think the same goes for all new models in all ranges of items... not just Pentax and not just cameras.

One small fault found and those who are either jealous, envious etc, for one reason or another be it lack of funds or whatever start a scare monger campaign.

I've been a micrsoft user since DOS and can state that with every new version once launched it has been doomed as a failure, yet I have found each to be great ..and far better then each earlier version ..but each not without its faults

We do not live in a faultless world.... these objects we choose to gather are after all man made.

Neil

07-31-2009, 12:32 AM   #9
Veteran Member




Join Date: Dec 2007
Posts: 923
Someone started a thread in another forum for satisfied K-7 users ....and rest assured, there are plenty of them, yours truly included.

I respect those who have brought up problems they encountered. The green line, after video usage, is without doubt an issue with a significant number of users, and Pentax really needs to find a fix.

Most of the other complaints, I think, are random initial build-quality issues (Canon and Nikon have plenty, too) which can be resolved through warranty fixes or exchange.

Some other matters are just a matter of personal preference, like the size of the body.
One major improvement (to me) is the K-7 is its brighter exposure, especially with P-TTL flash. Some users dislike it but I remember many other users had heavily thrashed the K20D/K10D's tendency to underexpose flash shots.....well, you can't please everyone.

The K-7 itself works like a dream, especially after the new firmware fix.
07-31-2009, 01:38 AM   #10
Ash
Community Manager
Loyal Site Supporter
Ash's Avatar

Join Date: Mar 2007
Location: Toowoomba, Queensland
Photos: Gallery | Albums
Posts: 22,695
Look for a 'fault' and statistics says you're bound to find one in the not too distant future.
Does it take shots the way it's expected to?
If so, just go out and shoot!
07-31-2009, 02:36 AM   #11
Site Supporter
Mallee Boy's Avatar

Join Date: Sep 2006
Location: Hindmarsh Isl. Sth Australia
Photos: Gallery | Albums
Posts: 3,490
What!!!

you've let Mabel use it!! Jeez mate!.....not Mabel. ...keep banging it (err thats the K7) on the pillow....


think I'd probably better go now...
07-31-2009, 02:39 AM   #12
Veteran Member
schmik's Avatar

Join Date: May 2008
Location: Sydney Aus
Photos: Gallery
Posts: 527
I too have tried and tried to fault my k7..... but haven't been able too.

Having said that I am actively testing mine for the green line issue because it is temperature related. Once the aussie summer starts mine will be out in 35deg C weather using movie and still modes. Temperature related issues scare me. If i was in the UK or most of europe..... no worries mate!

But karma is bitch..... don't laugh too hard.

mike
07-31-2009, 03:52 AM   #13
Forum Member
davidt's Avatar

Join Date: Apr 2009
Location: Vienna
Posts: 50
QuoteOriginally posted by smc Quote
I bought a K-7 and have tried everything....shooting movie mode....rapid shots....manual mode....everything...and it still hasn't screwed up. I'm not sure what I am doing wrong....I thought I could drop it...but that might leaves some kind of ugly mark. I tried shaking the crap out of it and banging it against a pillow..using my car battery...lending it to Mabel...but it still won't show me any lines in my pics...split screen image......anything!

Crap...what am I doing wrong!
Great to hear! But at least you got the temp warning sign? What was the highest temperature you shot a photo with? And how does you serial# start? Proably I'll try to get one from this batch...
07-31-2009, 03:57 AM   #14
Forum Member
snogglethorpe's Avatar

Join Date: Jul 2009
Location: Tokyo, Japan
Posts: 71
QuoteOriginally posted by schmik Quote
Having said that I am actively testing mine for the green line issue because it is temperature related. Once the aussie summer starts mine will be out in 35deg C weather using movie and still modes. Temperature related issues scare me.
Perhaps you'll get lucky and discover the "camera melting" issue instead!
07-31-2009, 06:13 AM   #15
Site Supporter




Join Date: Mar 2009
Location: Gladys, Virginia
Photos: Gallery
Posts: 16,247
Very funny. That said, I have to give a word of appreciation to those early adopters. There are always some issues that need to be worked out with new technology and those who buy them for full price and complain about them are the ones who make certain that those of us who come along later will be better satisfied.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
a discussion on god... god i was bored.. Gooshin General Talk 9 02-11-2010 01:01 PM
YES!!! There is a god! ve2vfd General Talk 1 02-24-2009 10:07 PM
God is good! bonovox Post Your Photos! 41 01-23-2009 05:14 PM
In God we U.S.A. WT Igilligan Post Your Photos! 6 11-07-2008 08:36 PM
Oh My God Christian Pentax DSLR Discussion 28 05-07-2007 03:44 AM



All times are GMT -7. The time now is 07:17 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top