Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-05-2009, 08:13 AM   #1
Veteran Member
MJB DIGITAL's Avatar

Join Date: Jul 2007
Location: st. louis
Posts: 1,173
How're the K7 bugs coming along

I know that with new releases, every DSLR has bugs that need to be worked out. An opportunity arises for me to have 2 K7s much earlier than I expected.

So how are they coming along. What are the current bugs? What have they worked out. For the newsguys out there, what bugs are out there that WILL be fixed soon.

Thanks.

Mitch

08-05-2009, 10:25 AM   #2
Veteran Member




Join Date: Nov 2006
Location: Norway
Photos: Gallery
Posts: 385
QuoteOriginally posted by MJB DIGITAL Quote
So how are they coming along. What are the current bugs? What have they worked out. For the newsguys out there, what bugs are out there that WILL be fixed soon.
They have fixed a bug regarding autofocus using the leftmost AF sensor and not able to readjust white balance and image parameter on pictures already taken when dist. correction or chr. ab. corr. was on.

They have not fixed problems with hypertv when autoiso is on and there is some problems with wireless and HS sync flash.


Lot of users are complaining about the electronic level and horizon correction not being very accurate. Mine is also wrong. All pictures are tilted when automatic horizon correction is on. They should allow for calibration of this feature in firmware.
08-05-2009, 10:35 AM   #3
Veteran Member
MJB DIGITAL's Avatar

Join Date: Jul 2007
Location: st. louis
Posts: 1,173
Original Poster
wow auto horizon correction? i didnt even know that existed in the cam. cool feature, once it is working right.

question:

when your horizons are tilted due to the auto horizon correction, are they all tilted the same?

I'm thinking, if I do get my K7s at this early stage, what if I take a set of photos into lightroom, straighten the horizon on one photo, then synch the crop to all of the other photos. would that be my time saver here?

on a wedding, i ALWAYS straighten all of the horizons. even if there is a bump, maybe I can still use the feature to save time in editing.

Thanks for the input
08-05-2009, 12:26 PM   #4
Veteran Member
nostatic's Avatar

Join Date: Feb 2008
Location: socal
Photos: Gallery
Posts: 1,576
They already have one firmware update released. Only Pentax knows what other bugs/ features are on the timeline.

08-06-2009, 08:25 AM   #5
Site Supporter
opiedog's Avatar

Join Date: Jan 2008
Location: NC
Posts: 787
not a bug, but a feature was added in firmware 1.01 to allow an alternate way of selecting the focus point.
08-06-2009, 09:26 AM   #6
Veteran Member




Join Date: Dec 2007
Posts: 923
QuoteOriginally posted by MJB DIGITAL Quote
wow auto horizon correction? i didnt even know that existed in the cam. cool feature, once it is working right.

question:

Thanks for the input
The auto horizon correction on my K-7 is 100% spot on - I tested it against a friend's laser leveller ( he's in the construction industry and its basically a high-tech equivalent of the old spirit bubble level).

Its weird - I had almost "never" been able to get perfectly level shots handheld, but here I'm getting it nearly 100% of the time on the K-7.....love this feature.

It could be there are some units out there with tilted sensors, relative to the body; its not a new story with Pentax. In a case like that the tilt should be consistent from shot to shot, its not a fault with the horizon correction feature in itself.
08-06-2009, 10:36 AM   #7
Veteran Member
Miserere's Avatar

Join Date: Sep 2007
Location: Boston
Photos: Gallery
Posts: 1,994
I've read many people have messed-up levels. And from what I hear, the level is consitent with the sensor, not the body. Some people have levels that work correctly (horizons are level when the level says so), but are misaligned with the body.
08-06-2009, 10:58 AM   #8
Veteran Member




Join Date: Jun 2009
Photos: Albums
Posts: 1,679
everyone seems to forget THE RULE of coding.... "if it does in randomly, it is a bug....if it does it everytime, it's a feature..." so, are there really any true firmware bugs? I think not!!



08-06-2009, 11:18 AM   #9
Veteran Member
ManuH's Avatar

Join Date: Dec 2007
Location: Montreal
Photos: Gallery | Albums
Posts: 1,209
QuoteOriginally posted by StigVidar Quote
Lot of users are complaining about the electronic level and horizon correction not being very accurate. Mine is also wrong. All pictures are tilted when automatic horizon correction is on. They should allow for calibration of this feature in firmware.
Mine is not working either so I disabled it (all pictures were leaning slightly to the right). A calibration would be great because I don't want to send to repair my K-7 just for that.

I don't know if the slow fps in AF-C can be counted as bug but I find it a bit bothering.

I also had some little display glitches, but that appeared only 2 times and fixed by on/off. And a complete lock up one time, but I think it was due to the grip I just installed. This after 6000 shots... I didn't see the green line but then I don't use Liveview or video very intensively.
08-06-2009, 12:33 PM   #10
Veteran Member
jeffkrol's Avatar

Join Date: Sep 2006
Location: Wisconsin USA
Photos: Gallery
Posts: 8,434
QuoteOriginally posted by ManuH Quote
Mine is not working either so I disabled it (all pictures were leaning slightly to the right). A calibration would be great because I don't want to send to repair my K-7 just for that.
Curious to know how people are testing this.. seems AS would also effect horizons.
On a tripod ?
08-06-2009, 02:40 PM   #11
Veteran Member
MJB DIGITAL's Avatar

Join Date: Jul 2007
Location: st. louis
Posts: 1,173
Original Poster
I'm glad for the input on this one, guys.
08-06-2009, 03:18 PM   #12
Veteran Member
Torphoto's Avatar

Join Date: Mar 2008
Location: Trinidad W.I.
Photos: Gallery
Posts: 620
I think there are 2 things going on with the auto horizon thing,

1. from my limited use of the k7 is that the sensor aligns with the built in level meter, not the actual horizion, meaning it wil auto level itself to level the sensor level to the ground your standing on, if your on a slope it will level itself well BUT the horizon may not be level now will it?

2. it works with the sr system and the sr system sometimes needs to spool up, meaning you can take crocked pics if it hasn't spooled up yet.
08-06-2009, 03:25 PM   #13
Pentaxian
Class A's Avatar

Join Date: Aug 2008
Location: Wellington, New Zealand
Posts: 8,934
QuoteOriginally posted by StigVidar Quote
They have not fixed problems with hypertv when autoiso is on and there is some problems with wireless and HS sync flash.
I haven't heard about these bugs. What are they about?
The K20D had a "Hyper-Program + Auto ISO" bug which has been fixed for the K-7.

QuoteOriginally posted by ManuH Quote
A calibration would be great because I don't want to send to repair my K-7 just for that.
Wow, I'd send it in in a heartbeat. I wouldn't be able to shrug off the fact that such a cool and useful feature is not working.

BTW, Pentax is aware of the "green line" problem that appears with some copies and is working on a solution.

Hopefully they'll keep the firmware updates coming and will include a "manual" option for controlling the light of the top LCD.
08-06-2009, 03:42 PM   #14
Pentaxian
Transit's Avatar

Join Date: Aug 2007
Location: Whanganui NZ
Photos: Gallery | Albums
Posts: 3,873
QuoteOriginally posted by Class A Quote

Wow, I'd send it in in a heartbeat. I wouldn't be able to shrug off the fact that such a cool and useful feature is not working.
8 weeks in service
08-06-2009, 03:58 PM   #15
Forum Member




Join Date: Feb 2009
Location: Brisbane Australia
Photos: Gallery
Posts: 82
I cannot find fault with my K-7. Everything works as it should.
The more time I spend with the camera, the better it gets!
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
bugs, camera, dslr, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Macro Two bugs Rense Post Your Photos! 12 08-14-2010 11:54 AM
Macro Bugs eating bugs serie suzuki-j Post Your Photos! 8 06-22-2010 02:09 PM
Macro Bugs n such LiveNLearn Post Your Photos! 2 03-24-2010 02:04 AM
Misc It's been a while... some bugs flippedgazelle Post Your Photos! 10 09-28-2009 10:33 PM
Those bugs.. dantuyhoa Post Your Photos! 3 08-12-2007 06:58 AM



All times are GMT -7. The time now is 01:25 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top