Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-11-2009, 06:19 AM   #1
Junior Member
seliscan's Avatar

Join Date: Aug 2009
Posts: 31
Need help in a problem betwen a Samsung GX-20 and a Sigma 17-70

Hy,

I have the next problem and I'm searching for help from persons who know the problem or have experience it themselves...

I bought 2 months ago a Samsung GX-20 with a kit lens and few days ago I managed to spare fond for a Sigma 17-70 f/2,8-4,5

(witch is a superb less for Pentax users).

The problem is that the Sigma has a huge front focus on my Camera, and it could not be resolved even with a -10

calibration from the menu.

I reported this problem to the Sigma-Pentax representation in Bucharest (county Romania) and they asked to send them the

camera + objective to see if it can be resolved. After a day, they called me and sad that the lens is perfectly fine and

worked perfectly on two other Pentax cameras and asked my if I had the same problem with my kit lens, and I said no. The

answer was that must be an incompatibility form my Samsung Camera and Sigma lens and I must ask for advice to Samsung.ro

. I did that but the guy there was overwhelmed by the problem and sad that he can not help me - how ironical...

So what is there to be done is this situation, the guys from Pentax-Sigma Bucharest have a program for Penatx camera

calibration in conjunction with Sigma Lenses but they did not knew if it's compatible with Samsung, and did not want to

risk.

Has anyone knowledge of how can I resolve the problem? I who'd be very thankful...

08-11-2009, 07:25 AM   #2
Senior Member




Join Date: Apr 2008
Location: North Wales
Posts: 222
I thought that you needed to go + rather than - for front focusing (e.g. +10)? I guess you tried it both ways though and confirmed it didn't work? The manual isn't very clear?

Anyway, I have the same setup, GX20 and Sigma 17-70mm and can confirm there are no compatibility issues with them. I did update the GX20 to firmware 1.01 before I took any pictures with it so it's possible that fixed something?

The first thing you need to prove is whether the problem is with your camera or lens. If they tested the lens with other Pentax cameras (which presumably they know are ok) then that would suggest the problem is with your GX20. Just because your kit lens works ok with it doesn't prove anything - that may be faulty as well. Do you have a third lens you can test the camera with?

Sorry I can't be anymore help but there are plenty of camera nerds on here so you should get a good answer soon
08-11-2009, 07:30 AM   #3
Pentaxian
Moderator Emeritus




Join Date: May 2007
Location: Edmonton Alberta, Canada
Photos: Gallery | Albums
Posts: 10,648
If the lens is quite new and came from a store, why not return it for a new one. It's possible that there is an element that is mis aligned and no amount of adjusting would fix that.
08-11-2009, 08:16 AM   #4
Junior Member
seliscan's Avatar

Join Date: Aug 2009
Posts: 31
Original Poster
Thank you woodworm for the answer, I think that the camera may be faulty and I should send it back, but the problem is that the guys won't change the faulty camera if it works OK with the kit lens, they will just wash their hands because I bought the camera from another store than the lens.

The -10 i the settings moves the focus further from the subject, and does exactly what I needed but that wasn't enough (I used a calibration paper and tested all the possibilities), and I still have the front focus.


Last edited by seliscan; 08-11-2009 at 08:25 AM.
08-11-2009, 08:51 PM   #5
Pentaxian
LeDave's Avatar

Join Date: Jun 2009
Location: Minneapolis - St. Paul
Photos: Gallery
Posts: 2,895
Wow, even if it works with the kit lens, it doesn't change the fact that they sold you a defective camera.
08-11-2009, 11:09 PM   #6
Site Supporter




Join Date: Jul 2008
Location: Detroit MI, USA
Posts: 502
Sigma USA did the same to me when I sent it in for the second time, the asked me to send in my GX10 and told me one day latter that the lens worked perfect with two Pentax K10Ds. I posted it here about one year ago. Anyways I fought them hard and they said the would send mine back, but they send a new one to me that did not have the problem. The Samsungs and Pentax are the same. Its hard to know for sure who is telling the truth, or what is wrong. I would demand a replacement and or send it you Samsung to be checked.
08-11-2009, 11:21 PM   #7
Damn Brit
Guest




Can you post a couple of examples for people to look at?
Also include what settings you were using.
You never know, it might be something simple that you have or haven't done.
08-12-2009, 04:34 AM   #8
Junior Member
seliscan's Avatar

Join Date: Aug 2009
Posts: 31
Original Poster
Today I received a message that after trying multiple prime lenses on my camera, they discovered that they worked also perfectly. So they've start calibrating the lens step by step and discovered that worked god at -6 only (very interesting because - 10 was not enough and a slit modification was resulting in major error; for example -5 or - 7)...

In the end they told package is on his way home and the system is working god; I hope they were right...

Another interesting fact is that I had a macro distance of only 1 cm instead of 20 (which was mentions on the lens) when I was trying to photograph Jules.

.....

I'm puzzled, is it that hard to make something work properly from the beginning, or what? They should be ashamed that such problems exist at all and at least they can change the product immediately without so many cheep excuses...At least the guys from Pentax-Sigma were very polite and don their best, I can't tell the same thing about our Samsung representatives witch are INCOMPETENTS and wash their hands immediately!
......

Thank you for all the answers, in the end the guys from Pentax-Sigma representatives solved the problem .


Last edited by seliscan; 08-13-2009 at 04:11 AM.
11-18-2009, 06:58 PM   #9
Veteran Member
theperception2008's Avatar

Join Date: Aug 2009
Location: Łódź, Poland and Riverside, California, U.S.A
Photos: Gallery | Albums
Posts: 488
QuoteOriginally posted by seliscan Quote
Today I received a message that after trying multiple prime lenses on my camera, they discovered that they worked also perfectly. So they've start calibrating the lens step by step and discovered that worked god at -6 only (very interesting because - 10 was not enough and a slit modification was resulting in major error; for example -5 or - 7)...

In the end they told package is on his way home and the system is working god; I hope they were right...

Another interesting fact is that I had a macro distance of only 1 cm instead of 20 (which was mentions on the lens) when I was trying to photograph Jules.

.....

I'm puzzled, is it that hard to make something work properly from the beginning, or what? They should be ashamed that such problems exist at all and at least they can change the product immediately without so many cheep excuses...At least the guys from Pentax-Sigma were very polite and don their best, I can't tell the same thing about our Samsung representatives witch are INCOMPETENTS and wash their hands immediately!
......

Thank you for all the answers, in the end the guys from Pentax-Sigma representatives solved the problem .
It seems that anytime you buy a third party lens, they have some focusing problems as a result of different cameras with different tolerances. I will most likely send in my tamron and gx-20 to get calibrated so they can work in unison :-)
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
bucharest, camera, dslr, gx-20, kit, lens, pentax, photography, samsung, samsung gx-20, sigma
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sigma 70-250 1:3.5-4.5 KA mount lens on Samsung GX20 DasModell Pentax SLR Lens Discussion 1 08-18-2009 12:19 PM
[Ask suggestion] betwen FA 50 f/2.8 with M 50 f/1.7 Aufa Pentax SLR Lens Discussion 4 03-10-2009 11:23 AM
Samsung GX-1S Firmware Update Problem Tim4Peace Pentax DSLR Discussion 1 04-03-2008 03:32 PM
For Sale - Sold: FS: Samsung GX10, Sigma 50-500mm (Bigma), Sigma 400mm AF chirpy Sold Items 4 03-24-2008 11:07 AM



All times are GMT -7. The time now is 09:30 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top