Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-13-2009, 08:25 PM   #1
New Member




Join Date: Feb 2009
Location: Toronto, Canada
Posts: 8
Nugging problem with K-20

I just got my K20 and found something weird - every time I turn the camera on it opens the language/time set up menu (although I set those up already). I thought it was some sort of a software bug even after I upgraded the version to 1.3 the problem persists. It is my second K20 and it never happened with my first one. Any ideas/tips how to get rid of this annoying menu?
Thanks,

08-13-2009, 08:50 PM   #2
New Member




Join Date: Jul 2009
Posts: 6
that is weird. Have you tried resetting it?
08-13-2009, 10:46 PM   #3
Ash
Community Manager
Loyal Site Supporter
Ash's Avatar

Join Date: Mar 2007
Location: Toowoomba, Queensland
Photos: Gallery | Albums
Posts: 22,679
Haven't heard this before.
There is an internal battery that keeps the date, time and language details.
Perhaps it's flat and needs replacing.
If so, I'd get your local repair store to do it for you.
But this is just a guess.
Hard to know unless someone skilled is able to look at it more closely.
08-14-2009, 12:16 AM   #4
Site Supporter
Mallee Boy's Avatar

Join Date: Sep 2006
Location: Hindmarsh Isl. Sth Australia
Photos: Gallery | Albums
Posts: 3,485

very strange.

The good book does talk about the menu coming back on if something in the initial set up is not done properly. Have a read starting at page 45.
Cheers

08-14-2009, 05:37 AM   #5
Senior Member




Join Date: May 2009
Location: Atlanta
Posts: 110
I had the same thing happen with my old istDs2. Don't know what the problem was, but I went back through the setup menu and the problem seems to be fixed. I was also having a problem with a defective Tamron lens screwing up my camera's electronics. The display wouldn't stay on long enough to change settings. I thought the camera's electronics were going bad, but found it to be the lens, instead.
08-14-2009, 05:51 AM   #6
New Member




Join Date: Feb 2009
Location: Toronto, Canada
Posts: 8
Original Poster
Thanks Guys.
08-14-2009, 07:44 AM   #7
Ash
Community Manager
Loyal Site Supporter
Ash's Avatar

Join Date: Mar 2007
Location: Toowoomba, Queensland
Photos: Gallery | Albums
Posts: 22,679
Did you manage to fix the problem?
How did it go?
08-14-2009, 01:52 PM   #8
Site Supporter
Mallee Boy's Avatar

Join Date: Sep 2006
Location: Hindmarsh Isl. Sth Australia
Photos: Gallery | Albums
Posts: 3,485
QuoteOriginally posted by audio_mad Quote
Thanks Guys.
How have you got on? Any solutions?

08-15-2009, 08:18 AM   #9
New Member




Join Date: Feb 2009
Location: Toronto, Canada
Posts: 8
Original Poster
I went thru the initial set up al leat 5-6 times and somehow it went away...Still weird...No solution to report, pure luck here. It could have stayed the same way too...
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, k20, menu, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
MZ-7 (ZX-7) Problem Hello_Photo Pentax Film SLR Discussion 13 03-23-2015 07:32 AM
K-5 battery problem? camera problem? user problem? imtheguy Pentax K-5 39 11-03-2010 06:02 PM
Card read problem K20d. Have you had this problem? rsi1986 Pentax DSLR Discussion 8 12-27-2008 05:25 AM
What was the problem here? straightshooter Pentax Film SLR Discussion 15 09-15-2008 02:46 PM
this may be a problem nathancombs Pentax DSLR Discussion 24 02-02-2008 10:39 PM



All times are GMT -7. The time now is 08:47 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top