Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-26-2009, 06:42 PM   #1
Inactive Account




Join Date: Aug 2009
Location: Orlando, FL
Posts: 2
K100D stuck in Tv mode

Anyone seen this before? I turn on my camera, press the shutter, and nothing happens. The flash will pop up but there's no auto focus or shutter release. The top display says I'm in Tv mode and will not change regardless what setting I choose on the mode dial. I've updated the firmware. Does this sound like an expensive repair? A local camera repair shop felt it could need a new processor, at least $225, but couldn't do anything because he said all Pentax repairs have been tasked to C.R.I.S. in Arizona.

08-26-2009, 07:17 PM   #2
Ash
Community Manager
Loyal Site Supporter
Ash's Avatar

Join Date: Mar 2007
Location: Toowoomba, Queensland
Photos: Gallery | Albums
Posts: 22,695
Firstly, welcome here.
Sorry that you're first post is a problem with your cam.
Can't really help you with that one.
In the off chance that tipping out all the batteries for about an hour and reinserting them back in might 'reset' the malfunction back to normal, you may be able to salvage it. Do you have a lens mounted on properly?

Hope it works out for you.
08-26-2009, 07:19 PM   #3
Veteran Member




Join Date: Dec 2007
Posts: 923
A couple of questions
a. Try turning it off, removing the batteries, putting it back (make sure its fully charged), turn it back on.
b. Does the camera function if you switch to Manual Focus ?
c. Have you tried another lens ?
d. I gather the camera was functioning normally before this - anything unusual happened before this issue cropped up ?
08-26-2009, 09:04 PM   #4
Veteran Member
GLXLR's Avatar

Join Date: Feb 2009
Location: Sugar Land, TX
Photos: Gallery
Posts: 686
QuoteOriginally posted by ToddM Quote
Anyone seen this before? I turn on my camera, press the shutter, and nothing happens. The flash will pop up but there's no auto focus or shutter release. The top display says I'm in Tv mode and will not change regardless what setting I choose on the mode dial. I've updated the firmware. Does this sound like an expensive repair? A local camera repair shop felt it could need a new processor, at least $225, but couldn't do anything because he said all Pentax repairs have been tasked to C.R.I.S. in Arizona.
You can get CRIS get an ACCURATE estimate for you, and if it is $100 or less I would say go for it. If it really $225, you could get a K100D for around the same price on the marketplace.

08-27-2009, 05:30 PM   #5
Inactive Account




Join Date: Aug 2009
Location: Orlando, FL
Posts: 2
Original Poster
Tried it.

I've replaced the batteries with known fully charged ones and tried my other lens, a Tamron 70-300, without success. Ignoring the focus I can't get the shutter to release at all. It was working perfectly until it suddenly wouldn't do anything. I updated the firmware before this happened but took pictures since with no problems.
08-27-2009, 07:19 PM   #6
Veteran Member




Join Date: Dec 2007
Posts: 923
QuoteOriginally posted by ToddM Quote
I've replaced the batteries with known fully charged ones and tried my other lens, a Tamron 70-300, without success. Ignoring the focus I can't get the shutter to release at all. It was working perfectly until it suddenly wouldn't do anything. I updated the firmware before this happened but took pictures since with no problems.
Looks like something has gone bust in the camera circuits.
You'd want to check out how much it costs to repair vs. replacing the K100DS (good value in the used market right now) vs. upgrading to a new model.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, mode, photography, repair, shutter, tv
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help! Mode Dial stuck? chriiisty Troubleshooting and Beginner Help 6 03-14-2011 01:05 AM
K20D get stuck on playback mode goldenzebra Pentax DSLR Discussion 5 10-11-2010 02:48 AM
K10D Stuck in AV mode mpodesta Pentax DSLR Discussion 10 04-27-2010 10:49 AM
k100d MF/AF toggle switch stuck in MF summatusmentis Pentax DSLR Discussion 9 11-26-2009 03:52 PM
K100D Stuck/bad pixels -Joe- Pentax DSLR Discussion 17 10-30-2009 12:05 PM



All times are GMT -7. The time now is 12:18 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top