Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-21-2009, 10:48 PM   #1
Forum Member




Join Date: Jul 2009
Location: Houston & Dubai
Posts: 51
Serious Short Circuit in the K-7 electronics

I have had a Pentax k-7 for about 3 months now and i have had a short circuit in the k-7 for the 3rd time and it goes as follows:
  • the shutter and the lcd display just go on and off at a speed of about 3 to 4 times a second and it doesnt stop untill I remove the battery off the camera.
  • It first happend in the first week of buying the camera and I first thought it was because I had the powergrip on along with the camera regular battery
  • The next time it happened was 2 weeks ago and with only the origianl battery on with no powergrip
  • The 3rd time was yesterday again with the powegrip and orignal battery on .

In all cases, the only way to stop it was to remove the all the batteries from the body.

Anyone else had this problem?

09-22-2009, 12:49 AM   #2
Senior Moderator
Loyal Site Supporter
Nass's Avatar

Join Date: Aug 2009
Location: The British Isles
Photos: Gallery
Posts: 2,210
QuoteOriginally posted by alman Quote
I have had a Pentax k-7 for about 3 months now and i have had a short circuit in the k-7 for the 3rd time and it goes as follows:
  • the shutter and the lcd display just go on and off at a speed of about 3 to 4 times a second and it doesnt stop untill I remove the battery off the camera.
  • It first happend in the first week of buying the camera and I first thought it was because I had the powergrip on along with the camera regular battery
  • The next time it happened was 2 weeks ago and with only the origianl battery on with no powergrip
  • The 3rd time was yesterday again with the powegrip and orignal battery on .

In all cases, the only way to stop it was to remove the all the batteries from the body.

Anyone else had this problem?
Nope, none of the above. I'd send it back to Pentax to fix if I were you.
09-22-2009, 03:28 AM   #3
Site Supporter
tomwil's Avatar

Join Date: May 2009
Location: Maryland USA
Posts: 778
Have you applied the most recent firmware update?
09-22-2009, 03:57 AM   #4
Forum Member




Join Date: Jul 2009
Location: Houston & Dubai
Posts: 51
Original Poster
yes I did the firmware update which is only one so far that I am aware off

09-22-2009, 04:35 AM   #5
Senior Member
Rich_A's Avatar

Join Date: Aug 2009
Location: Montana
Photos: Gallery
Posts: 213
No similar experiences with mine either. It sounds like you've eliminated a bad battery. I would say call and have it repaired while it's still under warranty.
09-22-2009, 05:11 AM   #6
Pentaxian
dosdan's Avatar

Join Date: Dec 2007
Location: Brisbane, Australia
Photos: Gallery | Albums
Posts: 1,697
That problem does not sound like a short-circuit. It sounds like the camera's electronics have entered an unstable mode of operation.

Dan
09-22-2009, 08:22 AM   #7
Pentaxian
Wheatfield's Avatar

Join Date: Apr 2008
Location: The wheatfields of Canada
Posts: 10,043
The real question is why haen't you gotten the camera replaced under warranty already. This is something to deal with, not crab about on internet forums.
So far, my K7 has been flawless for nearly 4k exposures.
09-22-2009, 08:31 AM   #8
Veteran Member
mtroute's Avatar

Join Date: Jun 2009
Location: Portland OR
Posts: 532
My K200 did this once, it was right as the batteries were dying.Had to pull the batteries to stop it.

09-22-2009, 10:21 PM   #9
Forum Member




Join Date: May 2007
Location: Colorado Springs, CO
Photos: Gallery | Albums
Posts: 59
I had the same problem with my K10D at about 50,000 shutter actuations. The main circuit board had to be replaced.
09-23-2009, 06:55 AM   #10
Veteran Member
FotoPete's Avatar

Join Date: Feb 2007
Location: Toronto
Photos: Gallery
Posts: 1,710
Sounds similar to what happened with my K200D. I thought it was the batteries but apparently sounding was wrong with the camera and the shutter would sporadically go off w/o me touching the button or go off 2-3times on the shutter press.

Got it fixed under warranty so all is well.
09-23-2009, 10:53 AM   #11
Forum Member




Join Date: Jul 2009
Location: Houston & Dubai
Posts: 51
Original Poster
Reason i didnt get it fixed or replaced is because I live in Dubai and bought it from Best Buy in Houston Texas
Long way from the dealer or retailer
09-23-2009, 12:01 PM   #12
Veteran Member
Jasvox's Avatar

Join Date: Oct 2007
Location: Melbourne, Australia
Posts: 3,110
No warranty there in Dubai?

Jason
09-23-2009, 12:03 PM   #13
Forum Member




Join Date: Jul 2009
Location: Houston & Dubai
Posts: 51
Original Poster
I TALKED TO PENTAX AND THEY WANT THE CAMERA INDEFINITELY TO FIGURE OUT THE PROBLEM

They are crazy ... this is their flagship camera and they have electronics issues and they want the customer to send it by post to Arizona and wait and wait and wait while they try figure it out. did it occur to them that this is not a cheap holiday camera? That I may be using it for work or studies?
09-23-2009, 03:08 PM   #14
Pentaxian
Wheatfield's Avatar

Join Date: Apr 2008
Location: The wheatfields of Canada
Posts: 10,043
This is why I don't mail order stuff if I can help it.
OTOH, think of the money you saved by not supporting a local business.....
09-23-2009, 03:32 PM   #15
Inactive Account




Join Date: Sep 2009
Location: Oregon
Posts: 8
I just got my K7 a few days ago.. no problems so far.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
battery, camera, circuit, dslr, k-7, photography, time
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Short circuit in K-x Hemi345 Pentax DSLR Discussion 5 03-03-2010 03:18 PM
Octopus Electronics? Graham67 Photographic Technique 0 10-03-2009 10:01 AM
K-7 at Fry's Electronics lenp Pentax News and Rumors 27 08-18-2009 06:24 AM
Samsung Electronics to split activites between Consumer Electronics and Components ghelary Pentax News and Rumors 3 01-18-2009 04:36 AM
Disposable electronics *isteve Pentax DSLR Discussion 17 03-30-2007 12:33 PM



All times are GMT -7. The time now is 09:29 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top