Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-23-2009, 09:26 AM   #1
Site Supporter
opiedog's Avatar

Join Date: Jan 2008
Location: NC
Posts: 787
Kx/K2000 Flash AF assist doesn't work in all modes?

i just spoke with pentax and they confirmed that the Flash AF assist of the k2000/km does NOT work in all modes.

it works in some of the preset modes, like portrait, Auto-PIC, but not in Av, Tv, Manual.

Is this normal?

My wife's k200 flash AF assist works in all modes and i could swear that my former K10 and *DL also worked in all modes.

can someone confirm that this is the same in their km/k2000?

thanks!

09-23-2009, 09:27 AM   #2
Senior Member




Join Date: Feb 2009
Location: Pilsen, Czech Republic
Posts: 224
QuoteOriginally posted by opiedog Quote
i just spoke with pentax and they confirmed that the Flash AF assist of the k2000/km does NOT work in all modes.

it works in some of the preset modes, like portrait, Auto-PIC, but not in Av, Tv, Manual.

Is this normal?

My wife's k200 flash AF assist works in all modes and i could swear that my former K10 and *DL also worked in all modes.

can someone confirm that this is the same in their km/k2000?

thanks!
Works just fine in Av, P, Tv and even M for me.

I think they confused auto flash pop-up with AF assist.
09-23-2009, 09:39 AM   #3
Site Supporter
opiedog's Avatar

Join Date: Jan 2008
Location: NC
Posts: 787
Original Poster
jerry,

i confirmed it with the pentax rep. i had him switch between modes and it would not strobe the flash in Av, M, or P.

what firmware version do you have ? i'm using the latest version 1.1.


tnx
jordan
09-23-2009, 11:37 AM   #4
Site Supporter
opiedog's Avatar

Join Date: Jan 2008
Location: NC
Posts: 787
Original Poster
using the menu, i did a full reset and all seems well again.

so all is well in k2000 land

09-23-2009, 06:02 PM   #5
Pentaxian
Arpe's Avatar

Join Date: Sep 2006
Location: New Zealand
Photos: Gallery | Albums
Posts: 4,329
Make sure you're not in AF-C. It only works in AF-S.

Last edited by Arpe; 09-24-2009 at 05:22 PM. Reason: oops
09-23-2009, 06:44 PM   #6
Site Supporter
opiedog's Avatar

Join Date: Jan 2008
Location: NC
Posts: 787
Original Poster
QuoteOriginally posted by Arpe Quote
Make sure you're in AF-C. It only works in AF-S.
i thought i had it in AF-A, but i did a reset from the menu and it started working again.

next time it happens, i'll check if it's in AF-C

thanks!

jordan
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
af, camera, dslr, flash, modes, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tamron 2X TC doesn't work with DA 70mm SOldBear Pentax SLR Lens Discussion 0 10-27-2010 05:05 PM
How well does K-7 AF assist work? GeneV Pentax DSLR Discussion 4 07-28-2010 05:43 PM
K2000 low light autofocus flash assist - without using flash Eruditass Troubleshooting and Beginner Help 21 08-24-2009 05:33 PM
Flash Modes Gadget_Guy Photographic Technique 2 04-21-2008 04:11 AM
Samsung GX10 - AF flash assist without flash nixter Pentax DSLR Discussion 0 11-22-2007 05:17 PM



All times are GMT -7. The time now is 02:18 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top