Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-29-2009, 09:43 AM   #1
Veteran Member
PentaxPoke's Avatar

Join Date: Jan 2008
Location: Oklahoma
Posts: 1,411
Anyone else notice this about the K-7 dials?

I have noticed on my K-7 an odd behavior with the front e-dial. The front dial controls shutter speed in most modes. When I spin the dial to the right (clockwise) the shutter speed increases as it should. When I spin it the other way however, the behavior is erratic. The shutter speed may go down a couple of clicks, and then jump back up. Sometimes even faster than the speed originally set.

It is such an odd behavior. You would think that if there was a problem with the dial, it would have a problem both ways. This only shows up when reducing shutter speed. (I have tried it in P, Tv, and M modes)

Does anyone else notice this on their K-7? Does my camera need service already?


Last edited by PentaxPoke; 09-29-2009 at 09:55 AM.
09-29-2009, 11:39 AM   #2
Senior Member




Join Date: Aug 2009
Location: Santiago
Photos: Gallery
Posts: 173
This type of selectors use normally two optic of magnetic sensors to determine the direction of the dial. Same type is used in many car radio volume dials (I have similar problem with radio).
If one of the sensors is shifted, the function becomes erratic to one direction only. If one sensor dies, dial does not work at all.
Unfortunately (in my opinion) service is needed.
09-29-2009, 11:51 AM   #3
Site Supporter
tomwil's Avatar

Join Date: May 2009
Location: Maryland USA
Posts: 778
There are 2 possible user fixes:

1) cleaning

2) resetting the camera in the custom menu

Last edited by tomwil; 09-29-2009 at 11:57 AM.
09-29-2009, 12:52 PM   #4
Veteran Member
frank's Avatar

Join Date: Nov 2006
Location: Singapore
Photos: Gallery
Posts: 3,202
My K-7 exactly had the same problem about 1month after I bought it (in early July). Sent to our local Pentax service center (my K7 was their first ever case locally w/ any problem), it was opened and cleaned up, then the front dial has been okay ever since. I was told it's probably because the dirts during assembly, nothing series.

I guess yours needs a trip to the service center too. I saw the techinian opened up the camera top, not as easy as I expected. Better don't do it yourself.

Good luck.

09-29-2009, 02:19 PM   #5
Inactive Account




Join Date: May 2009
Location: Haugesund, Norway
Posts: 5
Had the same experience on my DS, and it just got worse and worse. In the beginning it was "cleanable", but eventually it totally failed after having become more and more erratic and failing more frequent. It "died" on me during a holiday in China — nice one ... 8o(

I don't know if the dials are the same on later models, or if it was the dial in my case, but when I got it back from repair the paperwork stated that the mainborad had been replaced — after the warranty had expired.

So my thoughts are; don't bother to mess about with it — just get it fixed properly the first time.
09-29-2009, 05:15 PM   #6
Veteran Member
PentaxPoke's Avatar

Join Date: Jan 2008
Location: Oklahoma
Posts: 1,411
Original Poster
QuoteOriginally posted by Autodidact Quote
Had the same experience on my DS, and it just got worse and worse. In the beginning it was "cleanable", but eventually it totally failed after having become more and more erratic and failing more frequent. It "died" on me during a holiday in China — nice one ... 8o(

I don't know if the dials are the same on later models, or if it was the dial in my case, but when I got it back from repair the paperwork stated that the mainborad had been replaced — after the warranty had expired.

So my thoughts are; don't bother to mess about with it — just get it fixed properly the first time.
Wonderful. So this brings my problems with Pentax quality control up to 6 items within the last 2 years:

-3x 16-50 lenses badly decentered
-a DA* 50-135 complete SDM failure
-k20d rear e-dail intermittency

and now the K-7 front e-dial failure.

don't they define insanity as doing the same thing over and over, and expecting a different result?

thanks for the suggestions folks. I don't know how I would even try to clean the e-dial sensors since they are internal, and the k-7 is weathersealed, so there is no way to just squirt the cleaning fluid in there. I am not going to dissassemble it and worry about voiding the warranty. Plus, with what Auto said, even if I did clean it, it may go bad anyway.
09-29-2009, 06:32 PM   #7
Pentaxian
Moderator Emeritus




Join Date: May 2007
Location: Edmonton Alberta, Canada
Photos: Gallery | Albums
Posts: 10,648
Rear e dail intermintancy on the K20D? I've had that in combination with the AE-L button. Locking exposure whenever it wanted to and the Edail being erratic particularly in playback. Not zooming in, protect on and off etc.

Similar?
09-29-2009, 07:33 PM   #8
Veteran Member
PentaxPoke's Avatar

Join Date: Jan 2008
Location: Oklahoma
Posts: 1,411
Original Poster
QuoteOriginally posted by Peter Zack Quote
Rear e dail intermintancy on the K20D? I've had that in combination with the AE-L button. Locking exposure whenever it wanted to and the Edail being erratic particularly in playback. Not zooming in, protect on and off etc.

Similar?
Sorry to hear that Pete. The e-dial on my k-20d got very stiff compared to the front one. This made it difficult for the dial to land on a "stop." It would often land sort of in between stops, and I would have to jiggle it to get it in the right spot. Also, not only did it become stiff, but the wheel developed some "slop" in it. It wasn't so much an electrical problem, as much as a mechanical problem. Or at least that what it feels like to me.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
behavior, camera, dslr, front, k-7, modes, notice, photography, shutter
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
pentax K-7 - annoying e-dials Digitalis Pentax DSLR Discussion 15 05-16-2010 05:05 PM
K7 dials question candgpics Pentax DSLR Discussion 5 03-28-2010 04:46 PM
I nearly fainted when I saw the Mz-M's dials BookSaw Troubleshooting and Beginner Help 3 01-05-2010 08:58 PM
Asahi Pentax KX self timer dials iht Troubleshooting and Beginner Help 4 11-05-2009 05:52 AM
customize e-dials on K20D winglik Pentax DSLR Discussion 8 02-11-2009 08:56 PM



All times are GMT -7. The time now is 07:58 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top