Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-22-2011, 08:33 PM   #16
Site Supporter
Site Supporter




Join Date: Jan 2010
Location: Michigan
Photos: Gallery
Posts: 2,200
Old thread. The ist ds had the AF trim available in the firmware, a slider in the DeBug mode.
Only one adjustment for the body, not for individual lenses.
However 2 lenses tested both needed the same setting
I used a 1 metre long carpenter's straightedge and sat a focus hash at 500 mm
One well used body needed to be set - 80 um, a newer one was OK at 0.
The tricky bit is the slider reverts to 0 after the adjustment is saved.
I am about to take the sensor out of a broken ist ds, mabe make one good
body out of 2, so the adjustment will be needed if I get that far.
(The sensor and the dsp/cpu board have to stay together)

07-23-2011, 07:41 AM   #17
Veteran Member




Join Date: Mar 2009
Location: Chicago suburbs
Photos: Albums
Posts: 848
Bookmark
07-24-2011, 02:35 PM   #18
Site Supporter
Site Supporter




Join Date: Aug 2008
Location: Surrey, UK
Photos: Gallery
Posts: 53
Well, I had a go yesterday morning at adjusting the focus. I have a Pentax DA 18-250mm lens which came with the camera but have not been entirely happy with shots taken with the lens wide open. It always struck me that the focal point was just in front of the subject rather than at the centre of the object.

So I set up three pencils and a plastic ruler on the kitchen worktop and, with the camera on a tripod, I went to work. All shots were taken by manually setting the focus to be as close as possible, and then auto-focussing to take the shot. This way, focus is not the same each time but relies on the camera having to re-focus on the same spot before taking the picture (Highly scientific, but there we are.)

The first picture shows the focus set without adjustment:
Name:  250mm-no adjustment.jpg
Views: 1112
Size:  118.1 KB

The focal point here was the tip of the central pencil. However, the shot shows that the focal point of the shot is actually set around 5.6" rather than 6" (the pencil tip).

I adjusted the AF setting by -50um and took another photo:
Name:  250mm-neg50um adjustment.jpg
Views: 1189
Size:  117.7 KB

This time the focal point does seem to be at the 6" mark and ruler markings between 6" and 7" do appear sharper (especially when the two photos are viewed side-by-side)

So this has made a discernable difference, so may I add my thanks to the others here for your work setting up the guide.

Interestingly I tried two of my other zooms and noticed that my Pentax-F 35-135mm zoom looks decidedly soft in comparison. Here are the three pencils in Macro mode:
Name:  135mm-Macro.jpg
Views: 1035
Size:  86.6 KB

And here is the same picture through the DA 18-250mm set at 250mm:
Name:  250mm-NoMacro.jpg
Views: 1085
Size:  115.0 KB

Much better. And both were focussed the same way.

I've not had a chance to play outside as the batteries decided to die on me during this work, but I have got one photo from this afternoon that shows that focus looks about right....

Name:  rose.jpg
Views: 1571
Size:  88.7 KB

Thanks again. Well worth the time and effort.

Cheers

Savcom
11-17-2011, 02:26 PM   #19
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 43,656
This should probably be re-formatted and then posted in the articles section!


Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

11-17-2011, 03:41 PM   #20
Site Supporter
Site Supporter




Join Date: Aug 2008
Location: Surrey, UK
Photos: Gallery
Posts: 53
QuoteOriginally posted by Adam Quote
This should probably be re-formatted and then posted in the articles section!
Happy to help - I'll take a look over the weekend and see if there are any guidelines I should follow. Is the OP happy with this?
01-20-2012, 07:20 PM   #21
New Member




Join Date: Jan 2012
Posts: 3
no debug on K200d firmware v1.01??

I'm in desperate need of help. my firmware is 1.01 & cannot get debug mode to work, only displays my firmware version for a few secs then screen goes dark. I have a back focus issue. PLEASE HELP! I need my camera, just started a new job, can't afford a new camera right now :-(
01-21-2012, 06:14 PM   #22
Inactive Account




Join Date: Nov 2008
Location: Trabzon/Turkey
Photos: Gallery
Posts: 1,010
QuoteOriginally posted by kmac1036 Quote
I'm in desperate need of help. my firmware is 1.01 & cannot get debug mode to work, only displays my firmware version for a few secs then screen goes dark. I have a back focus issue. PLEASE HELP! I need my camera, just started a new job, can't afford a new camera right now :-(
Try pk_tether it takes camera to debug mode with one click on and off without messing with text file to memory card or anything, but since my camera stil has FW 1.00 please let us know if it worked out for you too.

PK_Tether | Tethering and remote control software for Pentax DSLR cameras

Last edited by cbaytan; 01-21-2012 at 06:58 PM.
01-21-2012, 11:35 PM   #23
New Member




Join Date: Jan 2012
Posts: 3
just tried it, didn't work either. all of this got squelched in the firmware update works on the K7 I bit the bullet on & picked up today. $820 OTD with 3 yr pentax extended warranty. couldn't pass it up.

01-22-2012, 01:49 AM   #24
Pentaxian
Jonathan Mac's Avatar

Join Date: Apr 2009
Location: Madrid, Spain
Posts: 4,412
QuoteOriginally posted by kmac1036 Quote
just tried it, didn't work either. all of this got squelched in the firmware update works on the K7 I bit the bullet on & picked up today. $820 OTD with 3 yr pentax extended warranty. couldn't pass it up.
The focus adjust is still there in firmware 1.01, and accessed in exactly the same way. Why don't you tell us exactly which instructions you're using and we can spot where you're going wrong?
01-22-2012, 07:53 AM   #25
New Member




Join Date: Jan 2012
Posts: 3
took one more look at it. put a [CR] in it to make sure it was registering the line return I checked the file info (under OS X. tried this on Win 7 too, both actually were appending the .txt on the file!!!). once I opened the Get Info pane (same as right click > Properties on Win), I deleted the .txt from the filename & the icon changed... debug popped right up! I even tried the PK Tether, it has a button that enables/disables the debug menu but it wasn't seeing my camera. used the AF adjust, needed a +70 to get it back close. I also had a problem a couple weeks ago: it froze up to the point I had to pull the batteries.
wish I'd figured this out sooner, but I really like the K7. Having a really hard time parting with it.
thanks for the help!!!!!

Last edited by kmac1036; 01-22-2012 at 07:59 AM.
01-22-2012, 04:01 PM   #26
Inactive Account




Join Date: Nov 2008
Location: Trabzon/Turkey
Photos: Gallery
Posts: 1,010
OS X !! I would try once more with pk-tether on a 32 bit windoze, mine is Win XP x64. My steps just in case=

-I connect the cam off with USB without turning on.
-I open pk-tether
-I turn on K200D,
-pk tether sees the camera
-just one click to debug mode off, that all,
-disconnect from pk tether, wait for discconnection
-disconnect from USB
-turn off cam
-turn on cam -- ta-daa.
09-15-2012, 09:49 AM   #27
Site Supporter
Site Supporter




Join Date: Aug 2012
Location: Oklahoma
Photos: Gallery
Posts: 59
Old post, but just wanted to pass along a thank you. I've had my K200D for almost three years now and I had no idea this was possible. I just dealt with inaccurate focus all that time. I just bought a DA70 and it was backfocusing pretty bad. A +100 adjustment did the trick (I just had to make sure I removed the ".txt" from the file that OSX automatically appended to it). Thanks again!
09-16-2012, 01:09 AM   #28
Pentaxian
Jonathan Mac's Avatar

Join Date: Apr 2009
Location: Madrid, Spain
Posts: 4,412
Yes, it's a bit tricky getting it right and removing the .txt isn't mentioned anywhere in the instructions I used.

Really, all DSLRs should have a system for proper AF adjustment for at least a dozen lenses as a basic feature. DSLRs are more sensitive to focus errors than film cameras, or at least we're more aware of them due to the ability to pixel-peep.
02-09-2014, 12:38 PM   #29
Site Supporter
Site Supporter
nutkasse's Avatar

Join Date: Aug 2008
Location: vancouver bc
Posts: 92
hi all, i also have a k200d & i have windows 7 pro. i don't have a "new" when i right click on the sd card. i have a "open in new window".is it the same thing??
02-09-2014, 01:03 PM   #30
Site Supporter
Site Supporter




Join Date: Aug 2008
Location: Surrey, UK
Photos: Gallery
Posts: 53
QuoteOriginally posted by nutkasse Quote
hi all, i also have a k200d & i have windows 7 pro. i don't have a "new" when i right click on the sd card. i have a "open in new window".is it the same thing??
Hi Nutkasse.

No, unfortunately this is not the same thing. Open in new window lets you browse the contents of the SD card in a new explorer window.

I suspect you're clicking on the SD card in the My Computer view.
Name:  New2.jpg
Views: 351
Size:  86.6 KB

Try double-clicking this and then try right-click then New...
Name:  New.jpg
Views: 333
Size:  76.4 KB

Let me know if this helps.

SavCom
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
af, button, camera, card, debug, dslr, focus, menu, mode, photography, sd
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fine Sharpness in Custom Image on K200D MoiVous Pentax DSLR Discussion 9 08-03-2009 11:21 AM
Will K-7 have AF lens tuning like the K20D? jsherman999 Pentax News and Rumors 17 04-27-2009 04:01 PM
K200D autofocus modes - speed and accuracy grainbelt Photographic Technique 9 12-19-2008 03:53 PM
K20D AF tuning with FA*80-200mm dsport Pentax SLR Lens Discussion 9 09-14-2008 11:49 AM
K20D with AF Fine Tuning? blende8 Pentax News and Rumors 12 12-17-2007 06:36 AM



All times are GMT -7. The time now is 10:51 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top