Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-02-2009, 07:37 AM   #1
New Member




Join Date: Sep 2009
Location: New Jersey, USA
Posts: 3
Possible SD Cards Issue

Good morning all,
I was wondering if anyone has encountered this issue.

I formatted a "quality" 4gb SD card (Kingston, I believe) in my K20d, however the card-reader I have attached to my PC does not recognize the card. I needed to connect the camera to the PC to get the pictures off the card. Is it being caused by the format process?

The card reader is one of the 6 in one card reader types and works fine with the other cards in the household (cf & xd).

I'm not 100% convinced that it's not the reader, but just wanted to check and see if anyone else has run into this.

-Chris


Last edited by WCMans; 10-03-2009 at 06:58 AM.
10-03-2009, 06:34 PM   #2
Senior Member




Join Date: Jul 2009
Location: Croydon Park, Sydney, Australia
Posts: 161
WCMans - Your reader might be okay with "SD" cards - up to 2GB. The ones - SDHC - over 2GB, don't read in older readers. I have a 2002 (about) - one that only reads SD to 2GB. I bought one a couple of months back - when the old reader wouldn't read the 4GB Transcend SDHC I bought for my Canon SX10. Readers are now quite cheap - just check that whatever you buy is marked for SDHC.

Regards, Dave.
10-03-2009, 07:15 PM   #3
Veteran Member
GLXLR's Avatar

Join Date: Feb 2009
Location: Sugar Land, TX
Photos: Gallery
Posts: 686
QuoteOriginally posted by WCMans Quote
Good morning all,
I was wondering if anyone has encountered this issue.

I formatted a "quality" 4gb SD card (Kingston, I believe) in my K20d, however the card-reader I have attached to my PC does not recognize the card. I needed to connect the camera to the PC to get the pictures off the card. Is it being caused by the format process?

The card reader is one of the 6 in one card reader types and works fine with the other cards in the household (cf & xd).

I'm not 100% convinced that it's not the reader, but just wanted to check and see if anyone else has run into this.

-Chris
I had the same problem. My old reader couldn't read SDHC. Plus, I think it's faster just to plug the camera into the computer.
10-03-2009, 07:40 PM   #4
Banned




Join Date: Sep 2006
Location: Millstone,NJ
Posts: 6,491
I use the 30mb/sec Sandisk SDHC reader.


10-03-2009, 08:20 PM   #5
Site Supporter




Join Date: Sep 2009
Location: Texas
Photos: Gallery
Posts: 3,393
I ran into this problem last week. I picked up a SDHC reader from Fry's Electronics for $10. It does the job.
10-04-2009, 07:20 AM   #6
Veteran Member




Join Date: May 2007
Location: Prince George, BC Canada
Photos: Gallery | Albums
Posts: 644
QuoteOriginally posted by WCMans Quote
Good morning all,
I was wondering if anyone has encountered this issue.

I formatted a "quality" 4gb SD card (Kingston, I believe) in my K20d, however the card-reader I have attached to my PC does not recognize the card. I needed to connect the camera to the PC to get the pictures off the card. Is it being caused by the format process?

-Chris
I had this happen with a Panasonic 8gb card ...threw it away and went back to my Sandisk Extreem III cards. I made a resolution to resist buying cheap cards from now on. And btw, the only high speed card reader I could find locally was a Lexar, works fine with the Sandisk cards. My previous so called high speed reader has been retired!
10-06-2009, 01:02 PM   #7
New Member




Join Date: Sep 2009
Location: New Jersey, USA
Posts: 3
Original Poster
Thanks for your feedback everyone!!! As it turns out it was the card reader, likely for the suggested issue of the 2gb limitation. All other cards in the household are < 2GB. I went out and got a new SDHC reader and all is well.

Thanks again,
Chris
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, card, cards, dslr, issue, pc, photography, reader, sd, sd cards
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Vivitar MC Tele Converter 2X PK-A/R-PK issue...or no issue? WiseOx Pentax SLR Lens Discussion 5 06-11-2014 01:14 PM
SD WI-FI Cards rodneyr Pentax Camera and Field Accessories 4 07-17-2010 06:06 AM
SD Cards Bellakelpie Pentax Camera and Field Accessories 24 01-08-2009 02:46 PM
A printer issue, or a processing issue... FHPhotographer Digital Processing, Software, and Printing 0 10-03-2008 12:13 PM



All times are GMT -7. The time now is 04:19 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top