Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-24-2009, 09:59 AM   #1
Senior Member
AMBIVALENCE's Avatar

Join Date: May 2009
Location: Toronto
Posts: 149
HELP: *ist DL Died, please diagnose?

Hey All!

I am so depressed right now. I've a *ist DL and it no longer turn on. I've tried to use different battery, and no good news. I am too afraid to try AC input to test if it's really not working.
the camera is well kept and no problem with connectivity with battery. It just dies. No light no indicator whatsoever. Never water damaged. This really sucks

1. Can anyone offer any suggestion on what to look for/ what to do, before I send it off to pentax?
2. Also, usually how much does camera repair cost? Should I go back to pentax to do it? =(

Please help me, i am very sad. I never own a pet but it feels just like my pet died.


Last edited by AMBIVALENCE; 12-02-2009 at 08:55 PM. Reason: remove photo to free up server space
10-24-2009, 11:30 AM   #2
Veteran Member




Join Date: Mar 2009
Location: Chicago suburbs
Photos: Albums
Posts: 848
DL

Sorry about your DL.
First verify that the batteries are good - Test voltage on each one with a volt meter.
Install batteries in camera. Turn on camera and leave on for several minutes. Test voltage again on each battery with a volt meter. If one battery is lower than the others, you have found a problem battery.
Try the AC adapter - what do you have to loose - the camera doesn't work anyway.
Try turning it on while hold the MENU button down.
I would not send it to Pentax for repair - too expensive. I would sell you a DL for less.
You can sell your DL on ebay as a parts/repair camera. I watched an auction for a broken DL a while back - it sold for 75 dollars.
GP
10-24-2009, 12:21 PM   #3
Senior Member
AMBIVALENCE's Avatar

Join Date: May 2009
Location: Toronto
Posts: 149
Original Poster
Battery voltage. ... hmm interesting. I've tried different battery.
as for AC... I'll definitely give it a try. I just dont want to burn my great companion in flame. (I've done it to one of my MP3... it was scary)

I will try the menu button as well...

Are they any camera repair books around?
10-24-2009, 12:55 PM   #4
Ash
Community Manager
Loyal Site Supporter
Ash's Avatar

Join Date: Mar 2007
Location: Toowoomba, Queensland
Photos: Gallery | Albums
Posts: 22,679
Probably nothing you would be able to do yourself - we're no longer dealing with solely mechanical cameras anymore (kind of like trying to fox cars on your own nowadays...)

Hope it works out for you with the AC power source (use its dedicated one if you have it).
If it works, it may just be that perhaps a battery contact has lost its 'spring' and not making contact with one of the battery's poles. May need physical manipulation to spring back into contact...

10-24-2009, 02:19 PM   #5
Senior Member
AMBIVALENCE's Avatar

Join Date: May 2009
Location: Toronto
Posts: 149
Original Poster
I dont have the stock AC adaptor, I've try to boot it at 6V, nothing happened. I am afraid to go up to 6.5V or 7V just to double check =(

Argh... i am so depressed
10-24-2009, 03:14 PM   #6
Forum Member




Join Date: Jan 2009
Location: Berlin, Germany
Posts: 62
can understand your feelings. I started with ist DL, still like it and would hardly sell it. Have you tried dismounting everything dispensable that could prevent it from starting? These are lens and memory card. I have heard of instances where defective mem cards did that. I would try with a power adapter if you can get hold of it (the prod# is K-AC10H), since it uses different connection to the electronics of the cam.

Good luck, kai
10-24-2009, 03:17 PM   #7
Forum Member




Join Date: Jan 2009
Location: Berlin, Germany
Posts: 62
the pentax ac adapter has 6.5 Volts (ABC Products Pentax K-AC10H K-AC10B 6.5V Ac Mains Power: Amazon.co.uk: Electronics & Photo), so you cannot go wrong applying that. Yet if I am not mistaken, the plug is non standard, hence it might not work due to bad or missing contact.
10-24-2009, 03:27 PM   #8
Senior Member
AMBIVALENCE's Avatar

Join Date: May 2009
Location: Toronto
Posts: 149
Original Poster
thanks for your info. I will see.
Yes, you totally agree my feeling, the unit is so smooth and beautiful too...

10-24-2009, 03:55 PM   #9
Pentaxian
eccs19's Avatar

Join Date: Jul 2008
Location: Lisle, Ontario
Photos: Gallery
Posts: 1,458
I know I was having trouble with my *ist D a while back, and I had to replace the smaller battery in it (Not the AA's), and after I did that, it worked great. Mind you I don't see the spot on the bottom of the camera where it would go. Not sure if your version of the camera uses one or not.
10-24-2009, 08:19 PM   #10
Banned




Join Date: Jun 2009
Location: Massachusetts, USA
Photos: Gallery
Posts: 84
Sorry to hear about your DL. Nice body btw, love the silver, mine is solid black. Don't know if this will help, but have you tried a new mem card? I once had a "starting" issue with my DL because I had forgotten to replace the card, perhaps a bad card would do the same.
Hope the fix is a simple one for you, Good Luck!!
10-24-2009, 10:22 PM   #11
Senior Member
AMBIVALENCE's Avatar

Join Date: May 2009
Location: Toronto
Posts: 149
Original Poster
still tempering with the dead body. but thanks all for your suggestions! Will take it apart in 2 days if i cant find a true external fixable problem...

and yes.. you can tell it's a cosmetically perfect DL...grrrr
10-24-2009, 10:30 PM   #12
Senior Member
AMBIVALENCE's Avatar

Join Date: May 2009
Location: Toronto
Posts: 149
Original Poster
btw, are there instructions on how to take apart a DSLR on this forum? =)
10-24-2009, 10:35 PM   #13
Ash
Community Manager
Loyal Site Supporter
Ash's Avatar

Join Date: Mar 2007
Location: Toowoomba, Queensland
Photos: Gallery | Albums
Posts: 22,679
QuoteOriginally posted by kasv Quote
the pentax ac adapter has 6.5 Volts (ABC Products Pentax K-AC10H K-AC10B 6.5V Ac Mains Power: Amazon.co.uk: Electronics & Photo), so you cannot go wrong applying that. Yet if I am not mistaken, the plug is non standard, hence it might not work due to bad or missing contact.
What's just as important is the current rating that's driving the 6.5V - it would need at least that which is indicated on the OEM power source.
10-25-2009, 06:46 AM   #14
Inactive Account




Join Date: Nov 2008
Location: USA
Posts: 924
In order to get the top off, you have to be able to get the flash to pop up. There are two screws under the flash head.
It could possibly be a problem with the contact fingers for the on/off switch.
Forum Examples - thirsty's Photos
10-25-2009, 03:07 PM   #15
Senior Member
AMBIVALENCE's Avatar

Join Date: May 2009
Location: Toronto
Posts: 149
Original Poster
QuoteOriginally posted by wildlifephotog Quote
In order to get the top off, you have to be able to get the flash to pop up. There are two screws under the flash head.
It could possibly be a problem with the contact fingers for the on/off switch.
Forum Examples - thirsty's Photos
hmmmm what can i do to make the flash pop up... =(
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
*ist, battery, camera, dl, dslr, pentax, pet, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
New K-X died? bdtalley Pentax DSLR Discussion 11 12-28-2009 07:21 PM
GX10 just died jamesm007 Pentax DSLR Discussion 8 10-25-2009 01:57 PM
Help me diagnose a lens problem germar Pentax SLR Lens Discussion 10 05-21-2008 12:16 AM
Diagnose Lens Problem (pictures) user440 Pentax SLR Lens Discussion 5 02-01-2008 11:29 PM



All times are GMT -7. The time now is 04:49 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top