Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-25-2009, 08:30 PM   #1
Loyal Site Supporter
RollsUp's Avatar

Join Date: Apr 2008
Location: AK USA
Photos: Gallery
Posts: 1,454
K20D slow shutter lag

The shutter of my K20D has started to lag up to 2 sec at the worst but most of the time it's around 1 sec before the K20D takes a photo. When the shutter button on the battery grip is used the shutter lag is pretty much non existent.
I rarely use the K20D in bad weather, just a few times recently in light snow conditions and each time after taking a photo I put it in a bag until I want to take another.
I've tried resetting back to initial settings in Menu > Setup, made sure the 2 sec delay is off and charged the batteries. It still has some shutter lag when taking photos. The shutter count is less than 20,000 I think. The previous owner at the time I bought it said it had less than 5,000 clicks on it.
Anything else I should try before contacting Pentax USA for a repair quote?
TIA

10-25-2009, 09:13 PM   #2
Ash
Community Manager
Loyal Site Supporter
Ash's Avatar

Join Date: Mar 2007
Location: Toowoomba, Queensland
Photos: Gallery | Albums
Posts: 22,695
Does it matter how hard the shutter is pressed?
If by pressing harder the shutter activates, then the mechanism of the button may be wearing out, becoming less sensitive.
10-25-2009, 09:14 PM   #3
Site Supporter
enoeske's Avatar

Join Date: Jul 2009
Location: Surprise, Az
Photos: Gallery
Posts: 1,925
QuoteOriginally posted by RollsUp Quote
The shutter of my K20D has started to lag up to 2 sec at the worst but most of the time it's around 1 sec before the K20D takes a photo. When the shutter button on the battery grip is used the shutter lag is pretty much non existent.
I rarely use the K20D in bad weather, just a few times recently in light snow conditions and each time after taking a photo I put it in a bag until I want to take another.
I've tried resetting back to initial settings in Menu > Setup, made sure the 2 sec delay is off and charged the batteries. It still has some shutter lag when taking photos. The shutter count is less than 20,000 I think. The previous owner at the time I bought it said it had less than 5,000 clicks on it.
Anything else I should try before contacting Pentax USA for a repair quote?
TIA
What mode are you in? What conditions are you shooting in? Any example images with the EXIF intact from shots where this problem is happening?
10-25-2009, 09:57 PM   #4
Loyal Site Supporter
RollsUp's Avatar

Join Date: Apr 2008
Location: AK USA
Photos: Gallery
Posts: 1,454
Original Poster
QuoteOriginally posted by Ash Quote
Does it matter how hard the shutter is pressed?
If by pressing harder the shutter activates, then the mechanism of the button may be wearing out, becoming less sensitive.
I don't try and press it harder when the shutter lags, just the usual slow firm press that I use to keep my hand shake to a minimum when I take a photo.

QuoteOriginally posted by enoeske Quote
What mode are you in? What conditions are you shooting in? Any example images with the EXIF intact from shots where this problem is happening?
M mode, I haven't tried any of the other modes yet. I've noticed it happening in both daylight and in some low light conditions.

A couple of example photos where the shutter lagged.

Attached Images
View Picture EXIF
PENTAX K20D  Photo 
View Picture EXIF
PENTAX K20D  Photo 
10-25-2009, 10:22 PM   #5
Veteran Member




Join Date: Dec 2007
Posts: 923
QuoteOriginally posted by RollsUp Quote
......When the shutter button on the battery grip is used the shutter lag is pretty much non existent.
.....TIA
Your critical clue is there....looks like either a mechanical or electrical contact problem related to the main shutter button. It could be as simples as bad solder joint or dirt trapped somewhere, or the contacts are getting worn out.
It shouldn't be difficult to repair...
10-25-2009, 10:48 PM   #6
Ash
Community Manager
Loyal Site Supporter
Ash's Avatar

Join Date: Mar 2007
Location: Toowoomba, Queensland
Photos: Gallery | Albums
Posts: 22,695
This is what I suggested originally asking about whether it responded to firmer presses. The photos won't help work things out any further.

There's little you can do to fix it yourself - you'll need it repaired to rectify the problem.
10-25-2009, 11:48 PM   #7
Loyal Site Supporter
RollsUp's Avatar

Join Date: Apr 2008
Location: AK USA
Photos: Gallery
Posts: 1,454
Original Poster
I was thinking along those lines too but I wanted to check with forum members just in case there was a magical solution that I had missed somewhere.
I'll see what Pentax USA has to say about it. Thanks.
10-26-2009, 12:21 AM   #8
Veteran Member
troyz's Avatar

Join Date: May 2008
Posts: 389
Does the lag go away in manual focus mode?

It's possible that snow = low contrast at AF point(s) = delayed autofocus lock.

10-26-2009, 01:01 AM   #9
Loyal Site Supporter
RollsUp's Avatar

Join Date: Apr 2008
Location: AK USA
Photos: Gallery
Posts: 1,454
Original Poster
QuoteOriginally posted by troyz Quote
Does the lag go away in manual focus mode?
Using manual focus was when I first noticed it, the shutter lag was at its slowest then.

QuoteQuote:
It's possible that snow = low contrast at AF point(s) = delayed autofocus lock.
I use the AF button for focusing, wait for the confirmation then depress the shutter button to take the photo.
10-26-2009, 04:54 AM   #10
Inactive Account




Join Date: Nov 2008
Location: USA
Posts: 924
If you decide to repair it yourself. I have 2 brand new K20D shutter release switches.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, k20d, photo, photography, sec, shutter, time
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K20D Shutter Lag nanhi Pentax DSLR Discussion 3 08-09-2010 04:20 AM
K20D slow shutter speed NR mysticcowboy Pentax DSLR Discussion 4 03-01-2010 09:31 AM
inexpensive and no shutter lag? DanLoc78 Pentax Compact Cameras 8 10-14-2008 04:34 PM
AF-360FGZ on K20D Slow Shutter Speed in Av Mode Peter71 Pentax Camera and Field Accessories 3 09-11-2008 07:37 PM
HELP: Camera Shutter Lag DJey Pentax DSLR Discussion 9 08-22-2008 06:42 PM



All times are GMT -7. The time now is 08:26 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top