Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-29-2009, 07:05 PM   #1
Igilligan
Guest




My K20 died - any thoughts

Aw dang darn it...

1 day before the big Halloween Parade at the Human Tornado's school and two days before Halloween.... DEAD K20

Yesterday I was shooting some snaps at a soccer match with a MF lens and all of a sudden it would not snap the pics... push the shutter/nothing. I pulled out the battery..,. still nothin'. Then pulled out the battery and the SD card, waited a couple of minutes and it began to work.

This morning I was shooting with Damn Brit's zenitar plastic fantastic and it worked fine... Then later in the afternoon I was at my friend's daughters last Water polo match (she is a senior) I was using the AF Tammy 70-300 since there was plenty of light... started off fine during warm up, but once the game started.... no shutter at the click of the button again. It still Auto focuses and achieves focus lock, but when you finish the half press of the shutter, is makes a slow mo electronic sound like it is trying to trigger the shutter but nothing happens. Everytime you press, you get focus then the same slow-mo mechanical nothingness. I can hear it trying to do something...

PS the other very interesting thing is that it no longer green button meters with MF lenses on there.

HELP

Anyone heard of this issue?

10-29-2009, 07:26 PM   #2
Ash
Community Manager
Loyal Site Supporter
Ash's Avatar

Join Date: Mar 2007
Location: Toowoomba, Queensland
Photos: Gallery | Albums
Posts: 22,687
So Gus, are you saying that everything else on the camera works fine - it's just the shutter button mechanism that's failing to communicate with the camera. Does the AF button work to activate AF (if activated on the menus)?
10-29-2009, 07:35 PM   #3
Igilligan
Guest




Just found out the Mirror does not move on mirror lock up.

Ash.... Yes, the af on back works... the af at half press of the shutter button works. Only the shutter itself is not activating.

Just did a test and the Mirror Lock up will not work. The sound I think I am hearing on shutter press may actually be the failed attempt at moving the mirror...

uggghhh.

That exp
10-29-2009, 07:46 PM   #4
Pentaxian
LeDave's Avatar

Join Date: Jun 2009
Location: Minneapolis - St. Paul
Photos: Gallery
Posts: 2,898
Dude that sucks man, how many shutter actuations does your K20D have? Maybe it's all rusted out or it's stuck or something, who knows. But hope all goes well and you resolve the problem before Halloween.

10-29-2009, 08:01 PM   #5
Igilligan
Guest




A Point and Shoot Halloween...

Oh, I now have to quickly learn how to use my old Sony H2... Its like riding a bike except the pedals, handle bars and seat are all in different places.


It definately has something to do with the mirror not flipping out of the way.


Dave... it has a lot of actuations on it. Maybe flipped twice... so 20,000 ish


I would play with the mirror except I dont want to break it since it is still in warranty.
10-29-2009, 08:17 PM   #6
Ash
Community Manager
Loyal Site Supporter
Ash's Avatar

Join Date: Mar 2007
Location: Toowoomba, Queensland
Photos: Gallery | Albums
Posts: 22,687
At least being under warranty it'll be sorted out - however long that'll take.
But at only 20,000 it shouldn't have failed so soon...
Sorry to hear that.
10-29-2009, 08:19 PM   #7
Senior Member




Join Date: Dec 2008
Location: AZ
Posts: 285
QuoteOriginally posted by Igilligan Quote
... since it is still in warranty.
send it in
10-29-2009, 08:24 PM   #8
Igilligan
Guest




Oh it's goin in!

I think I will send in my DA 40 with it to have AF finally adjusted... But maybe that is too much! They might loose the DA 40.

I just read a nasty thread about the CRIS repair facility so that scares me a little, but what choice do I have? I supposedly have a 3 year warranty with it.

10-29-2009, 10:48 PM   #9
Veteran Member
res3567's Avatar

Join Date: Sep 2008
Location: Houston Tx.
Photos: Gallery
Posts: 1,876
QuoteOriginally posted by Igilligan Quote
Oh it's goin in!

I think I will send in my DA 40 with it to have AF finally adjusted... But maybe that is too much! They might loose the DA 40.

I just read a nasty thread about the CRIS repair facility so that scares me a little, but what choice do I have? I supposedly have a 3 year warranty with it.
What is the CRIS? My K10 needs to go. Also did you see the after warrenty thread in this forum below? Had a few K20's in the posts; sounds kinda like your problem...............
10-30-2009, 01:09 AM   #10
Senior Member




Join Date: Oct 2007
Location: London
Posts: 266
just a thought

could it be just a bit of dust under the shutter button? I'd try a rocket blower all around it for awhile in case it's something as small as that!
10-30-2009, 04:43 AM   #11
Loyal Site Supporter
dadipentak's Avatar

Join Date: Jul 2008
Location: Baltimore, Maryland
Photos: Gallery
Posts: 10,327
Well at least you have a lotta nice lenses!

But seriously, why not pick up a used body while this one is in the shop? Once this one is fixed, you'll have twin bodies which, I'm finding, is very handy--especially with a lotta lenses .

Last edited by dadipentak; 10-30-2009 at 04:51 AM.
12-28-2009, 06:17 AM   #12
emr
Guest




So, how did this K20D problem resolve? A hardware failure under warranty?
12-28-2009, 09:06 AM   #13
Junior Member




Join Date: Dec 2009
Photos: Albums
Posts: 38
Hemm, just a thought - did you try to self timer? or the remote option (if you got any)?
I think this is an old issue, but maybe it would help someone else with the same problem.

BTW, did you have it fixed already?
12-28-2009, 10:01 AM   #14
Igilligan
Guest




not fixed yet

No the camera is not fixed yet. Due to work and a long battle with the swine flu, it did not go in until the first week of December.

It logged into Cris repair system on Dec 9 but I have heard nothing yet.

I will definitely post the second it hear anything. I am rooting for a positive turn around from Cris, as I had good dealings with the old Pentax Repair company.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
button, camera, dslr, focus, k20, mf, photography, press, shutter
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
New K-X died? bdtalley Pentax DSLR Discussion 11 12-28-2009 07:21 PM
GX10 just died jamesm007 Pentax DSLR Discussion 8 10-25-2009 01:57 PM
My second MZ-50 just died. And a question. phenri Pentax Film SLR Discussion 7 12-30-2008 08:37 PM
My 43 1.9 limited has died iņaki Pentax SLR Lens Discussion 3 11-27-2008 04:39 AM
PSP died on me!!! dudlew Digital Processing, Software, and Printing 2 03-21-2008 04:03 AM



All times are GMT -7. The time now is 10:26 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top