Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-30-2009, 05:05 AM   #1
Veteran Member




Join Date: Nov 2006
Location: Mission Hills, CA
Posts: 773
Got my K-x Yesterday, and it's Going Back to B&H Today - Known Battery Problem

Yep,

Great little camera, and fast as heck, but ....... battery always shows low and shuts off after just a few minutes.

Have rechargeables that are new in it and use the same brand in other cameras ... this set was brand new and then recharged slowly in a MAHA 801D charger.

This is a known problem and happens in selected units ..... some K-x's work great with everything you feed them and some are very particular.

I did not try the Lithiums that came with the camera, as I was planning on keeping them in the bag as a back up.

I'll send it back today and tell B&H to send another K-x out. Hope #2 does not have this problem.



wll

10-30-2009, 05:23 AM   #2
Pentaxian




Join Date: Jun 2009
Location: GMT +10
Photos: Albums
Posts: 10,893
Just for info, what was the battery brand, type and capacity?
10-30-2009, 05:30 AM   #3
Senior Member




Join Date: Feb 2009
Location: Pilsen, Czech Republic
Posts: 224
I'd rule out batteries first. Try different ones (fully charged), wait for a while after inserting batteries before turning the camera on. Try to swith LV on/off.

And try supplied lithiums.
10-30-2009, 05:45 AM   #4
wll
Veteran Member




Join Date: Nov 2006
Location: Mission Hills, CA
Posts: 773
Original Poster
Did all that stuff, use Rayovac Hybids, and they are great.


wll

10-30-2009, 06:10 AM   #5
Veteran Member




Join Date: May 2009
Location: Twin Cities, MN
Posts: 2,869
That is unfortunate. I will have to give my eneloops a run-through over the weekend. Been using the lithiums supplied with no sign of slow down so far. Shot probably 20 minutes of video, extensively tried out the liveview options, lots of menu and playback useage and just over 100 photos taken so far without a hiccup.
10-30-2009, 07:03 AM   #6
Senior Member
chedoy's Avatar

Join Date: Dec 2006
Location: Chicago, IL
Posts: 143
So the Pentax Tech Center recommendation did not work?

As I understand it ..... Insert batteries. Wait 20-30 seconds before powering up camera, which allows internal circuitry to reboot and recognize battery type.
10-30-2009, 07:12 AM   #7
Senior Member
blu3ness's Avatar

Join Date: Oct 2009
Location: Edmonton, Alberta
Posts: 117
what chedoy said, also go into the menu and set the correct battery type to NiMh, do a reboot.
10-30-2009, 07:16 AM   #8
Veteran Member
Eruditass's Avatar

Join Date: Jul 2009
Location: Pittsburgh, PA
Photos: Gallery | Albums
Posts: 2,206
Please post part of your SN here

https://www.pentaxforums.com/forums/pentax-dslr-discussion/77835-k-x-owners-n...ts-please.html

10-30-2009, 09:13 PM   #9
wll
Veteran Member




Join Date: Nov 2006
Location: Mission Hills, CA
Posts: 773
Original Poster
Like i said,

I put batteries in, let set for over a minute.

Reset battery type in menu, bla, bla bla.

Sorry, camera did not work with Hybrid batteries that my Ds, Sony, Canon and others work with ..... camera is on its way back as of 2ish this afternoon.



wll
10-31-2009, 02:39 AM   #10
Veteran Member




Join Date: Jul 2009
Location: kobe/japan
Posts: 510
QuoteOriginally posted by wll Quote
I put batteries in, let set for over a minute.

Reset battery type in menu, bla, bla bla.

Sorry, camera did not work with Hybrid batteries that my Ds, Sony, Canon and others work with ..... camera is on its way back as of 2ish this afternoon.



wll

your bad luck, either your cam is bad or the battery.
Anyway good that you returned.

for me, used nimh batteries today took around 250 photos, still working fine.
I think pentax should fix this bug, if it is possible to fix in firmware it would be wonderful for people who want buy and use it.
10-31-2009, 04:25 AM   #11
wll
Veteran Member




Join Date: Nov 2006
Location: Mission Hills, CA
Posts: 773
Original Poster
QuoteOriginally posted by zxaar Quote
your bad luck, either your cam is bad or the battery.
Anyway good that you returned.

for me, used nimh batteries today took around 250 photos, still working fine.
I think pentax should fix this bug, if it is possible to fix in firmware it would be wonderful for people who want buy and use it.
It is hopefully a fixable problem in firmware. If my second camera has this problem, instead of sending it to B&H for yet another camera, I will just call Pentax USA and have them fix the problem.

I can tell the rest of you folks who have not seen the camera, it is a little thing, that feels very nice in your hands. I did not get to take any photos, but from all reports it's high ISO and good DR is exactly what I've been looking for.

This camera, a 15mm DA and my 18-250mm DA in my little Domke bag will fill the bill very nicely as a walk around set up. The fact that the 18-250mm is a bit slow now does not matter much as higher ISO's in this camera are fantastic (according to what I've seen).

I might add from the little I played around with the K-x ..... It focuses MUCH faster than my K20D's or my K200D's ..... and I do mean MUCH faster.


wll
10-31-2009, 10:05 AM   #12
Veteran Member




Join Date: Mar 2009
Location: Perth Australia
Photos: Albums
Posts: 1,512
You DIDNT try another set of batteries first?
10-31-2009, 10:19 AM   #13
Veteran Member
tomtor's Avatar

Join Date: Apr 2008
Location: Netherlands
Posts: 382
Rayovac hybrids

See my thread about the Varta 2100 hybrids which are probably the same as the Rayovacs. Bottom line, the eneloops and high capacity non hybrids seem to work better, but I got the 2100 hybrids to work with some effort:

https://www.pentaxforums.com/forums/pentax-dslr-discussion/78157-flash-batter...periences.html
10-31-2009, 10:46 AM   #14
Senior Member




Join Date: Aug 2007
Location: Perth, Australia
Posts: 268
I have varta 2100 hybrid too. So far it works very well.
I'm on my 3rd set of four. First was Eneloop, then Varta, and now back to Eneloop.
The first 2 sets got me around 1000 photos. I use lifeview to focus quite a bit, and tried some Adhoc video as well.

Nice little cam. All my Nikon friends are amazed by the high iso shoots at 3200 and 6400. I can say the photos from D90 ISO1600 can't even get close to Kx at the 3200 setting.
10-31-2009, 11:13 AM   #15
Veteran Member
tomtor's Avatar

Join Date: Apr 2008
Location: Netherlands
Posts: 382
QuoteOriginally posted by mcjm78 Quote
I have varta 2100 hybrid too. So far it works very well.
I'm on my 3rd set of four. First was Eneloop, then Varta, and now back to Eneloop.
The first 2 sets got me around 1000 photos. I use lifeview to focus quite a bit, and tried some Adhoc video as well.

Nice little cam. All my Nikon friends are amazed by the high iso shoots at 3200 and 6400. I can say the photos from D90 ISO1600 can't even get close to Kx at the 3200 setting.
Yes, it's a nice little cam.

Good to hear that it works also for you. Did you never had start-up troubles after placing the batteries? Have you Auto or the NiMH setting in your configuration?
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
battery, brand, camera, dslr, k-x, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-5 battery problem? camera problem? user problem? imtheguy Pentax K-5 39 11-03-2010 06:02 PM
CIF worked yesterday, but not today Squier Pentax DSLR Discussion 23 10-09-2010 07:18 PM
For Sale - Sold: Pentax K10D (w/ extras) & BG2 Battery Grip w/ battery (US/CAN) DaveInPA Sold Items 2 07-02-2010 01:09 PM
yesterday or today? dcmsox2004 Post Your Photos! 5 09-07-2009 07:45 AM
Optio S60 BATTERY DEPLETION & Shut Down Problem fxg Pentax Compact Cameras 6 04-15-2008 06:35 AM



All times are GMT -7. The time now is 02:38 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top