Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-22-2009, 04:20 PM   #1
Forum Member




Join Date: Mar 2009
Posts: 52
k100d MF/AF toggle switch stuck in MF

Hi all,

The toggle switch that allows me to switch between MF and AF on the body is stuck in MF. However, when I have an AF lens mounted, the AF works fine. I'm able to move the switch down a little bit, about halfway between MF and AF, but it still doesn't lock into AF.

There's been some discussion of this on a flickr forum, but no one really has said why, or how to fix it. Thoughts? Is this something I ought to look into repairing? Am I damaging my camera by doing it this way?

11-23-2009, 02:42 PM   #2
Forum Member




Join Date: Mar 2009
Posts: 52
Original Poster
Additioanlly, when mounting a pentax MF lens, I'm still unable to move that toggle switch off of MF. Hope this helps.

Last edited by summatusmentis; 11-23-2009 at 02:43 PM. Reason: fixing redundancy
11-23-2009, 06:33 PM   #3
Site Supporter
Site Supporter
Steve Beswick's Avatar

Join Date: Apr 2009
Location: Ontario, California
Photos: Gallery
Posts: 1,584
I don't actually know the answer to your question, but I can feel you this: when the switch is in manual the AF drive shaft should be recessed into the body. If your AF is still working then this is not the case. Pressing the lens release button also pulls the shaft into the body. Byabe try moving the switch while it's pressed? I'm just throwing an idea out there. If it works then great, but don't blame me if it makes things worse.
11-23-2009, 06:55 PM   #4
Forum Member




Join Date: Mar 2009
Posts: 52
Original Poster
I appreciate the suggestion, but it didn't do anything. When watching what happenes when I press the lens release button, the shaft gets pulled into the body. However, when a lens is off, the shaft defaults to being out of the body, despite the fact that I'm stuck in MF mode.

11-23-2009, 11:32 PM   #5
Site Supporter
Site Supporter
Steve Beswick's Avatar

Join Date: Apr 2009
Location: Ontario, California
Photos: Gallery
Posts: 1,584
Hmm - it sounds like the switch has "jumped". This is just another one of my wacky ideas, but you could try unscrewing the lens mount and taking a look. You might want to run this idea by someone else before you do it though.
11-23-2009, 11:41 PM   #6
Forum Member




Join Date: Mar 2009
Posts: 52
Original Poster
can you explain more by what you mean when you say "jumped"?
11-25-2009, 10:39 PM   #7
Site Supporter
Site Supporter
Steve Beswick's Avatar

Join Date: Apr 2009
Location: Ontario, California
Photos: Gallery
Posts: 1,584
QuoteOriginally posted by summatusmentis Quote
can you explain more by what you mean when you say "jumped"?
Sorry my response has taken so long. I'm still trying to figure out how to word it. I guess the closest thing I can imagine is a gear that has jumped a tooth relative to it's mate. This is all just educated guessing of course.
11-26-2009, 09:22 AM   #8
Inactive Account




Join Date: Nov 2008
Location: USA
Posts: 924
The MF/AF switch can not be reached through the mount itself. It requires removal of front body panels.
Here is a link to the older service manuals for the K100D and others. Downloads

The password is 8639 for all manuals.

11-26-2009, 03:35 PM   #9
Forum Member




Join Date: Mar 2009
Posts: 52
Original Poster
How reasonable is it to try and repair it myself? Would it be better to just go to a camera store and see what it would cost there? Or is it safe to try and do it myself?
11-26-2009, 03:52 PM   #10
Inactive Account




Join Date: Nov 2008
Location: USA
Posts: 924
If you have never tackled something like this, or feel nervous. You may want to see about getting a quote from a repair shop.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
af, camera, dslr, k100d mf/af toggle, mf, mf/af toggle switch, photography, switch, toggle
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K100D Stuck/bad pixels -Joe- Pentax DSLR Discussion 17 10-30-2009 12:05 PM
Help! Autofocus switch stuck on AF.S and will not autofocus! pauldiebel Pentax DSLR Discussion 3 09-19-2009 08:59 PM
K100D stuck in Tv mode ToddM Pentax DSLR Discussion 5 08-27-2009 07:19 PM
NOOB : Toggle 'tween custom settings voicelit Pentax DSLR Discussion 11 09-27-2007 10:42 AM
Non Pentax lenses cannot use "Switch dst msr pt" in K100D?? raider Pentax SLR Lens Discussion 4 08-05-2007 06:50 AM



All times are GMT -7. The time now is 07:14 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top