Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-04-2009, 07:12 AM   #61
Forum Member




Join Date: Oct 2009
Location: Colorado
Photos: Albums
Posts: 91
pbo -

I got an error unpacking in Vista 64 too. Something like "the program did not install correctly". But the files did unpack, although I had to change the default directory. When I extracted them to the Desktop, I used them to successfully update my K-x.

My results: Two changes. No need for LV trick and no waiting after inserting good batteries.

Eneloops - Now work very well. I can turn on the camera as soon as I insert them and get green status. They worked before but had to sometimes use LV trick, and had to wait 30 seconds after installing before turning camera on.

LaCrosse 2700's NiMH - Now work well. Can turn on camera instantly. Previously require LV trick and waiting after install.

Various old 1800 NiMH - Camera won't turn on instantly, but if I wait a minute, camera will power up to black status and I can take a picture. I'm not going to use these in the camera.

12-04-2009, 07:14 AM   #62
Senior Member
piesforyou's Avatar

Join Date: Dec 2009
Photos: Albums
Posts: 129
QuoteOriginally posted by blu3ness Quote
I'm using win 7 64 bit and it worked for me... just saying... might be a singular issue here.
Ditto.

Kx battery problems, a thing of the past!? What a relief!
12-04-2009, 02:06 PM   #63
Forum Member




Join Date: Nov 2009
Location: Kern County California
Photos: Albums
Posts: 59
QuoteOriginally posted by Eruditass Quote
...

I will update my wishlist thread....
I was hoping they would add that time-lapse recording feature that I saw someone here complaining about. That's just about the only "fun feature" now missing on the K-x compared to the Canon G9 I was considering before.
12-06-2009, 01:25 PM   #64
Veteran Member




Join Date: Sep 2007
Location: USA
Posts: 1,812
This is now available on the USA PentaxImaging.com site - had been since before this weekend and for some inexplicable reason I could not access the page over most of this weekend - I am just now able to access it.

Manuals and Literature - Official PENTAX Imaging Web Site

I don't think I can give a direct access page - have to select product type, then Kx, then choose Firmware.

But the Windows version is at:

http://www.pentaximaging.com/images/temp/63395216872278534951591kx_e101w.exe

12-07-2009, 12:42 PM   #65
New Member




Join Date: Dec 2009
Location: Mumbai
Posts: 2
Anyone tried out a battery test with a brand new set and the new firmware? I know it's a little early, but just trying my luck. I am a big fan of this camera. Used my friend's once. Want to buy it.

Also, I don't use LV at all. Maybe once in every 200 shots. And I certainly am not going to record videos on my DSLR. Does anyone know how long the batteries will last using only the viewfinder and not using the video mode and the LV?

Thanks
12-08-2009, 06:35 AM   #66
Senior Member




Join Date: Feb 2009
Location: Pilsen, Czech Republic
Posts: 224
QuoteOriginally posted by nikhils Quote
Anyone tried out a battery test with a brand new set and the new firmware? I know it's a little early, but just trying my luck. I am a big fan of this camera. Used my friend's once. Want to buy it.

Also, I don't use LV at all. Maybe once in every 200 shots. And I certainly am not going to record videos on my DSLR. Does anyone know how long the batteries will last using only the viewfinder and not using the video mode and the LV?

Thanks
My Eneloops lasted over 1200 shots this weekend with firmware 1.01.
12-08-2009, 06:39 AM   #67
Veteran Member




Join Date: Jul 2009
Location: kobe/japan
Posts: 510
QuoteOriginally posted by nikhils Quote
Anyone tried out a battery test with a brand new set and the new firmware? I know it's a little early, but just trying my luck. I am a big fan of this camera. Used my friend's once. Want to buy it.

Also, I don't use LV at all. Maybe once in every 200 shots. And I certainly am not going to record videos on my DSLR. Does anyone know how long the batteries will last using only the viewfinder and not using the video mode and the LV?

Thanks
with new firmware the battery issue is just non-issue. If you are on fence do not wait.
12-08-2009, 12:22 PM   #68
Veteran Member




Join Date: Sep 2007
Location: USA
Posts: 1,812
remaining capacity of half Orange eneloops

Just did my Kx Firmware update -
being the cautious type I topped up a set of eneloops
- and took a picture of that, and the SD card I was using, just for evidence....

After the successful update - I replaced the just topped up eneloops with the set that was in the Kx before the update, ie: the set I took my evidence photo with.

I was somewhat surprised that the set of eneloops which showed Green full, now shows half Orange. I did all the usual tricks of turning off, LV, trying battery type NiMH and Auto-Detect and back; and even reinserting that set and waiting a good 15 secs before turning on - but the state remained a consistent half orange.

I had used that set (shot count 381, no flash) but on version 1.00 it would have continued to show full Green -
now with 1.01 it is showing consistently half orange.

This may well be more accurate -
but I thought people would like to know that perhaps version 1.01 may not show full Green as often now.

Here are the PhotoMe extracts of the battery information:

BEFORE Update -

in field Battery States - Body Battery: 4 which I think means Green Full

AFTER Update to 1.01 -

Battery States - Body Battery: 3 = half Orange.

EDIT to ADD -

I discharged that set of eneloops which now show half Orange to see the remaining charge/capacity.

1345; 1333; 1381; 1355 mAh (average = 1353.5mAh)

This means that those eneloops were roughly between 68-71% charged ie: more than 2/3 full - I would have expected to see as Green battery - but they definitely showed a half Orange - and according to the manual this is supposed to mean:

"Batteries are running low" -

over 2/3 full eneloops canNOT be considered as "running low" by any stretch of the imagination as they have really only taken 381 shots at that stage (and I have shown they are capable of nearly 1,300 shots per charge and the ending capacity is more like in the range of 20-40mAh) -

so could there be a possible problem still with battery level indication even in firmware version 1.01?


Last edited by UnknownVT; 12-09-2009 at 10:01 AM.
12-14-2009, 07:24 AM   #69
Veteran Member




Join Date: Nov 2009
Location: Hong Kong
Posts: 1,352
Just received my K-x... anyone know how to check what firmware is loaded? (sorry, left the manual in my office).

Thanks.
12-14-2009, 07:59 AM   #70
Veteran Member
Eruditass's Avatar

Join Date: Jul 2009
Location: Pittsburgh, PA
Photos: Gallery | Albums
Posts: 2,206
QuoteOriginally posted by UnknownVT Quote
Just did my Kx Firmware update -
being the cautious type I topped up a set of eneloops
- and took a picture of that, and the SD card I was using, just for evidence....

After the successful update - I replaced the just topped up eneloops with the set that was in the Kx before the update, ie: the set I took my evidence photo with.

I was somewhat surprised that the set of eneloops which showed Green full, now shows half Orange. I did all the usual tricks of turning off, LV, trying battery type NiMH and Auto-Detect and back; and even reinserting that set and waiting a good 15 secs before turning on - but the state remained a consistent half orange.

I had used that set (shot count 381, no flash) but on version 1.00 it would have continued to show full Green -
now with 1.01 it is showing consistently half orange.

This may well be more accurate -
but I thought people would like to know that perhaps version 1.01 may not show full Green as often now.

Here are the PhotoMe extracts of the battery information:

BEFORE Update -

in field Battery States - Body Battery: 4 which I think means Green Full

AFTER Update to 1.01 -

Battery States - Body Battery: 3 = half Orange.

EDIT to ADD -

I discharged that set of eneloops which now show half Orange to see the remaining charge/capacity.

1345; 1333; 1381; 1355 mAh (average = 1353.5mAh)

This means that those eneloops were roughly between 68-71% charged ie: more than 2/3 full - I would have expected to see as Green battery - but they definitely showed a half Orange - and according to the manual this is supposed to mean:

"Batteries are running low" -

over 2/3 full eneloops canNOT be considered as "running low" by any stretch of the imagination as they have really only taken 381 shots at that stage (and I have shown they are capable of nearly 1,300 shots per charge and the ending capacity is more like in the range of 20-40mAh) -

so could there be a possible problem still with battery level indication even in firmware version 1.01?
Did you have it set in AUTO or NiMH mode?

I had discovered the meter wasn't any more accurate (particularly in AUTO), but the camera certainly lasted longer. One set of batteries in AUTO showed red but lasted for hundreds of shots. My recently charged eneloop show green in NiMH but kodak pre-charged only show orange (even in NiMH iirc).
12-14-2009, 09:08 AM   #71
Veteran Member




Join Date: Nov 2009
Location: Hong Kong
Posts: 1,352
I should add, on my 'loops I've had no battery issues.
12-14-2009, 09:49 AM   #72
Pentaxian




Join Date: Mar 2009
Location: Perth Australia
Photos: Albums
Posts: 1,511
your firmware is old, there is no way any Kx's are shipping with the new firmware yet.
12-14-2009, 09:53 AM   #73
Veteran Member
Eruditass's Avatar

Join Date: Jul 2009
Location: Pittsburgh, PA
Photos: Gallery | Albums
Posts: 2,206
QuoteOriginally posted by Unsinkable II Quote
Just received my K-x... anyone know how to check what firmware is loaded? (sorry, left the manual in my office).

Thanks.
One way is loading the firmware upgrade, on the screen before you hit OK it says current firmware version.
12-14-2009, 10:33 AM   #74
Veteran Member




Join Date: Sep 2007
Location: USA
Posts: 1,812
QuoteOriginally posted by Eruditass Quote
Did you have it set in AUTO or NiMH mode?
I have my Kx set on NiMH.

While trying out the previous eneloops that were over 2/3 full and showed full Green on firmware 1.00 - but showed half Orange on FW 1.01 -
I switched from NiMH to Auto-Detect (tried that for a while including most of the former "tricks" - but continued to show half Orange) -
switched it back to NiMH (again tried most of the "tricks") those 2/3 full eneloops continued to show half-orange.

Kx was on NiMH when I put in a freshly topped-up charged set of eneloops - and got full Green.

This set of eneloops have now taken 362 shots - and still show full Green - on what I would consider my "normal usage" - a few, but mostly no flash (1 sec review, 1 min power save - no LV or movies; fair amount of, but not excessive reviewing) -
please remember I did manage to achieve just under 1,300 shots on eneloops in FW 1.00 - under similar circumstances (but probably more playing around since the Kx is/was new).

All my eneloops are in v. good condition, and individually id/numbered -
I use a Maha C9000 for analyzing and charging of these.

QuoteOriginally posted by Eruditass Quote
My recently charged eneloop show green in NiMH but kodak pre-charged only show orange (even in NiMH iirc).
This seems inconsistent -
I also have 2 sets of Kodak Pre-Charged
- on a straight run from charged these have more capacity than eneloops
and last longer in almost all practical tests (eg: runtime in flashlights).

But over about 3 months the Kodak Pre-Charged although do retain capacity
- do not maintain their voltage as well as eneloops
- resulting in (over months) fewer shots than eneloops
- despite the fact the Kodak Pre-Charge may still have quite respectable remaining capacity
- similar (but not as drastic) as the regular NiMH OutOfFocus tested on FW1.00 in your other thread:
K-x owners: NiMH batteries results please

You can read about this in a rather long and (complex) exploratory thread on CPF -

eneloop vs. Kodak Pre-Charged Voltage Maintenance

the short version - an attempt at summary is in Post #57

Last edited by UnknownVT; 12-14-2009 at 10:57 AM. Reason: comments on Kodak Pre-Charged
12-14-2009, 10:58 AM   #75
Veteran Member
Eruditass's Avatar

Join Date: Jul 2009
Location: Pittsburgh, PA
Photos: Gallery | Albums
Posts: 2,206
I remember reading that thread and thought the orange reading made sense because of your point:
QuoteQuote:
(1) I have demonstrated that the eneloops do maintain a higher operating voltage under load than the Kodak Pre-Charged by using static fixed resistors - 0.5, 1, 2 ohms (with current draws of about 2+A, 1.2A, 0.6A respectively) using fully charged and about 1/2 discharged batteries - Posts #41, #44 , #47
And the understanding that the K-x assigns a meter level based on voltage under load - since the Kodaks have higher internal resistance and lower voltage under load - it would make sense that they show orange - despite the fact that they very well may have a higher capacity. Anyways, the K-x liked to stay alive for hundreds of shots on one of my batteries when in RED with no battery depeleted message.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, k-x 1.01 firmware, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Firmware? Naturenut Pentax DSLR Discussion 10 08-03-2010 06:37 AM
K-7 Firmware 1.02 konraDarnok Pentax News and Rumors 1 10-22-2009 08:01 AM
New K7 firmware... dlacouture Pentax DSLR Discussion 9 10-07-2009 10:09 AM
When do we get the new firmware? ottoangel Pentax DSLR Discussion 1 04-19-2009 12:05 PM
Firmware 1.11 benjikan Pentax DSLR Discussion 21 03-15-2007 10:41 AM



All times are GMT -7. The time now is 09:50 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top