Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-23-2009, 07:32 AM   #91
Veteran Member




Join Date: Sep 2007
Location: Edmonton, AB, Canada
Posts: 408
Usually you don't have to reformat the card. But then again, I usually format all my cards as soon as they are removed from the package.

Enjoy your new firmware.

12-23-2009, 08:36 AM   #92
Senior Member




Join Date: Jan 2008
Location: Madison (Verona), WI
Photos: Gallery
Posts: 144
Can someone list what the new firmware changes, other than the battery issue?
12-23-2009, 08:56 AM   #93
New Member




Join Date: Dec 2009
Posts: 12
Yes, I had to different 16 GB cards, one was brand new. So I didn't understand what the problem could be in trying both to update the firmware. If this helps someone else, great.

It's good to join the club. First really nice DSLR camera. Owned the original Nikon digital when it came out and also have the Panasonic TZ5 but this is a whole new ballgame. And the red is certainly unique.

Thanks again for the help.

Last edited by smartyjones; 12-23-2009 at 11:02 AM.
12-24-2009, 03:25 PM   #94
Junior Member




Join Date: Dec 2009
Location: Houston, TX
Posts: 37
Can anyone confirm whether or not it's okay or recommended to use the AC adaptor while doing the update instead of relying on batteries?

12-24-2009, 04:02 PM   #95
Inactive Account




Join Date: Dec 2009
Location: San Jose
Posts: 24
It's actually recommended in the document to use AC if you have the optional AC adaptor.
12-25-2009, 05:14 AM   #96
Veteran Member
Nomad's Avatar

Join Date: Dec 2009
Location: Maine
Photos: Gallery | Albums
Posts: 406
Updated

Merry Christmas to all (and happy holidays),
We just opened up my wife's new k-x and had all sorts of battery issues with brand new Eneloops as well as ones that I had charged earlier this week.
Kept "fiddling" with the different sets until I got a green indicator and uploaded the firmware.
All sets are now showing green( as they should) and no other problems to report....except that we are both new to digi and very intimidated!!
TIME TO LEARN AND PLAY!!!
BTW everyone has been a huge help so far and this forum has proven to be invaluable...thanks to all!!
12-28-2009, 06:00 PM   #97
New Member
daniel_1234's Avatar

Join Date: Dec 2009
Location: NE Florida, USA
Photos: Gallery
Posts: 21
New K-x owner here. I installed the new firmware no problem. It only took about two minutes but it seemed much longer since I think I had stopped breathing while staring at the screen waiting for the "Complete" message . Thanks to all who contributed to this thread, it has been a big help.
01-01-2010, 06:53 AM   #98
New Member




Join Date: Jan 2010
Location: Hong Kong
Posts: 18
Pentax Kx + Tamron sp af 17-50mm f/2.8 xr ld aspherical

I got troubles after upgrade the Kx firmware to 1.01; the TAMRON len was function abnormally, all the focus/aperture etc. indicators were fluctuated/refreshed continusously and unexpectedly. I can't access any menu since the LCD display was kept refreshing.

Does anyone has such experience before? Neither downgrade files nor methods could be found at Pentax offical sites. It's terrible to a new DSLR guy.

Please kindly help...

Henry from Hong Kong

01-01-2010, 07:22 AM   #99
Site Supporter
opiedog's Avatar

Join Date: Jan 2008
Location: NC
Posts: 787
Original Poster
henry,

have you tried a different lens? does the kx do the same fluctuation w/ other lenses?
i dont' have a 17-50 tammy, but so far, my tamron 18-250 and sigma 17-70 works ok with the new fw.

YMMV

jordan
01-01-2010, 06:33 PM   #100
New Member




Join Date: Jan 2010
Location: Hong Kong
Posts: 18
Pentax Kx + Tamron sp af 17-50mm f/2.8 xr ld aspherical

jordan,

thanks for your reply.

kx was functioned normally with other lens (included tamron 18-250 which tested at retail shop). i think the problem was only occurred on 3rd party lens with fixed aperture. i had contacted Hong Kong support and he refused for a downgrade action. furthermore, it's not pentax responsibility to support 3rd party lens. i'm horribly upset that I can't use this great and reasonsble price len (Tamron sp af 17-50mm f/2.8 xr ld aspherical)

I have only two choices; either give up the Tamron len or hope for a fix of new firmware release

Henry from Hong Kong
01-01-2010, 07:20 PM   #101
Site Supporter
opiedog's Avatar

Join Date: Jan 2008
Location: NC
Posts: 787
Original Poster
henry,

i don't think the fw should cause problems with the tamron 17-50 specifically.

when you flashed the firmware, did it get to the "completed" screen? i.e., no errors?

you could try reflashing again with fresh, newly charged batteries.

good luck.

jordan

Last edited by opiedog; 01-01-2010 at 07:44 PM.
01-02-2010, 12:28 AM   #102
New Member




Join Date: Jan 2010
Location: Hong Kong
Posts: 18
Pentax Kx + Tamron sp af 17-50mm f/2.8 xr ld aspherical

jordan,

thanks for your help and reply. i'd already tried to refresh the firmware again. as you know, if upgrade process was failed, the camera should not be functioned. unfortunately, the result was negative. i give up and had changed with another len from retail shop; TAMRON af18-250 f/3.5-6.3 ld aspherical (if) macro.

actually, i really love TAMRON fixed aperture len; reasonable price and good quality. why can't i use it??? i'll never upgrade firmware again, this is a terrible experience

may be i need to wait further...make more money to purchase an expensive Pentax len or wish there would be a firmware fix in coming future

henry from hong kong
01-02-2010, 12:50 AM   #103
Senior Member




Join Date: Aug 2009
Location: Houston, TX
Photos: Gallery
Posts: 141
QuoteOriginally posted by henrywmk Quote
i think the problem was only occurred on 3rd party lens with fixed aperture.
My K-x with firmware 1.01 works fine using a Tamron 35-70mm f3.5 manual lens (fixed maximum aperture) using an adaptall-2 adaptor for KM mount.
01-02-2010, 01:06 AM   #104
Pentaxian




Join Date: Sep 2007
Location: Boston, MA
Posts: 7,411
I've been using my 17-50/2.8 with my K-x on firmware 1.01 without any problems...
01-02-2010, 01:23 AM   #105
New Member




Join Date: Jan 2010
Location: Hong Kong
Posts: 18
dear OutOfFocus & deadwolfbones,

that's really a great news for me, but how come i can't. it was failed even testing on several Kx 1.01 bodies. are you using extra adaptor or bundle mount with TAMRON len? i am sure firmware 1.00 was working fine on this good quality len; the only difference was firmware.

one more thing: are you using old TAMRON models without AF??? it seems like this was another differ

henry from hong kong

Last edited by henrywmk; 01-02-2010 at 01:40 AM.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, k-x 1.01 firmware, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Firmware? Naturenut Pentax DSLR Discussion 10 08-03-2010 06:37 AM
K-7 Firmware 1.02 konraDarnok Pentax News and Rumors 1 10-22-2009 08:01 AM
New K7 firmware... dlacouture Pentax DSLR Discussion 9 10-07-2009 10:09 AM
When do we get the new firmware? ottoangel Pentax DSLR Discussion 1 04-19-2009 12:05 PM
Firmware 1.11 benjikan Pentax DSLR Discussion 21 03-15-2007 10:41 AM



All times are GMT -7. The time now is 06:39 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top