Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-16-2009, 01:09 PM   #1
New Member




Join Date: Dec 2009
Posts: 8
New DSLR K-x troubles

Hi guys.

I turn to you in my time of troubles!

Finally decided what DSLR to go for, it's the K-x.

Arrived in the post today. Happy as Larry.

However, I cannot get the camera to take pictures! I've followed the manual. When I attached a lense, the camera will not take a picture. There is no shutter action at all. Removing the lense, the shutter works.

I cannot fathom it out. It should really work right out of the box.

Gutted to say the least.

Any ideas/guidence please would be greatly appreciated, before I think about sending it back

12-16-2009, 03:27 PM   #2
Pentaxian




Join Date: Jun 2009
Location: GMT +10
Photos: Albums
Posts: 10,832
More details pls. Which lens are you using?
12-16-2009, 03:46 PM   #3
Junior Member




Join Date: Jul 2009
Location: London
Photos: Gallery
Posts: 42
Double check that the batteries are installed in the correct order... it's a different sequence than my K200D, so I still put one of them in backwards from time to time.
12-16-2009, 09:54 PM   #4
Pentaxian
Marc Sabatella's Avatar

Join Date: Sep 2006
Location: Denver, CO
Photos: Gallery
Posts: 10,686
Does the lens try to focus? Does it appear to succeed? Does the green hexgon focus confirmation indicator appea rin the viewfinder? What exposure mode are you in on the main dial?

12-17-2009, 12:29 AM   #5
Veteran Member
inferno10's Avatar

Join Date: Feb 2007
Location: San Francisco, California
Posts: 342
Based on what you said (unable to take a shot w/ lens mounted, but able to take a shot when lens isn't mounted), my initial guess would be that you're using a lens that has an aperture ring.

Check the info screen. If the info screen is flashing "F--", then you are probably using a lens with an aperture ring. Either set the aperture to the 'A' position, or set Custom option 22 ("Using Aperture Ring") to Permitted. This is found in the menu under page 4 of the C tab.

If that does not fix your problem, please provide some additional details, such as lens causing the issue, whether AF works, whether you've tried any other lenses, etc.

Please refer to the Pentax Beginner's Q&A section for additional tips & tricks: https://www.pentaxforums.com/forums/pentax-beginners-corner-q/

- Jason
12-17-2009, 10:42 AM   #6
Pentaxian
Marc Sabatella's Avatar

Join Date: Sep 2006
Location: Denver, CO
Photos: Gallery
Posts: 10,686
Great guess. I'd just add if that is the problem, and the lens doesn't have an "A" position on the ring, then check out the sticky thread at the top of the Beginner's forum for compelte instructions on using manual lenses on a Pentax DSLR - there's more to it than just setting that custom option.
12-17-2009, 11:45 AM   #7
Veteran Member




Join Date: Aug 2007
Photos: Gallery
Posts: 1,563
Ok, it is clear what the camera does not do.
However, can you please describe what it does do?
- Does life view work?
- Does it auto focus?
- Can you enter the menu screens?
- What does the status display tell you?
- Can you format the SD card?
- ...
-

= Bert
12-17-2009, 12:47 PM   #8
Senior Member
blu3ness's Avatar

Join Date: Oct 2009
Location: Edmonton, Alberta
Posts: 117
if you ar eusing kit lens... was the lens put on correctly? did you hear it snap into place? If you are using a manual lens, ensure that the aperture "F---" number is not flashing (aka config the aperture ring option).

Now, when you try to take a picture half pressing the shutter button, does the lens motor move at all in trying to focus??

You need to provide more details...

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, k-x, lense, photography, shutter, troubles
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Metering troubles with K7 fourmiX Pentax DSLR Discussion 15 12-10-2012 02:09 AM
K-x raw troubles audiobomber Pentax DSLR Discussion 3 12-31-2009 06:11 PM
Troubles but cool... metroeloise Post Your Photos! 5 08-23-2009 12:51 PM
50-135mm troubles or is it me? branphlake Pentax SLR Lens Discussion 4 08-17-2009 10:30 PM
Flash Troubles CAPTURE Troubleshooting and Beginner Help 7 07-02-2009 03:35 PM



All times are GMT -7. The time now is 04:02 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top