Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-21-2009, 08:46 AM   #1
New Member




Join Date: Dec 2009
Posts: 6
Unresponsive shutter button

Hi guys, really hope someone can help me with this. I've had the Pentax K100D with a manual 50mm lens for the last three years. I use it almost every day and it's never had any problems until now. I usually use the lithium one time batteries, but have recently started using rechargeable ones. I went to use it today and the shutter button just doesn't do anything. No response, if I push it halfway it still shows the little red focus icon so it's definitely connected, just if I push it all the way down it won't take a picture.

Really can't afford to upgrade! Any ideas?
Thanks so much.

12-21-2009, 04:19 PM   #2
Loyal Site Supporter
pacerr's Avatar

Join Date: Jan 2008
Location: Henry, TN
Photos: Gallery | Albums
Posts: 2,910
Coupl'a possibilities:
Verify there's a good SD card installed.
Go back to a known good set of lithiums.
Verify shutter release without focus lock is ON.
Reset all menu options to basic mode.
H2
12-21-2009, 04:31 PM   #3
Veteran Member
GerryL's Avatar

Join Date: Jan 2009
Location: CA
Posts: 2,731
Welcome to the forums naomirose!
If after trying everything and it still doesn't function, then your shutter mechanism might be the culprit and might need replacing.
It should last 100,000 shutter clicks but there had been reports that they at times fail sooner.
Others yet reported as saying, theirs were still functioning after more than 100,000 clicks.
12-22-2009, 08:51 AM   #4
Loyal Site Supporter




Join Date: Jun 2009
Location: Tumbleweed, Arizona
Photos: Gallery | Albums
Posts: 5,107
I would also try a new set of just AA's, just to make sure that there is not the voltage problem with the re chargeables.

12-22-2009, 09:21 AM   #5
Senior Member
TheTenaciousOne's Avatar

Join Date: Jul 2009
Location: Adelaide, SA, Australia
Photos: Gallery
Posts: 111
Might have to check whether you've accidentally set the camera to AF-S as it wont fire unless the subject is in focus
12-22-2009, 09:34 AM   #6
Pentaxian
Marc Sabatella's Avatar

Join Date: Sep 2006
Location: Denver, CO
Photos: Gallery
Posts: 10,686
Is this an "A" series len and you've accidentally knocked the aperture ring off the "A" position? Or did you perhaps accidentally reset the "Using Aperture Ring" custom function to "Prohibited"? That or being in AF mode strike me as most plausible. If none of those turn out to be it, do you have no other lenses you could test with? Any one you know or any stores with any pentax lenses?
12-22-2009, 09:47 AM   #7
New Member




Join Date: Dec 2009
Posts: 6
Original Poster
I just tried to reply but I guess it got lost...as I was saying. I just got some new lithium AA's and put them in, which hasn't changed a thing unfortunately. I've formatted the memory card and reset all the menu settings to the standard which also hasn't changed anything, but now if I hold the 'ok' button and press the shutter release it'll take a photo so obviously the shutter release button's still working.

A few of you have said I need to 'Verify shutter release without focus lock is ON.' how do I do this? I can't find the menu option?

Also tested it with another manual lens a 28mm and still the same problem. thanks again!
12-22-2009, 02:53 PM   #8
Junior Member
Charles Hueter's Avatar

Join Date: Oct 2008
Location: Austin, TX
Photos: Gallery
Posts: 42
The most common reason my K100D doesn't shoot with an old manual lens when I press the shutter is because I have the autofocus switch near the lens mount set to AF rather than MF.

12-22-2009, 03:19 PM   #9
New Member




Join Date: Dec 2009
Posts: 6
Original Poster
OH MY GOD. I must have just nudged it! I can't believe I'm so stupid! That was exactly the problem, thankyousomuch!!!
05-13-2014, 08:45 AM   #10
New Member




Join Date: May 2014
Posts: 1
Hello,

Im new to this thread so apologies in advance. I seem to be having the exact same problem but the AF MF switch doesnt seem to fix it.

When switching through the wheel the screen flashes and goes black, I cant even half press the shutter for a response either. I can go through the menu and function displays fine but cannot seem to take a picture.

Any help/adivce will be greatly appreciated.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
button, camera, dslr, photography, shutter
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Q regarding shutter button on K200D esman7 Pentax DSLR Discussion 22 01-05-2010 02:14 PM
ME Super stuck winding lever & unresponsive shutter Charles Hueter Pentax Film SLR Discussion 11 07-12-2009 11:26 AM
ME Super shutter button sticking? oinkely Pentax Film SLR Discussion 3 03-01-2009 01:51 PM
K20D shutter button feel Riktar Pentax DSLR Discussion 14 02-27-2009 09:08 AM
Shutter button - where to find one? Duh_Vinci Pentax Camera and Field Accessories 9 08-05-2007 07:22 PM



All times are GMT -7. The time now is 07:17 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top