Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-02-2010, 07:32 PM   #16
Pentaxian
JohnBee's Avatar

Join Date: Sep 2008
Location: front of computer
Posts: 4,496
Original Poster
QuoteOriginally posted by tmalkiew Quote
John,

Please have a look in this thread I Posted soon after I got my K20D. The issue you described happens to mine camera on regular basis. It is ususally happening after a period of inactivity. After it does the first good shot it's ok then. Sent it to Pentax but they didn't find any fault - had to pay for shipment. Looking forward to more observations. The only thing I can add is that I do not have the grip...

Best regards

Tom
Hi,

Had a look at your description, though the symptoms would seem different.
I've narrowed my own lock-up behavior directly to my PC card reader.

Though unlike your own experience, I was never able to reproduce the error without PC reader intervention in the mix. That is to say, I've turned off my camera for days at a time with various conditions without ever seeing a lock-up. However, the moment I introduce the PC reader into the process, lock-ups do follow.

What does bother me however, is that I was never able to create the same problem with our K200D(???) using the same procedures. Which raises a few questions as to why the K200D would tolerate the same hardware processes and the K20D cannot.

Having said that, the issue to date seems limited to the PC reader writing on SDHC in order for lock-ups to occur. So I have yet to test my theory without writes involved.

Still waiting for Pentax to comment on this issue on whether or not they themselves would conclude this to be a malfunction or... a faux-pas scenario.

01-04-2010, 05:19 AM   #17
New Member




Join Date: Apr 2008
Location: Dublin
Posts: 13
QuoteOriginally posted by JohnBee Quote
Hi,

Had a look at your description, though the symptoms would seem different.
I've narrowed my own lock-up behavior directly to my PC card reader.
I wouldn't agree here. I think the symptoms are quite similar to yours, but what worries me is that the reason for them seems quite different. I do not use PC card reader but only USB. Although I did use the card in different camera but always formated it in my k20d before use.

Regards

Tom
01-04-2010, 06:42 AM   #18
Pentaxian
JohnBee's Avatar

Join Date: Sep 2008
Location: front of computer
Posts: 4,496
Original Poster
QuoteOriginally posted by tmalkiew Quote
I wouldn't agree here. I think the symptoms are quite similar to yours, but what worries me is that the reason for them seems quite different. I do not use PC card reader but only USB. Although I did use the card in different camera but always formated it in my k20d before use.

Regards

Tom
having read your description, the only similarities seem to be in the lock-up aspect of things.
However, the images and extended mirror action are nothing like I've seen on my end. Which is what lead me to make the statement.

Though I do think lock-up's are all somewhat similar in nature, I also think that the steps leading up to the lock-ups and/or during the lock-ups play a vital role in identifying the cause(or discrepancy).

Having said that, I'd try a few thing before throwing in the towel with your unit.

1. Clear all settings on the camera
2. Get a new SDHC card and format it using the camera.
3. Flash with latest firmware.

Start afresh, keep card away from any other reader other than camera during duration of tests.
If the problem comes-up again, make arrangements to have camera repaired.
01-04-2010, 06:49 AM   #19
New Member




Join Date: Apr 2008
Location: Dublin
Posts: 13
Also I forgot to mention about the strange buzzing noise coming out from the camera when it's locked - now - this one it's not always happening.

Awaiting new card now - ordered SanDisk x155 4Gb. Will check when arrives.

In the meantime I searched this forum for similar issues and it appears it's too common...

01-04-2010, 07:11 AM   #20
Pentaxian
JohnBee's Avatar

Join Date: Sep 2008
Location: front of computer
Posts: 4,496
Original Poster
I won't pretend to know anything on camera's other than being a user, however the nature of the lockups could very well lend itself to a number of symptoms(noises) as it comes down to when the lockups occur(mid shutter etc etc).

However, it may still be that your camera runs into the problem upon accessing(writing) to the card so I wouldn't loose hope just yet.

On my own side of things, I've found that our lock-ups can only be reproduced on one of our K20D units(not the other or the K200D). At which point, I'm waiting for Pentax to comment on this as a defect or not. I mean... if you have one camera locking-up and the other same model not locking-up... it sort of leaves question marks as to why or how that could happen if they were both identical units.

I can't say I'm impressed with Pentax refusing to acknowledge the problem either(worst trick ever). Which is usually enough to drive customers away from future products. Its just to bad we've seen the same from Nikon and Canon as well

Business is cruel.
01-28-2010, 03:11 AM   #21
Pentaxian
JohnBee's Avatar

Join Date: Sep 2008
Location: front of computer
Posts: 4,496
Original Poster


This problem has been resolved
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
acr, camera, card, data, dslr, frame, issue, k20d, keyboard, pc, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale - Sold: K20D, Battery Grip, NEW K20D battery, cable remote (Worldwide) Albert Siegel Sold Items 6 09-23-2010 08:02 AM
[K20D] Does your SR icon light up when using the AF button to focus? Reportage Pentax DSLR Discussion 4 09-18-2010 10:46 PM
Pentax K20D freezing, locking up - RESOLVED JohnBee Pentax DSLR Discussion 0 01-28-2010 03:09 AM
Update on my K20D freezing BPT Pentax DSLR Discussion 0 02-19-2009 10:45 AM
Battery Grip Serial Number Location? Mark Castleman Pentax DSLR Discussion 2 01-04-2008 12:56 PM



All times are GMT -7. The time now is 06:13 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top