Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-26-2009, 12:23 PM   #1
New Member




Join Date: Sep 2007
Location: Seattle
Posts: 12
K10d - Menu Problems...

I have owned my K10d since Feb '06 and have mostly been happy with it... Lately i have been having problems navigating the various menus with them "blinking" off prematurely. At first it was random and infrequent, now I cannot access any menu long enough to make any changes. It doesn't matter if its the main menu, or the Fn menu to do something simple like change WB. The moment you turn on a menu they immediately close again. The camera shoots and fires fine (except WB is way off, despite being set for auto WB currently, has a very cold blue hue to i with certain lenses but works fine with others). Shutter fires fine, aperture and shutters speeds adjust ok. About every 10th time I turn it on the menu will work for 5 seconds or so and was able to get in and do a reset but that has had no effect on the problem at all.

Anyone see anything like this? At this point I doubt there is any reason to fix it as opposed to a new body.....

12-26-2009, 12:26 PM   #2
Loyal Site Supporter
Canada_Rockies's Avatar

Join Date: Nov 2007
Location: Sparwood, BC, Canada
Photos: Gallery | Albums
Posts: 9,134
If you are considering upgrading to the k20, the batteries are the same. I would swap in a new battery, fully charged, and see what happens, or if you already have a second battery, use that. If you are using the grip, remove it and test. I have two year old batteries, and they are still working, but yours are nearly four years old. There comes a point when you must spring for new batteries. They have a life expectancy, just like the battery in your vehicle.
12-26-2009, 12:28 PM   #3
New Member




Join Date: Sep 2007
Location: Seattle
Posts: 12
Original Poster
Yeah I have two new batteries for it and tried both and then tried one of the older ones after a full charge and it still does the same thing.. I guess I shouldn't complain, its seen a lot of use and travel and the last time I figured it out I was around 150,000 images shot....
12-26-2009, 12:36 PM   #4
Loyal Site Supporter
Canada_Rockies's Avatar

Join Date: Nov 2007
Location: Sparwood, BC, Canada
Photos: Gallery | Albums
Posts: 9,134
QuoteOriginally posted by mrchris Quote
Yeah I have two new batteries for it and tried both and then tried one of the older ones after a full charge and it still does the same thing.. I guess I shouldn't complain, its seen a lot of use and travel and the last time I figured it out I was around 150,000 images shot....
With that many images taken, I think you got more than the mileage expected out of your camera. Go for whichever new one turns your crank - or maybe pick up a good used one in the marketplace.

12-26-2009, 01:12 PM   #5
Veteran Member
kkoether's Avatar

Join Date: Jul 2008
Location: Huber Heights, OH, USA
Photos: Gallery | Albums
Posts: 572
Sounds like a stick push button somewhere. I have a battery grip on my K200D and if I inadvertly hit the shutter button on the grip when it's turned on I get what sounds like the same thing. Just something you might want to look at.
12-26-2009, 02:52 PM   #6
Pentaxian




Join Date: Sep 2007
Location: Bay Village, Ohio USA
Posts: 1,025
EXIF contains shutter count

QuoteOriginally posted by mrchris Quote
Yeah I have two new batteries for it and tried both and then tried one of the older ones after a full charge and it still does the same thing.. I guess I shouldn't complain, its seen a lot of use and travel and the last time I figured it out I was around 150,000 images shot....
You can find out exactly how many times your shutter has been tripped. Just take a picture, load it onto your PC and use Opanda, Photo ME or Exiftools to display the exif data. The shutter count is included for every shot.

I agree that, at 150k shots, you've probably gotten your money's worth. That's a lot of shots.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, fires, k10d, k10d menu, menu, photography, wb
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K10D Service Menu and AF Adjust! nosnoop Pentax DSLR Discussion 54 12-08-2008 02:49 PM
K10D Crashing when changing options in menu? jmdeegan Pentax DSLR Discussion 20 07-14-2008 08:34 AM
K10d-debug menu-IR possible? Bokeh Pentax DSLR Discussion 6 05-17-2008 05:54 PM
Menu Screen on K10D RussellW Pentax DSLR Discussion 12 02-04-2008 07:12 PM
K10D Menu Typos Faither Pentax DSLR Discussion 13 12-02-2006 10:28 PM



All times are GMT -7. The time now is 11:39 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top