Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-04-2010, 08:18 PM   #16
Veteran Member
StephenMerola's Avatar

Join Date: Feb 2009
Location: Southeast Wisconsin
Photos: Albums
Posts: 391
Wow. That is so odd. Please let us know what happens.

01-11-2010, 09:42 PM   #17
New Member




Join Date: Jun 2007
Location: Cali
Posts: 24
Ever since I installed the latest firmware, my photo playback has been funny.
It sometimes makes the rear screen go blank until I hit the shutter button.
Also, I'll be in playback, and when I move the camera body it will automatically go back to shooting mode.

Anyone else have these issues?

I just heard back from the studio I shot for last weekend. They asked if I had trouble getting tack sharp. I initially thought it was my shooting. Didn't even think it could have been the firmware.
01-11-2010, 09:54 PM   #18
Pentaxian
ivoire's Avatar

Join Date: Mar 2007
Location: chicago burbs
Photos: Gallery
Posts: 3,356
Original Poster
Still awaiting the repairs. I'll post an update once the body is returned. Its a nuisance not having a backup, but this a the slow real estate season. Am debating on a used or refurb k10 vs kx as backup if it isn't back soon. I'd hoped to hold out for the next pentax incarnation and retain K7 as backup.
01-12-2010, 03:29 AM   #19
Veteran Member
netuser's Avatar

Join Date: Oct 2008
Location: Azores Islands, Portugal
Photos: Gallery
Posts: 2,241
QuoteOriginally posted by ivoire Quote
........... I'd hoped to hold out for the next pentax incarnation and retain K7 as backup.
That's the best option... if you can wait

01-12-2010, 11:40 AM   #20
Pentaxian
ivoire's Avatar

Join Date: Mar 2007
Location: chicago burbs
Photos: Gallery
Posts: 3,356
Original Poster
QuoteOriginally posted by netuser Quote
That's the best option... if you can wait
I'm working on patience, but the woot deal of a new w/warranty K20D with 18-55 alII lens for $584.99 shipped to my door is like the sirens song.

Yahoo! Shopping - Online Shopping with great products, prices and reviews
01-12-2010, 11:56 PM   #21
Forum Member




Join Date: Dec 2009
Posts: 58
Check this thread: New K7 firmware! [Page 1]: Pentax SLR Talk Forum: Digital Photography Review
01-13-2010, 02:44 PM   #22
Veteran Member
Pentaxor's Avatar

Join Date: May 2009
Location: Vancouver, B.C.
Photos: Gallery
Posts: 6,513
guys, did you try overwriting the latest firmware version with the Japan firmware version?
01-13-2010, 02:49 PM   #23
Pentaxian
ivoire's Avatar

Join Date: Mar 2007
Location: chicago burbs
Photos: Gallery
Posts: 3,356
Original Poster
QuoteOriginally posted by Pentaxor Quote
guys, did you try overwriting the latest firmware version with the Japan firmware version?
thats what i was using when the focus got weird. then i downgraded and the problem remained, so off for a warranty checkup

01-13-2010, 03:11 PM   #24
Pentaxian
ivoire's Avatar

Join Date: Mar 2007
Location: chicago burbs
Photos: Gallery
Posts: 3,356
Original Poster
just got this from the pentax authorized repair shop here in the chicago burbs:


"It looks like your unit needs to be sent out to Pentax for main circuit board and calibrate this will most likely take about 2-3 weeks for repairs. Please advise."

this may mean a replacement body instead of repair

now what to do for a backup???

Last edited by ivoire; 01-13-2010 at 03:22 PM.
01-14-2010, 12:42 PM   #25
Senior Member




Join Date: Dec 2008
Location: Brisbane, Australia
Photos: Gallery
Posts: 239
QuoteOriginally posted by smitty Quote
Ever since I installed the latest firmware, my photo playback has been funny.
It sometimes makes the rear screen go blank until I hit the shutter button.
Also, I'll be in playback, and when I move the camera body it will automatically go back to shooting mode.

Anyone else have these issues?

I just heard back from the studio I shot for last weekend. They asked if I had trouble getting tack sharp. I initially thought it was my shooting. Didn't even think it could have been the firmware.
no problems with latest firmware on my k-7 (original first shipment batch in Australia)
01-15-2010, 06:09 PM   #26
Pentaxian
ivoire's Avatar

Join Date: Mar 2007
Location: chicago burbs
Photos: Gallery
Posts: 3,356
Original Poster
QuoteOriginally posted by smitty Quote
Ever since I installed the latest firmware, my photo playback has been funny.
It sometimes makes the rear screen go blank until I hit the shutter button.
Also, I'll be in playback, and when I move the camera body it will automatically go back to shooting mode.

Anyone else have these issues?

I just heard back from the studio I shot for last weekend. They asked if I had trouble getting tack sharp. I initially thought it was my shooting. Didn't even think it could have been the firmware.
Smitty, if that is still happening, i recommend sending it in for a 'under warranty checkup'. Better to have it done while its still under warranty than get a bill for $200-400. I ended up spending $280 for a used K10D to use as a backup while waiting for the K7 repairs. May keep it or sell it later.
01-15-2010, 08:37 PM   #27
Veteran Member
jgredline's Avatar

Join Date: Oct 2007
Location: LosAngeles, Ca.
Photos: Albums
Posts: 10,531
I had experienced a very similar problem when I upgraded the firmware. I forget what post / thread it was, but it got worse...What fixed it for me was that I ended up re-installing the new firmware. It took three tries and then it was back to normal. It had me really upset when I first did the upgrade. Now it works ok.
01-16-2010, 07:34 AM   #28
Senior Member




Join Date: Oct 2009
Location: Florida
Photos: Albums
Posts: 231
Didn't the FW V1.02 add a new sharpness level?

It's early, and I may be remembering the FW update on my wife's k-x.

I think it added a selectable 'Fine 2' level on the k7. That leads me to believe the sharpness was an issue.

Don't know enough about this to offer opinions though... I'll leave this to the resident 50 pound brains...
02-04-2010, 02:40 PM   #29
Pentaxian
ivoire's Avatar

Join Date: Mar 2007
Location: chicago burbs
Photos: Gallery
Posts: 3,356
Original Poster
The K7 was picked up today after waiting 30 days for replacement of the main circuit board. Everything is working fine. The repair time would have been less if I had sent it directly to Pentax. It took United Camera in Bensenville, IL 8 days to determine it had to go to Pentax. I'm just Happy that its back and in pristine condition.
02-04-2010, 04:40 PM   #30
Site Supporter
grey goat's Avatar

Join Date: Dec 2009
Location: Spring Green, WI
Photos: Gallery | Albums
Posts: 320
I just yesterday got a new K-7, and I'm in the beginning stages of figuring things out.

But one thing I wondered about was the firmware update. Reading this thread made me, well, a little wary of the latest update, US or Japanese version.

I have a really goofy question, though: how can one determine which firmware version is installed in the camera? I searched here, and looked at the Pentax site, and have hunted in the manual. I might be missing something somewhere.

If someone could point me in the right direction, I'd be grateful.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, firmware, k7, k7 firmware, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tamron 17-50mm a worthy "downgrade" (from Pentax 16-50mm)??? Ubuntu_user Pentax SLR Lens Discussion 53 11-07-2010 06:23 PM
K200D to K-x: upgrade, downgrade, or "sidegrade"? ChooseAName Pentax DSLR Discussion 19 07-19-2010 09:36 AM
Did I just downgrade to K100D Super, or actually upgrade? pentaman Pentax DSLR Discussion 28 12-14-2009 10:14 PM
Considering a body downgrade--have I lost my mind? heatherslightbox Pentax DSLR Discussion 15 06-02-2009 07:12 AM
K200d owner Downgrade??? shiestmiester Pentax DSLR Discussion 14 02-25-2009 02:22 PM



All times are GMT -7. The time now is 03:33 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top