Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-03-2010, 01:39 PM   #1
Pentaxian
ivoire's Avatar

Join Date: Mar 2007
Location: chicago burbs
Photos: Gallery
Posts: 3,368
K7 firmware downgrade

I updated my K7 firmware and now all my lenses produce soft images. Anyone know how to revert to the original firmware?

01-03-2010, 01:53 PM   #2
Pentaxian
LeDave's Avatar

Join Date: Jun 2009
Location: Minneapolis - St. Paul
Photos: Gallery
Posts: 2,904
Can you post some examples? That's odd.
01-03-2010, 01:56 PM   #3
Pentaxian
Wheatfield's Avatar

Join Date: Apr 2008
Location: The wheatfields of Canada
Posts: 10,157
Why don't you dial in the AF instead?
01-03-2010, 02:02 PM   #4
Pentaxian
ivoire's Avatar

Join Date: Mar 2007
Location: chicago burbs
Photos: Gallery
Posts: 3,368
Original Poster
The lenses were spot on before the firmware upgrade. now the images with the f*300 and sigma 70-200mm both at f8 are soft. Either the focus (both af and mf) has failed in the camera or it is the firmware upgrade. I've tried the in camera adjustment for each of my lenses to no avail.

01-03-2010, 02:10 PM   #5
Veteran Member
netuser's Avatar

Join Date: Oct 2008
Location: Azores Islands, Portugal
Photos: Gallery
Posts: 2,241
For other reasons I also want to know how to downgrade and where I can find the older versions...
01-03-2010, 02:21 PM   #6
Pentaxian
ivoire's Avatar

Join Date: Mar 2007
Location: chicago burbs
Photos: Gallery
Posts: 3,368
Original Poster
QuoteOriginally posted by netuser Quote
For other reasons I also want to know how to downgrade and where I can find the older versions...
Sent you a PM. I found a copy of ver 1.01 on my backup drive. PM me with an email address and i'll send you a copy. It replaced the current version to ver 1.01 , so i'm off to do some tests.
01-03-2010, 02:41 PM   #7
Veteran Member
netuser's Avatar

Join Date: Oct 2008
Location: Azores Islands, Portugal
Photos: Gallery
Posts: 2,241
QuoteOriginally posted by ivoire Quote
Sent you a PM. I found a copy of ver 1.01 on my backup drive. PM me with an email address and i'll send you a copy. It replaced the current version to ver 1.01 , so i'm off to do some tests.
PM sent. Thanks
Will do my tests tomorrow and let you know.
01-03-2010, 02:53 PM   #8
Pentaxian
LeDave's Avatar

Join Date: Jun 2009
Location: Minneapolis - St. Paul
Photos: Gallery
Posts: 2,904
I don't get what's really wrong, how can this firmware mess things up? I upgraded to the new firmware with my K-7 and haven't seen anything wrong. Hopefully this doesn't affect me later.

01-03-2010, 03:13 PM   #9
Pentaxian
ivoire's Avatar

Join Date: Mar 2007
Location: chicago burbs
Photos: Gallery
Posts: 3,368
Original Poster
QuoteOriginally posted by LeDave Quote
I don't get what's really wrong, how can this firmware mess things up? .
That makes 2 of us. All of a sudden my images are soft. The only change was an upgrade to the latest firmware version. No amount of in camera adjust makes the images as sharp as they were previously. So, either the firmware is to blame or there is something wrong with the camera. My preference is to clean contacts, try in camera adjustment, downgrade the firmware, etc, prior to returning the camera to Pentax. I posted this to see how to revert to the factory settings and see if anyone else is experiencing a similar problem and what, if any, fix has worked.
01-03-2010, 04:09 PM   #10
Veteran Member
netuser's Avatar

Join Date: Oct 2008
Location: Azores Islands, Portugal
Photos: Gallery
Posts: 2,241
For me was only to test a strange thing... my 70-200 with the 2x converter works perfect on k20d and k200d. Now with k-7 it doesn't autofocus ....

Trying to understand what can be wrong. Any thoughts anyone ?

Last edited by netuser; 01-03-2010 at 04:18 PM.
01-04-2010, 08:42 AM   #11
Veteran Member
StephenMerola's Avatar

Join Date: Feb 2009
Location: Southeast Wisconsin
Photos: Albums
Posts: 391
Ivoire, did you verify your problem? I am very curious. I have not noticed anything on my k-7 yet.
01-04-2010, 09:38 AM   #12
Pentaxian
Marc Sabatella's Avatar

Join Date: Sep 2006
Location: Denver, CO
Photos: Gallery
Posts: 10,686
There is basically no chance at all that firmware change is making images soft. Whatever difference you are seeing has got to be just coincidence. "Post hoc ergo propter hoc" - oldest fallacy in the book.
01-04-2010, 02:18 PM   #13
Pentaxian
ivoire's Avatar

Join Date: Mar 2007
Location: chicago burbs
Photos: Gallery
Posts: 3,368
Original Poster
Did the downgrade, tried all the fixes and the problem persists with several lenses. no amt of + - adjust helps. So, off to pentax for warranty work.
01-04-2010, 03:30 PM   #14
Veteran Member
StephenMerola's Avatar

Join Date: Feb 2009
Location: Southeast Wisconsin
Photos: Albums
Posts: 391
Sorry to hear that. Good luck with the repairs.
01-04-2010, 07:31 PM   #15
Pentaxian
ivoire's Avatar

Join Date: Mar 2007
Location: chicago burbs
Photos: Gallery
Posts: 3,368
Original Poster
QuoteOriginally posted by StephenMerola Quote
Sorry to hear that. Good luck with the repairs.
Thanks, there is a pentax repair facility 25 miles from home. I'll drop it off tomorrow. Heres a sample of the problem (for those interested) from the f*300mm. this is the best i could get on a tripod after several adjustments. zoom lenses were even worse. In the viewfinder, focus appeared spot on with focus lock confirmation.

Last edited by ivoire; 11-26-2010 at 06:58 PM.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, firmware, k7, k7 firmware, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tamron 17-50mm a worthy "downgrade" (from Pentax 16-50mm)??? Ubuntu_user Pentax SLR Lens Discussion 53 11-07-2010 06:23 PM
K200D to K-x: upgrade, downgrade, or "sidegrade"? ChooseAName Pentax DSLR Discussion 19 07-19-2010 09:36 AM
Did I just downgrade to K100D Super, or actually upgrade? pentaman Pentax DSLR Discussion 28 12-14-2009 10:14 PM
Considering a body downgrade--have I lost my mind? heatherslightbox Pentax DSLR Discussion 15 06-02-2009 07:12 AM
K200d owner Downgrade??? shiestmiester Pentax DSLR Discussion 14 02-25-2009 02:22 PM



All times are GMT -7. The time now is 02:23 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top