Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-10-2010, 12:47 PM   #1
Inactive Account




Join Date: Dec 2009
Location: Norwich, UK
Posts: 8
K20d problem

Hi all,

Thought I'd put this up for discussion, as not come across anythign like it before, neither had anyone where I bought it, so it's off to Pentax UK......

Bought a K20D other day from Warehouse Express's Bargain Basement, and with varying lenses and varying memory cards have experienced the same intermittent, unpredictable problem....

Switch camera on, take first picture and the camera seems to crash / lock up / freeze.......... cannot access menu, cannot take another picture, switch it off, everything goes off apart from the no of exposures left on the card slot, and the only way to reset the camera is to remove the battery and then reinsert it. The camera could then be fine for a while or freeze up again.


1) If it gets past the first shot will be fine until switch off and then switch on again (may be fine then as well)

2) Shoot high res Jpg (****) and RAW (PEF file, not DNG) - so each time I am writing somewhere in the region of 21 Mb to a card.

3) Only have Sandisk or Lexar cards bought from reputable sources - either 4 or 8 Gb's.

4) Most recent firmware of 1.03 installed as per Pentax.jp's instructions.


Any ideas?

One of the guys there did say that had a slowish speed memory card - but surely that shouldn't casue the problem. Am I right in my understanding it will just take longer for each dataset to get from teh camera to the card.......

Unfortunately, as now an obsolete model, only real option was for it to go back to Pentax for them to take a llok.


ANyone else heard of a similar problem?

01-10-2010, 01:14 PM   #2
Veteran Member
Raybo's Avatar

Join Date: Dec 2007
Posts: 871
No problems with mine.
Have you tried going into the last page of your set-up menu and doing a total reset? I have read that this might help with certain problems.
01-10-2010, 01:49 PM   #3
Damn Brit
Guest




QuoteOriginally posted by Raybo Quote
No problems with mine.
Have you tried going into the last page of your set-up menu and doing a total reset? I have read that this might help with certain problems.
Agreed, a reset is advisable. Leaving batteries out overnight is something else that gets advised. If the cards all came from the same source, it wouldn't hurt to try one from a different source.
Basically it's a case of trying anything that might save you having to return it.

Sorry that you've had a bad start with it but it can happen to anyone with any camera.
01-10-2010, 01:52 PM   #4
Ash
Community Manager
Loyal Site Supporter
Ash's Avatar

Join Date: Mar 2007
Location: Toowoomba, Queensland
Photos: Gallery | Albums
Posts: 22,678
Does this happen with all your different SD cards?
If not, it may not be a camera problem - have a look at the SD card in question.

01-10-2010, 02:10 PM   #5
Inactive Account




Join Date: Dec 2009
Location: Norwich, UK
Posts: 8
Original Poster
thanks all so far for replies.........

It's already on its way back.

happens on 5 of the 6 memory cards with a variety of lens, but a bit random as to when it may or may not happen!

Also happens with the proper pentax battery and the 3rd party additional one........ bizarre!
01-10-2010, 02:37 PM   #6
Ash
Community Manager
Loyal Site Supporter
Ash's Avatar

Join Date: Mar 2007
Location: Toowoomba, Queensland
Photos: Gallery | Albums
Posts: 22,678
Has the global reset helped?
It does seem unusual.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, card, cards, dslr, k20d, memory, pentax, photography, picture, switch
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
k20d problem Neto Pentax DSLR Discussion 2 09-24-2009 02:59 AM
K20D Problem photoTaz Pentax DSLR Discussion 2 06-21-2009 09:25 PM
Just got my K20D... problem already - need help! dimak Troubleshooting and Beginner Help 6 05-01-2009 04:21 AM
Card read problem K20d. Have you had this problem? rsi1986 Pentax DSLR Discussion 8 12-27-2008 05:25 AM
Problem with K20D eadnams Pentax DSLR Discussion 7 06-28-2008 07:21 AM



All times are GMT -7. The time now is 01:18 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top