Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-22-2010, 06:31 AM   #1
Inactive Account




Join Date: Jan 2010
Posts: 5
pentax K7 and af540fgz flash

Hi guys,

I purchased a pentax K7 and have tried to use this with a af540fgz flash but with no luck with the flash head and the auto zoom. thought this may have been an issue with the flash but have tried the flash on a k10d and k100 with perfect results so i have ruled out there being any issue with the flash head, so that leaves me to think there is an issue with the pentax K7 communicating with the af540fgz flash due to firmware, i am wondering if anyone else has this same issue, the camera is only 2 weeks old and am wondering if i should return it or wait to see if there is another firmware fix for this issue, camera in using V1.02 firmware at the moment.
Any help would be appreciated

01-22-2010, 06:41 AM   #2
Veteran Member
mattdm's Avatar

Join Date: Feb 2007
Location: Boston, MA
Photos: Gallery
Posts: 2,964
Haven't heard of any such problem. What does Pentax customer service say?
01-22-2010, 06:56 AM   #3
Pentaxian
Lowell Goudge's Avatar

Join Date: Jan 2007
Location: Toronto
Photos: Gallery | Albums
Posts: 15,400
can you post some results?
01-22-2010, 07:02 AM   #4
Inactive Account




Join Date: Jan 2010
Posts: 5
Original Poster
Have not yet called customer service, and as for results there isnt too much to post rather than to just say the zoom head will not zoom neither in or out as it should in auto mode as you adjust the zoom length on the camera.

01-22-2010, 08:49 AM   #5
Forum Member
Bobe416's Avatar

Join Date: Mar 2009
Location: Toronto
Photos: Gallery | Albums
Posts: 57
One suggestion is to clean the hot shoe with a dry cloth as well as the contacts on the bottom of the flash - I had problems with the 540 and the K10D this past weekend, but a quick clean seems to have fixed it
01-22-2010, 10:10 AM   #6
Pentaxian
Lowell Goudge's Avatar

Join Date: Jan 2007
Location: Toronto
Photos: Gallery | Albums
Posts: 15,400
A simple question if I may

I have an AF 540 FGZ and *istD, K10D and K7D cameras,

In your second post, yoou state the head will not zoom in or out in "AUTO" mode.

Do you mean that in all automatic flash modes, i.e. TTL, P-TTL etc or do you specificaly mean in "AUTO" flash mode, where you need to set F Stop, Aperture and ISO and use the flash's internal sensor to meter.

The AF 540 Does not do this on any of my bodies, and in fact the manual specifically states if the flash mode is set to AUTO that the auto zoom feature does not function/
01-22-2010, 06:09 PM   #7
Inactive Account




Join Date: Jan 2010
Posts: 5
Original Poster
I can get the flash to work the way it should on a k10d and k100 but not the new k7, it would seem there is an obvious issue with the camera. will take it back to where i bought it from along with the flash so they can either replace the camera or send it off to be looked at
01-23-2010, 12:48 PM   #8
Ash
Community Manager
Loyal Site Supporter
Ash's Avatar

Join Date: Mar 2007
Location: Toowoomba, Queensland
Photos: Gallery | Albums
Posts: 22,695
If you've cleaned the contacts and the camera and flash communicate with each other in every other way (as well as correctly expose P-TTL images) then it does seem a breakdown in communicating the lens focal length to the flash.

01-23-2010, 01:57 PM   #9
Pentaxian
Lowell Goudge's Avatar

Join Date: Jan 2007
Location: Toronto
Photos: Gallery | Albums
Posts: 15,400
this may be a dumb question but is the flash seated fully on the camera
01-24-2010, 06:24 AM   #10
Inactive Account




Join Date: Jan 2010
Posts: 5
Original Poster
Yes i have cleaned both the contacts on the camera and the flash, have now also tried various lenses, and have now tried a af360fgz flash on the camera and have no luck with that flash on the camera either, the camera shop where i purchased it from have ordered me another K7 to change it over with, will see how i go with that when i pick it up, Thanks for your help people !
01-25-2010, 05:02 PM   #11
New Member




Join Date: Dec 2009
Location: Manchester
Posts: 4
My af360fgz works fine with my K7, so definitely sounds like it's your K7 that's the problem. Is it on the latest firmware?
01-25-2010, 08:19 PM   #12
Senior Member




Join Date: Aug 2007
Location: Perth, Australia
Posts: 268
My af540 works fine on my K7.... not actually my second K7, as my first one got some issues, and got replaced in the end. So much issues.. almost hard to believe.. the service centre operated on it 3 times....from exposure tweaking, SR mechanism replacement to Sensor goes out of wack. In the end they gave me a new body.

I think its the body, so hope your new body will perform as expected.
01-29-2010, 07:10 PM   #13
Inactive Account




Join Date: Jan 2010
Posts: 5
Original Poster
Ok, got phone call from camera shop to say they had the replacement k7 come in, so went in took the flash with me too, tried it on the replacement and all works as it should with no issues at all "touch wood" so we changed over the k7 body
01-29-2010, 09:59 PM   #14
Veteran Member
nulla's Avatar

Join Date: Jul 2008
Location: Melbourne Australia
Posts: 1,560
QuoteOriginally posted by theedge Quote
Ok, got phone call from camera shop to say they had the replacement k7 come in, so went in took the flash with me too, tried it on the replacement and all works as it should with no issues at all "touch wood" so we changed over the k7 body

Thats good news... believe me the AF540 flash unit and the K-7 combo is a vast improvement in the Pentax lineup, I was at a loss with flash prior to getting my K-7, now I feel like a pro with the results.

Cheers

Neil
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
af540fgz, camera, dslr, firmware, flash, head, issue, k7, pentax, pentax k7, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale - Sold: Pentax AF540FGZ Flash JFMichaud Sold Items 2 07-01-2009 01:06 PM
Pentax Flash AF540FGZ sznajder Flashes, Lighting, and Studio 6 12-29-2008 06:30 AM



All times are GMT -7. The time now is 12:54 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top