Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-03-2010, 03:09 PM   #1
New Member




Join Date: Aug 2008
Location: Sweden
Posts: 2
K10D problem - won't start at all

Hi everyone! Hope you might be able to give me some advice!

My K10D is completely dead and won't start at all. I have a fully charged battery and have tried it both with a new memorycard as well as wothout any card at all. All that hapens is that the battery symbol (showing a fully charged battery) flickers once and then nothing more, completely dead... If I try it with a memorycard installed, the red LED flashes once as well.

Is there anyone who can give me some help with what to do? Or do I have to send it in to have it repaired ?

Thank you in advance!

02-03-2010, 03:26 PM   #2
Damn Brit
Guest




You don't say how long you've had the camera, maybe the battery is dead. Have you a different one to try? Clean the contacts as well.
02-03-2010, 03:32 PM   #3
New Member




Join Date: Aug 2008
Location: Sweden
Posts: 2
Original Poster
I've had it for two years now I think... I'll give it a go with a new battery - thanks!

Any other ideas?

/Daniel
02-03-2010, 03:44 PM   #4
Pentaxian
aleonx3's Avatar

Join Date: Jul 2007
Location: Brampton, Ontario
Photos: Gallery | Albums
Posts: 3,873
Could it be possible that there is a firmware problem? Do you have a MF lens? Trying mounting it on, if the camera is ON, it should prompt you for the focal length of the lens. If it does not, then, it is possible that you have a firmware problem - you may have to reload the firmware.

02-03-2010, 03:53 PM   #5
Damn Brit
Guest




QuoteOriginally posted by aleonx3 Quote
Could it be possible that there is a firmware problem? Do you have a MF lens? Trying mounting it on, if the camera is ON, it should prompt you for the focal length of the lens. If it does not, then, it is possible that you have a firmware problem - you may have to reload the firmware.
How can he reload the firmware if the camera won't turn on?
02-03-2010, 04:45 PM   #6
Veteran Member




Join Date: Oct 2008
Photos: Gallery | Albums
Posts: 550
I had my k10d broke 2 times. Maybe your k10d's switch on and off broke. So I bought K-7. Forgot k10d. If you want to repair. it cost $270. Forgot it.
02-03-2010, 05:01 PM   #7
Pentaxian
aleonx3's Avatar

Join Date: Jul 2007
Location: Brampton, Ontario
Photos: Gallery | Albums
Posts: 3,873
QuoteOriginally posted by Damn Brit Quote
How can he reload the firmware if the camera won't turn on?
Sorry, Gary, I could be wrong - since when he inserted the SD card the LED on the card slot blinks, it may be able to read off from the SD card. I could be totally off base.. sorry, just thought it may be worth a try.
02-03-2010, 05:44 PM   #8
Damn Brit
Guest




QuoteOriginally posted by aleonx3 Quote
Sorry, Gary, I could be wrong - since when he inserted the SD card the LED on the card slot blinks, it may be able to read off from the SD card. I could be totally off base.. sorry, just thought it may be worth a try.
No problem, I just thought you might know something that others don't.

02-03-2010, 08:39 PM   #9
Inactive Account




Join Date: Aug 2008
Location: Michigan, USA
Photos: Gallery | Albums
Posts: 7,485
QuoteOriginally posted by aleonx3 Quote
Sorry, Gary, I could be wrong - since when he inserted the SD card the LED on the card slot blinks, it may be able to read off from the SD card. I could be totally off base.. sorry, just thought it may be worth a try.
Still could be worth holding the menu button while turning the camera on. At least you could see if anything happens beyond the battery indicator. I wouldn't try to load a firmware though unless the camera IS working. Could finalize the journey to brick status. Also check (may be a long shot) that there are no stuck buttons, the mode dial isn't stuck between 2 settings, things like that. Plug a USB into the camera and see if it'll talk to a computer. Without a card, the camera should start. With one, of course it should start as well but it seems plausible that if the card is bad, the camera will not start with the card in the slot. All worth a try and costs nothing to do...

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
battery, camera, dslr, k10d, memorycard, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
k10d problem iwhizz Pentax DSLR Discussion 11 04-26-2009 05:02 PM
K10d got wet, won't start. cyclocross Pentax DSLR Discussion 16 12-08-2008 07:21 PM
Problem with K10d jay88keys25 Pentax DSLR Discussion 0 08-18-2008 07:03 PM
Newbie start up :K100d super or K10D Siver Surfer Troubleshooting and Beginner Help 12 03-21-2008 02:21 PM
Start-up of K10D nekhezin Pentax DSLR Discussion 23 04-07-2007 12:24 AM



All times are GMT -7. The time now is 12:04 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top