Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-20-2010, 07:15 PM   #1
New Member




Join Date: Feb 2010
Posts: 4
Pentax K-x Audible Noise in LiveView

Hi Guys,

I have a question and hope someone can help. After hearing a lot of good things about the K-x I went ahead and ordered one online. Got it in the mail today.

Everything seems ok and the pictures are great. But in Live view mode the camera makes a consistent crackling noise you know like a hard drive noise "krrrrrrr". I tried turning off the SR and set it to M but the noise is still there. Even when the camera is not moved. Its separate from the noise that the SR makes.

Do you guys think its a defect? I went to the mall and tried the Canons and Nikons and they don't have a similar issue. Couldn't find a Pentax in the mall to try.

Any help will appreciated. If its a defect, I can get a replacement as I just got it today.

Thx.

02-20-2010, 09:08 PM   #2
Veteran Member
fccwpe's Avatar

Join Date: Mar 2009
Location: Perris, CA
Photos: Gallery
Posts: 380
I just turned mine on and I hear only the SR when I move the camera around. I don't know what you are hearing. Do you hear it in movie mode?
02-21-2010, 12:09 AM   #3
Veteran Member
inferno10's Avatar

Join Date: Feb 2007
Location: San Francisco, California
Posts: 342
What you're hearing is the sensor shift mechanism in action. It's the same mechanism that drives the SR. Because the SR is in-body, the sensor is allowed to freely move within the confines of the SR guides when the camera is not using the sensor. Even though you de-activated SR, the camera still needs to power the SR system to straighten the sensor in a static position for LiveView or when taking a shot, otherwise your image would appear crooked. This explains the noise you're hearing. It's normal.

- Jason
02-21-2010, 06:48 PM   #4
New Member




Join Date: Feb 2010
Posts: 4
Original Poster
Thx Jason. That explains it.

02-21-2010, 06:48 PM   #5
New Member




Join Date: Feb 2010
Posts: 4
Original Poster
Hi fccwpe, you sure your not hearing anything. There are two noises, in my case. The primary is always present in Live View ONLY. No matter which mode I am and its also present in movie mode. The secondary only appears when I move the camera and only if SR is turned on. If SR is off I only hear this primary noise, which sort of a faint crackling noise. Similar to the noise that a Hard Drive makes when reading or writing, but its pretty faint. You will have to put your ears close to the camera to hear it.

QuoteOriginally posted by fccwpe Quote
I just turned mine on and I hear only the SR when I move the camera around. I don't know what you are hearing. Do you hear it in movie mode?
02-21-2010, 06:54 PM   #6
New Member




Join Date: Feb 2010
Posts: 4
Original Poster
Hi Jason, Does the K-7 make a similar noise? Since it has SR.
03-18-2010, 10:33 AM   #7
Inactive Account




Join Date: Mar 2010
Location: Richmond, VA
Posts: 4
Mine is the same. Audible noise ONLY when in Live View. Is this normal. It's definitely "noticeable."
03-18-2010, 10:43 AM   #8
Veteran Member




Join Date: Nov 2009
Location: Pittsburgh, PA
Posts: 479
If had a penny for every...

03-18-2010, 11:33 AM   #9
Inactive Account




Join Date: Mar 2010
Location: Richmond, VA
Posts: 4
Wow. This really IS a very friendly and helpful place. Where shall I send your penny?You've done yeoman's work. You've earned it. Really.
03-18-2010, 11:36 AM   #10
Veteran Member
RioRico's Avatar

Join Date: Jun 2008
Location: Limbo, California
Posts: 11,264
I forget the exact lens setup, but with my K20D in SR, I've put the camera down on a hard surface and had it hop around (slightly). Zowie.
06-01-2010, 09:00 PM   #11
New Member




Join Date: Jun 2010
Location: us
Posts: 1
my kx also very noisy in live view mode

hello fellow pentax owner,
i just got my kx today and also searching to see if my kx noisy "krrrr" sound in live view mode is image stabilizer in action of defect from damage, since outside shipping box was dent 1/3 on 1 side. Also have a dead pixel that is only showing up in live view mode not menu mode.

it's actually very noticeable and i would say to the point of annoying.
thinking of a return....
06-01-2010, 09:30 PM   #12
xjx
Forum Member




Join Date: Mar 2010
Location: Seattle, WA
Photos: Albums
Posts: 64
QuoteOriginally posted by aedahh Quote
hello fellow pentax owner,
i just got my kx today and also searching to see if my kx noisy "krrrr" sound in live view mode is image stabilizer in action of defect from damage, since outside shipping box was dent 1/3 on 1 side. Also have a dead pixel that is only showing up in live view mode not menu mode.

it's actually very noticeable and i would say to the point of annoying.
thinking of a return....
The noise is normal.
06-03-2010, 02:55 AM   #13
Senior Member




Join Date: May 2010
Posts: 113
Actually this noise is also audible when you set long exposure time (and shoot), and when you simply raise mirror to clean sensor.

So apparently the noise is produced at any time that the mirror is raised and the sensor is exposed to light. so it's definitely not a SR.

I wonder what is this noise? is it a cooler or something?

QuoteQuote:
Also have a dead pixel that is only showing up in live view mode not menu mode.
This might be a dust on the sensor. I had some as well, managed to blow off some of it. To remove it you need some thing that produces dust-less constant powerful air blow, need to direct it into the sensor with mirror raised and the stickied dust should go away... but this is dangerous procedure and ideally should only be performed in the service center.

By the way, this dust only shows on narrow apertures so perhaps you can live with it .. Problem is that every time a mirror is raised, some dust may pass to the sensor area, so it's hard to not have any dust at all if you ever change lenses.
06-03-2010, 03:09 AM   #14
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,984
I'm pretty sure that this noise is the SR system stabilizing the sensor. It's normal.

A dark, round spot is typically dust, can can be blown off with a rocket blower or a compressed air canister. A single pixels or shape that's oddly colored or bright, however, would be a hot pixel.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

06-03-2010, 11:45 AM   #15
New Member




Join Date: Jun 2010
Location: Grenoble
Posts: 10
Definitely the mirror lock-up

Hello All,

In live view the mirror is locked up (similar to the sensor cleaning procedure) so that the image is projected directly on the sensor. As the action of "holding up" the mirror is elctro-mechanical, there is some sound associated. To verify this, simply enter sensor cleaning mode, you shall hear the same noise. Also, when you enter LV, you hear a click, that's the mirror being lifted.

Just one parting comment: Dust causes spots, not noise while operating the camera, unless you fill the compartment with sand and shake it around

I do not hear a loud noise by the way, just a slight hiss, so it its too loud, better to get it checked, as it could indicate some problem in the mirror lock-up mechanism.

Enjoy,
Rwik

Last edited by rwik78; 06-03-2010 at 11:46 AM. Reason: Spelling mistake
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, defect, dslr, guys, help, k-x, mall, noise, pentax k-x, photography, sr
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Video of K-5's LiveView AF inferno10 Pentax K-5 22 10-31-2010 08:37 PM
K-7 audible noise (clicking) while zooming in or out Jimmymack Pentax DSLR Discussion 4 08-21-2010 05:53 AM
K7 not focusing on LiveView onairda Pentax DSLR Discussion 9 09-03-2009 10:53 PM
Liveview audible noise MM#8 Pentax DSLR Discussion 7 08-24-2009 08:52 PM
LiveView for Macro? TimB Photographic Technique 8 10-31-2008 02:17 PM



All times are GMT -7. The time now is 11:04 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top