Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-22-2010, 08:51 PM   #1
Forum Member
PlumRT's Avatar

Join Date: Sep 2009
Location: AZ Page LkPowell
Posts: 50
K10D shutter will not "snap" but focus/flash work!

In the third week of photo school and my Pentax K10D refuses to snap. Man, what a let down. It isn't mistreated and only 8000 shots.
It will focus, flash, and go through every step seemingly without fault - untill that final last push. The shutter wil not activate and no file is saved. Now what?
Had battery(s) out overnight and reset menu to defaults to no avail.

Guess I am in the market for another camera unless this can be fixed soon and cheaply. Any thoughts appreciated.
Thanks alot, PlumRT
Want but don't need a K7 - guess Kx would do.

02-22-2010, 08:58 PM   #2
Inactive Account




Join Date: Aug 2008
Location: Michigan, USA
Photos: Gallery | Albums
Posts: 7,484
QuoteOriginally posted by PlumRT Quote
In the third week of photo school and my Pentax K10D refuses to snap. Man, what a let down. It isn't mistreated and only 8000 shots.
It will focus, flash, and go through every step seemingly without fault - untill that final last push. The shutter wil not activate and no file is saved. Now what?
Had battery(s) out overnight and reset menu to defaults to no avail.

Guess I am in the market for another camera unless this can be fixed soon and cheaply. Any thoughts appreciated.
Thanks alot, PlumRT
Want but don't need a K7 - guess Kx would do.
If I'm reading your question right, you are getting normal action with a Full shutter press. Focus at half press and the flash fires when you push the button all the way, Correct?

These may sound silly but is your Card corrupt? Does the mirror flip up when you press the shutter button? Can you flip the mirror up by going into clean mode? Have you tried the Digital preview to see if the shutter will activate? Is the lens attached properly and are the contacts all clean? I've read stories about the shutter button switches going wonky on some cameras. Cheap fix, even doable yourself if you're brave enough to do it (I am, but that's just me). Your shutter shouldn't be dead after only 8k frames. It's just getting broken in..

02-22-2010, 09:19 PM   #3
Forum Member
PlumRT's Avatar

Join Date: Sep 2009
Location: AZ Page LkPowell
Posts: 50
Original Poster
Yes, it does focus and flash. It stopped working while in use after taking 20 photos.
Tries another card. Have 8 and a 4gig, nada. Tried formatting and still didn't help.
I can flip mirror up, it flips back down to 45 degrees when I let go.
Sensor Clean mode: Mirror doesn't move.
Digital Preview: Shutter doesn't activate.
I have several lenses and test same synptoms. Contacts are ok - tried erasor.

Yes, read that with just a little solder job a bad button is easily fixed.....but, is it a bad button?

Thanks, PlumRT
02-22-2010, 09:25 PM   #4
Inactive Account




Join Date: Aug 2008
Location: Michigan, USA
Photos: Gallery | Albums
Posts: 7,484
QuoteOriginally posted by PlumRT Quote
Yes, it does focus and flash. It stopped working while in use after taking 20 photos.
Tries another card. Have 8 and a 4gig, nada. Tried formatting and still didn't help.
I can flip mirror up, it flips back down to 45 degrees when I let go.
Sensor Clean mode: Mirror doesn't move.
Digital Preview: Shutter doesn't activate.
I have several lenses and test same synptoms. Contacts are ok - tried erasor.

Yes, read that with just a little solder job a bad button is easily fixed.....but, is it a bad button?

Thanks, PlumRT
When I asked if the mirror flips up I meant automatically with shutter button press. It not moving in cleaning mode or digital preview answers that question. I'm thinking something other than the shutter but don't really know what. I don't know if you should be able to move the mirror by hand . Basically, I'm out of ideas here.. I'd suggest at this point calling pentax service. I do believe they are in Arizona.. Don't know what part though. Maybe you can hand carry it in??

Good luck..

02-22-2010, 09:32 PM   #5
Forum Member
PlumRT's Avatar

Join Date: Sep 2009
Location: AZ Page LkPowell
Posts: 50
Original Poster
No, it fails to "snap" the mirror. No sound of that moving as normal. Thanks for trying, I appreciate you taking time to give me some ideas.I am in remote Canyon Country and 300 miles from any repair help.
Thanks, PlumRT
01-12-2011, 11:59 AM   #6
Junior Member




Join Date: Jun 2010
Photos: Gallery | Albums
Posts: 47
Same Issue

I have the same problem, mine occurred quite a while ago. The mirror will not flip up to take the picture, but everything else seems to be working fine. I am guessing the cause is whatever the mechanism is that flips up the mirror. You can hear it 'trying' to lift it up when the shutter is pressed.
I sent mine in to willoughbys camera (aka photoamerica) as I had an extended warranty through them (5 yr). After over a month in a half they sent the thing back to me, in the same shape it was when i sent it to them (another story, but the better business bureau has now given them not so high remarks, do not do business with those people).
I needed a camera so I bought the k-7. However, I still want to get my k10d fixed as a backup and something my wife can 'learn' on. I plan on sending this in to pentax to have a look and get a repair estimate, just not sure when.
If anyone else has had this issue and knows the problem or has had it fixed and knows the cost of that, please let us know. If not I will post the info whenever I decide to send it into Pentax.
I have learned my lesson and bought an extended warranty directly through Pentax, beware of 3rd party warranties. Lesson learned for me.
01-12-2011, 12:00 PM   #7
Junior Member




Join Date: Jun 2010
Photos: Gallery | Albums
Posts: 47
I wish Pentax would let you hand carry it into their repair centers. I live near Golden, CO but was told I still have to ship it to the Golden location.
01-12-2011, 12:11 PM   #8
Pentaxian




Join Date: Feb 2009
Location: Alameda, CA
Posts: 3,198
QuoteOriginally posted by NewTake Quote
I wish Pentax would let you hand carry it into their repair centers. I live near Golden, CO but was told I still have to ship it to the Golden location.
From what I know, there is no repair center in Golden, CO.

In the US, Pentax outsources repair jobs to CRIS in Chandler, AZ.

If you ship your camera to Pentax in Golden, they will in turn ship it to CRIS. You can ship it directly to CRIS - Linky.

01-12-2011, 06:51 PM   #9
Forum Member
PlumRT's Avatar

Join Date: Sep 2009
Location: AZ Page LkPowell
Posts: 50
Original Poster
NewTake - here's what I did

QuoteOriginally posted by NewTake Quote
I have the same problem, mine occurred quite a while ago. The mirror will not flip up to take the picture, but everything else seems to be working fine. I am guessing the cause is whatever the mechanism is that flips up the mirror. You can hear it 'trying' to lift it up when the shutter is pressed.
I sent mine in to willoughbys camera (aka photoamerica) as I had an extended warranty through them (5 yr). After over a month in a half they sent the thing back to me, in the same shape it was when i sent it to them (another story, but the better business bureau has now given them not so high remarks, do not do business with those people).
I needed a camera so I bought the k-7. However, I still want to get my k10d fixed as a backup and something my wife can 'learn' on. I plan on sending this in to pentax to have a look and get a repair estimate, just not sure when.
If anyone else has had this issue and knows the problem or has had it fixed and knows the cost of that, please let us know. If not I will post the info whenever I decide to send it into Pentax.
I have learned my lesson and bought an extended warranty directly through Pentax, beware of 3rd party warranties. Lesson learned for me.
No solution except they want you to throw money at it when I sent it to the Pentax repair facility here in Arizona to get a quote from them. $200 was what they wanted. No way says I and they send it back to me. I sell on ebay broken and buy a Red K-x that I'm happy with.
I know I'd be VERY upset at the warranty place that sent it back to you "in the same shape it was when i sent it to them" and would demand ! more from them(like repair cost)
01-13-2011, 07:11 AM   #10
Junior Member




Join Date: Jun 2010
Photos: Gallery | Albums
Posts: 47
Thanks!

Thanks PlumRT for the info, that is helpful. I may shell that out. I know I could probably get one used for about 100 more, but who is to say what will go wrong with that one. At least if I get it repaired hopefully that same issue would not occur again.
I did have a little war with Willoughby's escalated up the chain. They said they would take another look at it if I shipped it back to them on my dime. Keep in mind, I had already paid to ship it to them and back to me (that is part of the warranty agreement). They were adamant that they would not pay to ship it back to them but they would pay to ship it back to me. I didnt think that was good enought and I don't trust those people to work on my camera. I would rather send it out to whom Pentax authorizes to repair and get it done right. Since Willoughby's is in NY, and I am in CO, I couldnt just walk in, unfortunately. I think things would have gone much differently if I could have talked to them face to face. Believe me, I spread the word to everyone I know not to purchase anythingthing from them, and especially do not get a warranty through them.
SoldBear, thanks for that info as well. I was told to send my camera to Golden to have my sensor cleaned, but that was probably about 3 years ago, and I guess it has changed, or maybe they just did simple work there, back then.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, k10d, k10d shutter, photography, shutter
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Manual flash but "P" mode in K10D? Zakovva Troubleshooting and Beginner Help 1 03-13-2010 09:57 PM
Error "Confirmation" button in marketplace doesn't work with mobile version of site. tendim Site Suggestions and Help 4 12-05-2009 01:13 PM
Pentax "A" lens and "F" 1.7X converter on K10d yyyzzz Pentax SLR Lens Discussion 4 07-09-2009 05:04 AM
K10D focus screen "matte" visible during use wills Pentax DSLR Discussion 4 05-02-2008 06:42 AM
The "rush" of a good snap mediaslinky Pentax DSLR Discussion 9 04-14-2007 04:22 PM



All times are GMT -7. The time now is 04:08 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top