Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-24-2010, 10:42 AM   #1
Junior Member




Join Date: Sep 2009
Location: St.Andrews
Photos: Albums
Posts: 29
Stubborn Dust

Hi, i am having trouble with a fairly large piece of something appearing on my pictures.

I am using a k-7 and have run a couple of sensor cleaning protocols which cleared up some particles registering on the sensor test. However the original piece of dust is still visible in photographs. The dust does not seem to be present with other lenses, is it possible this is in the lens?



Any help is much appreciated,

thanks

Fraser

02-24-2010, 11:01 AM   #2
Inactive Account




Join Date: Aug 2008
Location: Michigan, USA
Photos: Gallery | Albums
Posts: 7,484
Have you tried a blower? I doubt it has anything to do with the lens but more to do with the lens settings.

02-24-2010, 11:19 AM   #3
Junior Member




Join Date: Sep 2009
Location: St.Andrews
Photos: Albums
Posts: 29
Original Poster
Have just been over the sensor with a blower and its seems to have gone, only a few smaller bits left in its place.

Strangely the dust mapping option on the k7 is now shaded and unavailable, why would this be?

thanks

Fraser
02-24-2010, 11:27 AM   #4
Inactive Account




Join Date: Aug 2008
Location: Michigan, USA
Photos: Gallery | Albums
Posts: 7,484
QuoteOriginally posted by fra-zzr Quote
Have just been over the sensor with a blower and its seems to have gone, only a few smaller bits left in its place.

Strangely the dust mapping option on the k7 is now shaded and unavailable, why would this be?

thanks

Fraser
Probably the lens you have mounted. I think it only works with autofocus lenses. I know it doesn't work with M or K lenses.

The fused on dust (that won't blow or shake off), is removable with the Pentax cleaning kit O-ICK1. At least that's what works best for me.



02-24-2010, 11:29 AM   #5
Pentaxian
Wheatfield's Avatar

Join Date: Apr 2008
Location: The wheatfields of Canada
Posts: 10,157
QuoteOriginally posted by fra-zzr Quote
Have just been over the sensor with a blower and its seems to have gone, only a few smaller bits left in its place.

Strangely the dust mapping option on the k7 is now shaded and unavailable, why would this be?

thanks

Fraser
As you've found, dust that is visible on the picture is also on or near the sensor. My guess was that your dust was attached to the shutter mechanism which was why the sensor shake wouldn't clean it off.
Check your camera settings for WRT dust mapping. It is very particular, I believe the camera must have an AF lens in, and be set to programmed AE with AF turned on or some such.
I have to look it up every time as well because my standard user settings don't allow for the dust mapping to be used either.
02-24-2010, 12:16 PM   #6
Veteran Member




Join Date: Aug 2007
Location: Dayton, OH
Posts: 365
According to the K-7 manual: *coughRTFMcough*

The following conditions must be met before using the Dust Alert function:

-- a DA, DA L, FA J lens, or a D FA, FA, or F lens that has an Auto aperture (A) setting is attached
-- the aperture is set to the A position when using a lens with an aperture ring
-- set the mode dial to any mode other than Movie
-- set the focus lever to AF.S or C.

Check those conditions for something that may keep the Dust Alert feature greyed out.
02-24-2010, 01:15 PM   #7
Veteran Member
Jasvox's Avatar

Join Date: Oct 2007
Location: Melbourne, Australia
Posts: 3,110
Regardless of the capabilities of dust removal, hasn't there been countless threads about the effectiveness and simplicity of a blower used to clean basic dust and or foreign objects from a sensor? Maybe this simple topic should be made into a "sticky" just like that of the "hey, my camera sounds like there is something lose inside"?

Jason
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, dust, photography, piece, sensor
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax K-7 Dust Alert and Dust Removal Functions brosen Pentax DSLR Discussion 9 02-09-2016 04:43 AM
Stubborn aperture ring on SMC-A 50 f/1.7 Sluggo Pentax SLR Lens Discussion 10 01-07-2015 11:07 PM
Blowing dust. Will I get more dust inside ? alphalt Pentax DSLR Discussion 7 05-12-2010 10:09 PM
dust on sensor or dust on lens 41ants Troubleshooting and Beginner Help 10 10-08-2009 10:28 AM
Help with Stubborn Dust Removal Looms Pentax DSLR Discussion 9 02-23-2008 11:18 AM



All times are GMT -7. The time now is 08:08 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top