Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-02-2010, 09:04 AM   #1
Forum Member




Join Date: Feb 2010
Location: Santa Clara, CA
Posts: 91
K7 viewfinder information display broken?

Hi Folks,

So I just got my K7 yesterday and noticed that the viewfinder display seems to be broken. Not all the segments of the 7 segment display of certain digits light up when they should. For instance, the 00 for the ISO never have the E segments (File:7 segment display labeled.svg - Wikipedia, the free encyclopedia ) lit. The A segments for the aperture reading don't light up, neither does the letter F. Similarly the D segments for the shutter speed don't light up.

I was wondering if anyone has had this problem with their cameras and how they went about getting it fixed.

Thanks,
-A.

03-02-2010, 09:18 AM   #2
Inactive Account




Join Date: Aug 2008
Location: Michigan, USA
Photos: Gallery | Albums
Posts: 7,484
QuoteOriginally posted by mapleneckblues Quote
Hi Folks,

So I just got my K7 yesterday and noticed that the viewfinder display seems to be broken. Not all the segments of the 7 segment display of certain digits light up when they should. For instance, the 00 for the ISO never have the E segments (File:7 segment display labeled.svg - Wikipedia, the free encyclopedia ) lit. The A segments for the aperture reading don't light up, neither does the letter F. Similarly the D segments for the shutter speed don't light up.

I was wondering if anyone has had this problem with their cameras and how they went about getting it fixed.

Thanks,
-A.
Some would suggest you send it in for service but I would get it exchanged. Who knows what else is wrong with it. Exchange it, let them deal with it (this is a NEW camera, correct?).

03-02-2010, 09:24 AM   #3
Forum Member




Join Date: Feb 2010
Location: Santa Clara, CA
Posts: 91
Original Poster
Yes this is a brand new camera, thanks for your response. I'm contemplating getting it exchanged as well.
03-02-2010, 10:06 AM   #4
Forum Member




Join Date: Feb 2010
Location: Santa Clara, CA
Posts: 91
Original Poster
I was just going over the return policy at B&H. Looks like they have this clause:

"Items with timers must show less than 120 minutes of use. Items with shutter counters must show less than 200 exposures."

Mine had 388 shutter actuations out of the box.

03-02-2010, 10:32 AM   #5
Inactive Account




Join Date: Aug 2008
Location: Michigan, USA
Photos: Gallery | Albums
Posts: 7,484
QuoteOriginally posted by mapleneckblues Quote
I was just going over the return policy at B&H. Looks like they have this clause:

"Items with timers must show less than 120 minutes of use. Items with shutter counters must show less than 200 exposures."

Mine had 388 shutter actuations out of the box.
Call and get an RMA number. I don't think they are going to give you any problem (could be wrong though), They are aware that shutter counts are never 0 right out of the box. What they are trying to avoid is the Try it out user who will take it on a one week vacation and then return it. You are not returning but asking for an exchange (I assume so anyway).

03-02-2010, 10:42 AM   #6
Forum Member




Join Date: Feb 2010
Location: Santa Clara, CA
Posts: 91
Original Poster
Yes thanks Jeff!. I just had a chat with an online agent, and he e-mailed me an RMA form and a prepaid UPS label instantly. I asked him about the shutter actuations and he said that it shouldn't be a problem since it is defective :-). Will call them during lunch and confirm.

P.S.:
I definitely want an exchange and don't want to just return it :-).
03-02-2010, 01:02 PM   #7
Senior Member




Join Date: Jan 2010
Location: Netherlands
Photos: Gallery
Posts: 148
Make a note of the serial number, so you can check if you indeed get a replacement or a repair.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, display, dslr, k7, light, photography, segment, segments, viewfinder
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-x display # shots in viewfinder opiedog Pentax DSLR Discussion 4 12-06-2009 05:11 AM
viewfinder lcd display k100 vs. k200 tibbitts Pentax DSLR Discussion 0 05-06-2008 03:13 PM
how to get the k10 information in the viewfinder to stay lit? slip Pentax DSLR Discussion 4 10-30-2007 05:05 AM
rear display screen is broken - cracked m8o Photographic Technique 1 09-03-2007 05:53 PM
ISO display in K10D viewfinder ? Confused Pentax DSLR Discussion 5 07-10-2007 05:16 AM



All times are GMT -7. The time now is 11:04 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top