Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-16-2010, 02:34 PM   #16
Veteran Member
kkoether's Avatar

Join Date: Jul 2008
Location: Huber Heights, OH, USA
Photos: Gallery | Albums
Posts: 576
As dumb as it sounds, did you try a fresh set of batteries? My K200D has done similar things when my batteries start getting low.

Hope this helps,

03-23-2010, 07:59 AM   #17
Senior Member




Join Date: Jul 2008
Location: Milwaukee
Posts: 129
I've changed batteries many times.

Any updates?
03-23-2010, 08:04 AM   #18
Pentaxian
johnmflores's Avatar

Join Date: Apr 2009
Location: Somerville, NJ
Photos: Gallery | Albums
Posts: 5,185
try cleaning the contacts on the k-mount and malfunctioning lenses. worked for me.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, lens, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hi guys . supersimon27 Welcomes and Introductions 1 10-02-2010 11:41 AM
How do you guys clean the old Pentax MF lenses? ducdao Pentax SLR Lens Discussion 7 05-24-2010 04:22 PM
Pentax guys to visit local store losecontrol Pentax News and Rumors 2 02-02-2009 09:35 AM
Please guys reassure me about Pentax kipsta Pentax News and Rumors 71 03-18-2008 10:21 PM
hello guys! ;) kjask Post Your Photos! 1 09-11-2006 01:34 PM



All times are GMT -7. The time now is 02:41 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top