Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-17-2010, 01:58 PM   #1
New Member




Join Date: Mar 2010
Location: New Jersey
Posts: 8
K10D Back Display is blank

Hi, recently my K10D display does not show anything. It's blank, as dark as nightime in a cave. The camera has very limited use in the past two years. I was just wondering if anyone has had this problem - accidentally hit a setting or if it's time to bring it into the shop.

03-17-2010, 02:35 PM   #2
Pentaxian
Mike.P's Avatar

Join Date: Mar 2008
Location: South Coast .. UK
Photos: Gallery
Posts: 1,758
What happens if you press the menu button?
03-17-2010, 03:22 PM   #3
New Member




Join Date: Mar 2010
Location: New Jersey
Posts: 8
Original Poster
Nothing, I can still take photos but have to use the LED display on the top - nothing I press on the back (so far) turns the back display on. Any suggestions?
03-17-2010, 03:24 PM   #4
Pentaxian
Mike.P's Avatar

Join Date: Mar 2008
Location: South Coast .. UK
Photos: Gallery
Posts: 1,758
Time to get it looked at I would say .. nothing much you can do if you cant even see the menu to reset.

03-17-2010, 03:31 PM   #5
New Member




Join Date: Mar 2010
Location: New Jersey
Posts: 8
Original Poster
QuoteOriginally posted by Mike.P Quote
Time to get it looked at I would say .. nothing much you can do if you cant even see the menu to reset.

Ah that's too bad. Thanks for your help and quick reply!
03-17-2010, 06:17 PM   #6
Senior Member




Join Date: Feb 2007
Location: Michigan/USA
Posts: 173
My K20 does this quite often, and I can ususally attribute it to changing the lens with a low battery in the camera. So if I pull the battery out and put in a fresh one, or at least pull it out and put the same one back in, it's usually OK. Not sure if your K10D would be similarly satisfied.
03-17-2010, 07:44 PM   #7
New Member




Join Date: Mar 2010
Location: New Jersey
Posts: 8
Original Poster
QuoteOriginally posted by kathyk Quote
My K20 does this quite often, and I can ususally attribute it to changing the lens with a low battery in the camera. So if I pull the battery out and put in a fresh one, or at least pull it out and put the same one back in, it's usually OK. Not sure if your K10D would be similarly satisfied.

Hi Kathy I tried it out and it still is blank. Recharged the battery and did it again but it is still blank. I'm a bit bummed but thanks for the suggestion.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, display, dslr, k10d, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax k100d Super back LCD display problem pisach Pentax DSLR Discussion 2 05-30-2010 10:31 PM
K10D corrupted/blank images issue Mart Pentax DSLR Discussion 6 10-31-2009 12:42 PM
K10D wierd display! But my dumb Canada_Rockies Pentax DSLR Discussion 5 01-21-2009 08:03 PM
K10D histogram display jjfdvm72 Pentax DSLR Discussion 3 12-15-2007 08:44 PM
ISO display in K10D viewfinder ? Confused Pentax DSLR Discussion 5 07-10-2007 05:16 AM



All times are GMT -7. The time now is 04:44 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top