Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-21-2010, 09:34 PM   #1
Pentaxian




Join Date: Jan 2009
Location: Nevada, USA
Posts: 465
K200D broken - Mirror stays up, picture not saved

See a short description of the problem in post #2.

My K200D stopped working a couple of days ago. Everything appears to work normally except when I press the shutter release, the mirror stays up for about 3/4 second regardless of the shutter speed and then the Guide display comes on (just as it does when you first turn on the camera). However it does not save a picture. It behaves like this whether using 18-55 kit lens, an SMC Takumar, or no lens at all.

All menu functions, controls, viewfinder display, top and back LCDs, autofocus all work normally. The camera asks for focal length when a Takumar is mounted, as it should.

The meter responds like I expect, and the shutter seems to open and close appropriate to shutter speed setting: I can see a definite reflection of the sensor at 1/60 sec., just barely at 1/250 sec. and not at all at 1/4000 sec.

The diaphram on the 18-55 kit lens stops down, and stays down for as long as the mirror is up. The amber SD card write light comes on, but the picture is not saved. Existing pictures on the SD card are displayed correctly on the camera.

If I set a shutter speed lower than 1/15 second, the mirror stays up. When I turn the camera off, the mirror is still up. When I remove the batteries, the mirror is still up. The mirror only returns when I put the batteries back in and close the battery door (while the camera is still turned off).

Shake reduction off/on, AF/MF, JPEG/RAW, JPEG size or quality, single or HI or Lo continuous drive mode, metering mode, P, Sv, Tv, Av, M do not make a difference; it fails just the same.

Other things I've tried:
Use nearly fresh set of Energizer lithiums.
Use freshly charged Rayovac Hybrids.
Format SD card.
Remove batteries overnight.
Slightly bend tabs in battery compartment to make sure they are tight.
Clean connection tabs in battery compartment.
Clean lens contacts.
Use brand new set of Energizer Ultimate Lithiums.
Leave new batteries in camera 15 mins. before turning the camera on.
Use brand new SD card.

Any ideas of what is wrong?


Last edited by cfraz; 03-22-2010 at 07:32 PM. Reason: Pointer to summary post
03-22-2010, 07:30 PM   #2
Pentaxian




Join Date: Jan 2009
Location: Nevada, USA
Posts: 465
Original Poster
Problem summary

Hoping someone will respond to this shorter description:

My K200D has stopped saving pictures. Also, the mirror stays up the same length of time (about 3/4 second) for any shutter speed above 1/20 sec. At shutter speeds 1/15 sec. and lower, the mirror stays up until the batteries are removed and then replaced.

Installing new Energizer Ultimate lithium batteries and a new SD card did not help.

Any ideas of what is wrong?
03-22-2010, 08:38 PM   #3
Pentaxian
Clicker's Avatar

Join Date: May 2008
Photos: Gallery
Posts: 3,241
Did you try to reset the settings in the menu options under "set-up"? If that doesn't help, it seems more like a mechanical break down?

I read your post yesterday and it's the first time i've come across this issue, i'm not sure if other past or present users have had your issue?
03-22-2010, 08:54 PM   #4
Pentaxian




Join Date: Jan 2009
Location: Nevada, USA
Posts: 465
Original Poster
Yes, reset the menu settings.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
batteries, battery, camera, card, dslr, lens, lithiums, mirror, photography, picture, sd, shutter
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K200d mirror cycles on its own - no image taken rae2 Pentax DSLR Discussion 12 11-01-2010 09:49 PM
New K200D - Please help. Slow picture release sue Pentax DSLR Discussion 18 12-22-2008 09:36 PM
New k200d: Is my body's aperture control broken? brockj Pentax DSLR Discussion 4 10-21-2008 08:24 AM
Picture numbering in a K200d hmcfly Pentax DSLR Discussion 3 05-18-2008 09:25 AM



All times are GMT -7. The time now is 04:25 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top