Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-06-2010, 12:58 AM   #1
Inactive Account




Join Date: Apr 2010
Location: lusaka
Posts: 3
flash does not work pentax k-x

Hi ,

I have just become a proud owner of a Pentax k-x camera with 18-55mm zoom ,its my first Pentax.

the two problems i am facing are as follows:-

1) I can not get the flash to work regardless of which mode i put the camera in.for example if i put the camera in Tv mode set the shutter speed then i open the flash . The moment i pressure the shutter release button ,the shutter does not activate however if i close the flash the shutter activates.

2) When i record video in hd mode on playing there is no sound even though it has been activated from the main menu.Regardless of whether i play the file through the camera or by copying it to a computer.

If anyone can help i will be most grateful .

Ismail rashid

04-06-2010, 05:49 AM   #2
Ira
Inactive Account




Join Date: Mar 2009
Location: Coral Springs, FL
Photos: Gallery | Albums
Posts: 5,218
QuoteOriginally posted by ISMAILRY Quote
Hi ,

I have just become a proud owner of a Pentax k-x camera with 18-55mm zoom ,its my first Pentax.

the two problems i am facing are as follows:-

1) I can not get the flash to work regardless of which mode i put the camera in.for example if i put the camera in Tv mode set the shutter speed then i open the flash . The moment i pressure the shutter release button ,the shutter does not activate however if i close the flash the shutter activates.

2) When i record video in hd mode on playing there is no sound even though it has been activated from the main menu.Regardless of whether i play the file through the camera or by copying it to a computer.

If anyone can help i will be most grateful .

Ismail rashid
The flash requires a shutter speed of 180 or less, and the burst is much faster than that.

I have the kx, and I don't know for sure, but the on-board flash might not even operate in Tv mode if you set the shutter speed faster than 180.
04-06-2010, 06:42 AM   #3
Inactive Account




Join Date: Apr 2010
Location: lusaka
Posts: 3
Original Poster
QuoteOriginally posted by Ira Quote
The flash requires a shutter speed of 180 or less, and the burst is much faster than that.

I have the kx, and I don't know for sure, but the on-board flash might not even operate in Tv mode if you set the shutter speed faster than 180.
i have tried with shutter speed lower then 180 but it still does not work
04-06-2010, 07:36 AM   #4
Ira
Inactive Account




Join Date: Mar 2009
Location: Coral Springs, FL
Photos: Gallery | Albums
Posts: 5,218
QuoteOriginally posted by ISMAILRY Quote
i have tried with shutter speed lower then 180 but it still does not work
Does it work in other modes?

04-06-2010, 07:50 AM   #5
New Member




Join Date: Apr 2010
Location: GA
Posts: 11
What lens are you using? Try changing the lens to the included kit lens and see if your Flash works after that.
See page 161 in the K-x manual that talks about Flash being unavailable when using certain lenses due to vignetting.

Try following pg 148 to set up sound when making a movie. Also check whether you have increased the playback volume to audible levels as described in pages 148 throuh 151.

All the best.
Krishna
04-06-2010, 10:52 AM   #6
Junior Member




Join Date: Jan 2010
Location: Sunny SoCal
Posts: 49
Shouldn't you set it at manual flash instead of auto flash in the settings?
04-07-2010, 01:11 AM   #7
Inactive Account




Join Date: Apr 2010
Location: lusaka
Posts: 3
Original Poster
I have tried the other modes as well Av,M and it does not work ,Setting the flash to manual does not make a difference.

The lens i am using is the 18-55 kit lens which comes with the camera.
04-07-2010, 01:31 AM   #8
Veteran Member
nulla's Avatar

Join Date: Jul 2008
Location: Melbourne Australia
Posts: 1,560
QuoteOriginally posted by ISMAILRY Quote
I have tried the other modes as well Av,M and it does not work ,Setting the flash to manual does not make a difference.

The lens i am using is the 18-55 kit lens which comes with the camera.
This might be a silly question but I must ask the obvious

Are you raising the flash by pressing the "up" button

Also what settings have you set for flash.?

Troubleshooting flash is on page 287 of the K-x manual

another thing you could do is reset to default settings and see if that helps.

otherwise it sounds like you have a fault in the camera



Neil


Last edited by nulla; 04-07-2010 at 01:53 AM.
04-09-2010, 09:21 PM   #9
New Member




Join Date: Apr 2010
Posts: 1
I am having the exact same problem with my new K-X. I have tried all the different modes that SHOULD use the flash. It pops up like it is going to discharge but never does. Same thing happens when the flash is set to manual and I push the flash up button. Any suggestions??? I may just have a faulty camera?
04-11-2010, 08:43 PM   #10
New Member




Join Date: Apr 2010
Location: NSW
Posts: 1
Same thing is happening to me, but I got it working by going into portrait mode with manual flash. Then popped the flash up and it worked! then I changed it to Manual Exposure (1/100 f4.5) without turning it off or shutting the flash and it worked again...

If I turn it off or close the flash lid it won't work again... I'm guessing its a firmware or software error?

Anyways thats what I've found out... can anyone else confirm what I did?

thanks.

update:
its working flawlessly now for some reason... I think a reset helps...

Last edited by kdk087; 04-12-2010 at 05:28 AM.
06-17-2010, 10:32 PM   #11
Senior Member




Join Date: Jun 2010
Location: Florida
Posts: 118
I'm having the same problem. It won't flash at all. No matter what mode I'm in.

I just tried manual flash in portrait but it still didn't work.
06-18-2010, 08:55 AM   #12
Pentaxian
Marc Sabatella's Avatar

Join Date: Sep 2006
Location: Denver, CO
Photos: Gallery
Posts: 10,686
Is it possible the batteries are too weak to power the flash? have you set the battery type option appropriately? Are the cells freshly charged? Or, if non-rechargeable, they aren't alkalines, are they? Those basically don't work.
06-18-2010, 09:14 AM   #13
Senior Member




Join Date: Jun 2010
Location: Florida
Posts: 118
they are brand new lithiums :< and i have the battery setting set correctly

in a dark situation, the flash never pops up on it's own
also when i manually pop it up, there's a flash icon in the viewfinder, and when I half press, the icon blinks, but when i take the picture nothing, i thought maybe it wanted me to wait till it's done blinking, so i held it half pressed for like 3 whole minutes and it still kept blinking
06-18-2010, 11:26 AM   #14
Ira
Inactive Account




Join Date: Mar 2009
Location: Coral Springs, FL
Photos: Gallery | Albums
Posts: 5,218
First make sure In Custom Menu 3 that Item 16 is set to 1 (off).


Also, you don't happen to have HDR on, do you? Or another auto bracketing function?
06-18-2010, 12:16 PM   #15
Veteran Member
subeeds's Avatar

Join Date: May 2010
Location: Camden County, Ga.
Photos: Gallery
Posts: 333
Sorry to hear you are having problems. I haven't encountered anything like like that with my new K-X. I have the flash turned off on the menu and when I want to use it, I just do it manually by popping it up with the button.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, flash, k-x, mode, pentax, photography, shutter
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Why won't Pentax flash PTTL work? jshram Flashes, Lighting, and Studio 61 04-02-2010 08:55 AM
Would an Asahi Pentax flash (AF200s) work with my K200D? causey Flashes, Lighting, and Studio 2 09-14-2009 09:13 AM
Ring Flash Idea would be very cool if it would work on Pentax Peter Zack Flashes, Lighting, and Studio 13 06-25-2008 08:06 AM
Will this flash work on my Pentax K100D? vmax84 Pentax DSLR Discussion 7 03-02-2008 04:47 AM
Will the Miranda 700CD multi dedicated flash work with my Pentax *ist DS? cotterill666 Flashes, Lighting, and Studio 0 11-21-2007 07:24 AM



All times are GMT -7. The time now is 11:57 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top