Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-08-2010, 03:18 PM   #1
Forum Member




Join Date: Jul 2008
Location: tokyo
Posts: 83
lens mount movement in k10d body

I have just noticed after clicking a lens into place on the k10d that there some rotational play. Could anybody tell me if this is normal?

04-08-2010, 03:41 PM   #2
Forum Member
Timichango's Avatar

Join Date: Feb 2010
Location: Vancouver
Photos: Albums
Posts: 62
I don't own a k10d, so my opinion here may not be worth much, but I've owned a bunch of cameras, and I've never seen a lens mount that moved independently of the body. My money's on 'loose screw(s)', 'glue failure', or 'cracked plastic'...

You sure it's not just that the lens has some rotational play within the mount in the locked-in position? Depending on the lens/camera, most of my lenses have about 0.5-1mm of rotational play when mounted, and turned with a bit of force.

**edit** I just re-read your original post, and realized that I assumed that you meant the body mount was moving, but you didn't say this explicity, so I apologize if that sounded alarmist. If the mount flange that's in the body is moving, you've got problems. If you're just talking about the lens itself having a bit of rotational play within the camera, then I'd say that a wee bit of play is perfectly normal.

Last edited by Timichango; 04-08-2010 at 03:47 PM. Reason: addendum
04-08-2010, 04:24 PM   #3
Veteran Member
Tuner571's Avatar

Join Date: Mar 2008
Location: Ohio
Photos: Gallery | Albums
Posts: 1,550
I agree with Tim on this one, if the lens mount on the camera is moving back and forth I would get that checked out immediately. As that could mean that some screws are missing or the plastic housing has been cracked.

If it is the lens that is moving that is somewhat normal to an extent. On my K20D there is some very, very slight movement, but not enough to really notice unless you were looking for it.

Cory
04-08-2010, 07:23 PM   #4
Pentaxian
Wheatfield's Avatar

Join Date: Apr 2008
Location: The wheatfields of Canada
Posts: 10,157
Is it the lens moving slightly against the body? Or the body flange rotating slightly?
If it's the former, and it's very slight, then it's normal. If it's the body flange that is moving, then no, it isn't.
If the body flange is at fault, you can try tightening the mount screws. If they have backed off a bit, then that will cause the mount to wiggle a bit.
If it's just one lens, then you could also try tightening the lens mount screws for the same reason.
I suspect that you have nothing to be concerned about though.

04-08-2010, 10:29 PM   #5
Senior Member
AOShep's Avatar

Join Date: Feb 2010
Location: Eastern PA
Photos: Gallery | Albums
Posts: 293
Is it one lens or all lenses? A little process of eliminatation will help.
04-08-2010, 11:31 PM   #6
Forum Member




Join Date: Jul 2008
Location: tokyo
Posts: 83
Original Poster
Thanks for all the comments. I have looked closer and you are correct in that the play is in the lens and not the body. Phew!!! Big sigh of relief here. Thanks again.
04-09-2010, 08:15 AM   #7
Veteran Member
GerryL's Avatar

Join Date: Jan 2009
Location: CA
Posts: 2,731
QuoteOriginally posted by kiwao Quote
Thanks for all the comments. I have looked closer and you are correct in that the play is in the lens and not the body. Phew!!! Big sigh of relief here. Thanks again.
What type of lens is it?
Maybe as the others have suggested, you can just tighten a screw..the owrst would be to change the mount altogether.
The actual mount should also have a square cut in one of the lips as that would prevent the lens from over-turning in the mount.
This is experienced from the non OEM M42 adapters.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, k10d, lens, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax DA* 16-50 lens barrel movement(?) Egg Salad Pentax SLR Lens Discussion 8 02-05-2010 06:48 AM
For Sale - Sold: K10D body, DA 18-55mm kit lens, Tamron DiII AF18-250mm lens; Tamrac Velocity 8 gimmepizza Sold Items 9 12-01-2009 05:26 AM
Wanted - Acquired: Adapter--M42 lens to K-mount body (Genuine Pentax, please) Sigmoid Sold Items 1 11-25-2009 10:10 AM
AF possible with K mount lens on a 4/3 body? emr Non-Pentax Cameras: Canon, Nikon, etc. 1 09-30-2009 02:20 PM
Is there a mount for Minolta lenses, on a k10d body? ranamar Pentax SLR Lens Discussion 12 06-23-2008 11:49 AM



All times are GMT -7. The time now is 06:19 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top