Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-16-2010, 09:47 AM   #1
Forum Member




Join Date: Oct 2007
Location: Los Angeles
Posts: 88
Help with Metz 48

My Metz 48 is acting odd, & seem not to be able to communicate between the the camera body & act as a dedicated flash. Can some one give me some suggestions?

Is it the camera or the flash at fault? Please advise. Thanks.

Symtems:
- Can't get the "P TTL" or P TTL HSS" mode up from time to time.
- Shutter doesn't change to sync speed when flash power on.
(i.e 1/5" f4 iso400, not 1/40, 1/60, 1/100..etc depend on the focal length)
- Shutter change back & fore between normal exposure & sync speed
(i.e when using flash bracket or EV bracket with flash , shutter was 1/60, then back to 1/5 on 2nd shot, than back to 1/60 on 3rd shot @f4 ISO 400.
- sometime, it keep flashing as the shutter change back & fore as if I ramdonly pressing the test button.
- Wireless TTL seem to be fine
- Did not test HSS yet.

Thanks

Steven
K20d + grip,Tamron 17-50, DA* 50-135,
Sigma 24/2.8, FA50/1.7, FA77, Kenko 1.5xTC, Metz 48,
Domke F-5Xb, Domke F-5XC

04-16-2010, 10:24 AM   #2
Veteran Member
parsons's Avatar

Join Date: Apr 2010
Location: ENGLAND
Posts: 389
i have never had any trouble with my metz 48, so sorry cant help.

maybe it is just faulty. how long ago did you buy it?
04-17-2010, 02:09 AM   #3
Veteran Member




Join Date: Jan 2009
Location: Budapest
Posts: 821
Sounds like dirty contacts. Clean the contacts of the flash and the camera hotshoe.
04-19-2010, 04:24 AM   #4
Veteran Member
MoiVous's Avatar

Join Date: Sep 2008
Location: Adelaide, South Australia
Photos: Gallery
Posts: 671
QuoteOriginally posted by slam Quote
My Metz 48 is acting odd, & seem not to be able to communicate between the the camera body & act as a dedicated flash. Can some one give me some suggestions?

Is it the camera or the flash at fault? Please advise. Thanks.

Symtems:
- Can't get the "P TTL" or P TTL HSS" mode up from time to time.
- Shutter doesn't change to sync speed when flash power on.
(i.e 1/5" f4 iso400, not 1/40, 1/60, 1/100..etc depend on the focal length)
- Shutter change back & fore between normal exposure & sync speed
(i.e when using flash bracket or EV bracket with flash , shutter was 1/60, then back to 1/5 on 2nd shot, than back to 1/60 on 3rd shot @f4 ISO 400.
- sometime, it keep flashing as the shutter change back & fore as if I ramdonly pressing the test button.
- Wireless TTL seem to be fine
- Did not test HSS yet.
I've had what I thought were intermittent problems with my Metz AF48. I thought I had a problem - like pTTL wouldn't display, it would flash randomly, etc almost as you describe.

It turned out I didn't have the unit screwed down firmly. Seems the contacts need to be firm. Once its tightenned up it behaves fine.

Maybe thats the solution.......

Cheers

04-19-2010, 04:37 AM   #5
Veteran Member




Join Date: Aug 2007
Photos: Gallery
Posts: 1,563
It is a contact problem, happens to my K10D all the time.
Try roughning the contacts.

- Bert
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
bracket, camera, change, domke, dslr, flash, fore, i.e, metz, photography, shot, shutter, test
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Metz 58 wireless not working? Metz 48 works great? Ideas? ksignorini Flashes, Lighting, and Studio 6 02-07-2010 05:33 PM
Metz 58 AF-1 Fl_Gulfer Flashes, Lighting, and Studio 2 10-19-2009 08:50 AM
Metz 48 AF 1 Landaris Photographic Technique 12 03-02-2008 06:40 AM
Metz 58 anthonysemone Flashes, Lighting, and Studio 10 01-17-2008 04:10 AM



All times are GMT -7. The time now is 12:33 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top