Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-29-2012, 06:20 AM   #1
Pentaxian
eccs19's Avatar

Join Date: Jul 2008
Location: Lisle, Ontario
Photos: Gallery
Posts: 1,458
Pentax X-5 - List your issues here.

Figured it might be a good resource to have a single list of X-5 issues in one thread. Something to build on as time goes along. Feel free to add your minor or major issues here.

So I took my X-5 back to Henrys yesterday. They gave me a straight exchange after owning it from October. (extended warranty)

We were having troubles with the flash of all things. It would sparatically lock up the camera when the flash fired. Only way to unlock the camera was to open the battery area. At first I figured it was just dead batteries, but fresh batteries and 6 shots later, froze again. Not sure if it was a issue with that camera, or if it's a common issue that needs to be addressed with a firmware update. I'll update if replacement still has the same issue.

12-29-2012, 09:57 AM   #2
New Member




Join Date: Dec 2012
Posts: 24
QuoteOriginally posted by eccs19 Quote
Figured it might be a good resource to have a single list of X-5 issues in one thread. Something to build on as time goes along. Feel free to add your minor or major issues here.

So I took my X-5 back to Henrys yesterday. They gave me a straight exchange after owning it from October. (extended warranty)

We were having troubles with the flash of all things. It would sparatically lock up the camera when the flash fired. Only way to unlock the camera was to open the battery area. At first I figured it was just dead batteries, but fresh batteries and 6 shots later, froze again. Not sure if it was a issue with that camera, or if it's a common issue that needs to be addressed with a firmware update. I'll update if replacement still has the same issue.
Not noticed any issue with the flash or anything else. Not likely too either. I have had seven Pentax cameras and never an issue
12-29-2012, 10:33 AM   #3
Pentaxian
eccs19's Avatar

Join Date: Jul 2008
Location: Lisle, Ontario
Photos: Gallery
Posts: 1,458
Original Poster
QuoteOriginally posted by JEREMYHN100 Quote
Not noticed any issue with the flash or anything else. Not likely too either. I have had seven Pentax cameras and never an issue
I suspect a bit of a fluke more than anything. I've owned a number of Pentax as well, and have always been happy. Just luck of the draw with this one.
12-30-2012, 04:23 AM   #4
New Member




Join Date: Dec 2012
Posts: 24
QuoteOriginally posted by eccs19 Quote
I suspect a bit of a fluke more than anything. I've owned a number of Pentax as well, and have always been happy. Just luck of the draw with this one.
Seven cameras ...no issues, not a fluke my friend. Its PENTAX.

06-03-2013, 01:46 PM   #5
New Member




Join Date: Jan 2008
Posts: 22
Same Problem...

Bought mine in December. Problem wasn't noticed as I was shooting primarily outdoors with daylight. Last week shot some flash pics and... Bingo! Lockup!
No firmware updates as yet from Pentax. Those are probably in cue.
08-10-2013, 04:03 AM   #6
New Member




Join Date: Aug 2013
Posts: 1
Same problem. Bought the X5 in June 2013 and it has locked-up 3 times, all when using the flash outdoors. Have to open the battery door to shut it off. Tried to duplicate the problem by taking shots in total darkness with flash but it works every time.????
02-24-2014, 03:20 PM   #7
New Member




Join Date: Feb 2014
Posts: 1
Same issue, seeing a trend.

When using the flash at night, I've had exactly the same lock-up problems - about 4-6 pictures then it clicks on the next picture, the screen goes dark and it freezes. But, I can shoot all day in the light with or without the flash without any problem.

It would appear that the issue might have something to do with the flash unit and the intensity of the flash. My guess is that it's a recharging issue - something gets hot or the flash draws so much power it causes issues. But it's definitely easy to reproduce the flaw.

With my settings on auto, default (only set the date), memory only on flash use, I shot 40 pictures without a problem in my living room during the afternoon. 20 were with flash and 20 were without. (nice imaging, by the way) Then I went to my desk, which has a dark corner, and shot another 20 shots without the flash. No problem. Then I used the flash, got 8 shots and it locked up. I reset (pop open the battery compartment, turn it off, back on etc.), shot 20 shots in the dark without a problem. I popped up the flash and got 6 before it locked up again. I reset, used the flash again and it locked up after 5. I reset, didn't use the flash and got 20 without any problems.

The flaw is repeatable, identifiable and fixable, but this unit's been out since 09/12 and there's been no firmware updates. Even finding the camera on the Pentax/Ricoh sites is next to impossible (this forum doesn't even have a "X-5" for "what kind of Pentax do you own!").

Since it doesn't have a hot-shoe, this presents something of a problem when shooting at night if you need flash. If you don't use a flash (at least with my camera), it's not a problem. My indoor shooting tends to be spontaneous and flash is important. It's a really nice camera without this problem. But my recommendation is to find a hand-held, soft spot (put a piece of paper in front to soften shadows) to mostly illuminate what you shoot instead of using the flash at night, and avoid using the flash at all unless you just need a couple of front-fill shots when you have too much back-lighting.

I'm going to bet if you folks try this, you'll see what I mean. If anyone can make it lock up WITHOUT every using the flash, please post it.
03-16-2014, 09:56 AM   #8
New Member




Join Date: Jan 2008
Posts: 22
Sent to Pentax for Repair - Still a problem

Finally sent my Z-5 to Pentax for repair. Got it back (with a big gash on the lens cover!). Tried it out - still can replicate the lockup problem.

I think this is a non-supported lower end camera. I really love it as a knock-around, great photos and oh that lens. Not bad at all for the price paid. Just wish by now there would have been a firmware upgrade, maybe that is not possible with this camera.

Just have to know when it locks and avoid the conditions if possible.

03-20-2014, 11:55 AM   #9
New Member




Join Date: Mar 2014
Posts: 1
Same flash problem.

I''ve had my Pentax X-5 for about a year now. Love the camera except for the flash locking up on occasion. I've tried every flash setting and they all seem to work fine for a while, then when I REALLY need it to work for an inside shot, It locks up. Please let us know when and if Pentax has a fix. Still the best value for the money in my humble opinion.
03-22-2014, 09:26 PM   #10
Site Supporter
LightBug's Avatar

Join Date: Nov 2007
Location: OC, CA, USA
Posts: 411
I've had the X-5 for a week now. When I first tried to use M mode, I often get under exposed shot with no warning. Then after a few bad shots, I see the yellow warning sign at the lower left corner about current exposure settings being incorrect. So seems like the metering in M mode does not turn on reliably. This forced to me to use P mode most of time now.
**** Correction: I just re-read the manual, seems like I interepreted the yellow warning sign incorrectly. When it displays "+/-" without number, it simply means it it's over or under exposed more than 2.0 EV. Now I know that, I will be able to try M mode again.

Also, this may not be a "bug", but it bugs me that whenever I press the "play" button to review my pictures, I have to switch the display from EVF to LCD via the "EVF" button. There ought to be an option to automatically direct picture review to always be on rear LCD. I can't imagine anyone enjoy reviewing their picture through the EVF.

I hope Ricoh/Pentax keeps updating the firmware/performance of this little cam, its got a few quirks that should be fixable to make it better.

**** Addition: I read online that some people are annoyed with having to take off the lens cap just to review pictures when starting up the camera with the on/off button. There is a "Playback Shortcut" option in the "Settings" menu that will allow one to start the cam via the "Play" button, and the lens will not extend out like it normally would when "on/off" button is used to start the cam.

Last edited by LightBug; 03-22-2014 at 11:17 PM.
03-22-2014, 10:16 PM   #11
Forum Member




Join Date: Sep 2011
Location: San Antonio, TX
Posts: 57
Mine has just been erratic. I haven't used it that much and it's too late to return it. It is just a different animal than my FZ35 and even my older Nikon 8800 zoomers. Going to look at the new Olympus SP100 that comes out next month for a zoomer. But I will keep trying it as I have time.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
batteries, camera, digital camera, flash, issue, issues, list, pentax cameras, point and shoot, x-5
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax K-x memory issues Gerrard Visitors' Center 3 03-08-2013 04:18 PM
K-5 camera - No Issues - *Post Here* GreenMachine Pentax K-5 75 05-11-2012 08:40 PM
Issues opening files from a Pentax K-x Memoreno Troubleshooting and Beginner Help 3 12-21-2011 12:34 PM
TAMRON 28-80mm f/3.5-5.6 77D - is this compatible with my K-X? newbie here SweetSherri Pentax SLR Lens Discussion 4 04-03-2011 03:53 PM
List Your Worst Flea-Bay Purchases Here Youngster General Talk 18 11-09-2008 11:44 PM



All times are GMT -7. The time now is 09:12 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top