Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-24-2008, 01:31 AM   #1
Inactive Account




Join Date: Aug 2008
Location: England
Posts: 2
Problem with Optio M20

Hi all,

I've just joined this forum in the hop that someone can help me with a problem with my Optio M20.

I've only had it two years and it doesn't get a great deal of use which is why I was surprised to find that all of a sudden it doesn't work!

When the unit is turned on, it seems to do all the right things in that the LCD turns on, the lens pops out, except that once the lens pops out, there is a small buzzing sound. The lens retreats, pops out again, then the little buzz and the lens goes back and the camera switches off. I can't take any photos!!

Has anyone any ideas about what this problem could be? Is it terminal or can it be fixed?

Any help would be appreciated.

Regards,

Chris.

08-25-2008, 09:09 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 42,347
Moved to the appropriate section.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

08-26-2008, 11:15 AM   #3
Junior Member




Join Date: May 2008
Location: Ĝlgod, Denmark
Photos: Gallery
Posts: 48
Hi Chris.
I think there is a problem with the lens, maybe you have damaged it, droped it or somthing like that or there has come some dirt in the small gears.
You can maybe pull it apart , take the lens out, open to the gear and clean the small wheels, but be carefull.
I have done it to severals cameraes with luck.
Naturally it also can be an other fault, I don't know.
I think it will be to expensive to get it repaired in a shop.

Regards Erik

ps. and to all other in the forum, I know my english is bad, just trying to help!!!
08-26-2008, 05:31 PM   #4
Damn Brit
Guest




Check out Gooshins signature.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
digital camera, help, lens, m20, optio, pentax cameras, point and shoot
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Optio S4 problem davagius Pentax Compact Cameras 1 08-11-2009 11:47 PM
Problem with Optio M20 cjiveson Pentax Compact Cameras 0 08-24-2008 11:43 AM
Optio 40 problem donmckeown Pentax Compact Cameras 5 07-15-2008 07:51 PM
Pentax Optio S4 problem davagius Photographic Technique 0 05-13-2008 05:35 AM
Optio m20...Feeling out of Place here flpoodle Pentax Compact Cameras 5 04-25-2007 06:32 AM



All times are GMT -7. The time now is 10:43 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top