Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-04-2009, 04:56 AM   #1
New Member




Join Date: Apr 2009
Location: Leeds
Posts: 1
Image display problem

Hi, I joined this site after I did a Google search for the error message my camera kept coming up with and saw someone had posted something similar 2 years ago about an A10. My camera is driving me a little bit mad now ! It's an Optio S10, and sometimes it will play back the pictures, sometimes it will just decide suddenly that it's not gonna do that any more, and says 'Camera cannot display this image and sound'. Sometimes it will go back to working again after a few of these, and sometimes it won't. If I bring the pictures up on the computer, the first one that came up with that message will be half picture, half grey, and the rest after that will be all grey.
It has a memory card, 8gb SD, which I can't really take pictures without because it's internal memory is tiny and fills up in no time at all. I read something on the previous thread about the card being the possible problem, and formatting the card ? I've no idea what that means, never mind how to do it !
It doesn't have anything in the manual about how to fix this problem and I've tried everything I can think of, tried every different mode, and it's still being temperamental. It's really annoying because you don't know until you go through your pics at the end and find that most of the ones you took have been lost
Anyone any ideas what I can do ? Any help greatly appreciated !

04-04-2009, 07:44 AM   #2
Pentaxian
Wheatfield's Avatar

Join Date: Apr 2008
Location: The wheatfields of Canada
Posts: 10,199
Just a shot in the dark, but try a smaller card, perhaps go to a 2GB (not SDHC) card, preferably from one of the well known brands such as Sandisk. Sometimes cameras can be a little touchy about what's put into them.
04-04-2009, 03:38 PM   #3
Veteran Member




Join Date: Jan 2008
Location: Ste-Anne des Plaines, Qc., Canada
Posts: 2,014
The Optio S10 is limited to 2 gb. SD cards. Using an 8 gb. card could explain your problem. If it is like other Optio, you go in the "menu", then use the navigation pad to go to "set up", and the first line should be "format", so you format the card there. You should try to use cards that are 2 gb. or below to avoid problems.
04-04-2009, 03:52 PM   #4
Veteran Member
Jewelltrail's Avatar

Join Date: May 2008
Location: Rhode Island
Photos: Albums
Posts: 4,180
magpie: If you go here Pentax Compact Camera Discussion - PentaxForums.com someone should be able to help you. This is the part of the forum which specializes in P & S models.

I'll bet, in a jiffy, a fellow owner of an Optio S10 will tell you how to format.

04-05-2009, 06:37 PM   #5
Loyal Site Supporter
Loyal Site Supporter
monochrome's Avatar

Join Date: Mar 2008
Location: Kirkwood (St. Louis) MO
Photos: Gallery | Albums
Posts: 20,612
Magpie: quick scan of the manual (downloaded from Pentax Support) gives some areas for you to look into.
  1. Instructions for formatting your SD card are found on page 168. Always delete images and format your card in the camera, not from your computer. All digital cameras are finicky about the way SD cards are formatted (which sets up an internal indexing system similar to a library index card file showing where the data that makes up an image is located on the card).
  2. Instructions for deleting images are found on page 131 of your manual
  3. Page 26 refers to the number of images that can be stored on a 512Mb card. At the time you bought your S10 large (8Gb) cards were exotic - I'm not even sure SDHC cards had been invented yet. flyer's idea to get yourself a 2Gb card is probably a good one - I just saw a Sandisk 2Gb at Walgreen's (USA pharmacy and notions chain) for $9.49. They are likely not too expensive in the UK.
  4. Store images you want to keep on a CD or PC, delete ALL the images from the card and Format it from time to time to keep the card fresh.

Here's a link to value cards on the Sandisk USA website Imaging Cards

Hope this all helps!

Last edited by monochrome; 04-05-2009 at 07:02 PM.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, card, digital camera, display, half, image, image display, memory, message, pentax cameras, pictures, point and shoot
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax K-x image display color flickering problem. Coeurdechene Pentax DSLR Discussion 5 04-24-2012 05:07 PM
Display problem in gallery Iam1of2 General Talk 3 04-17-2010 03:08 PM
Failure to fire/display problem smf Pentax DSLR Discussion 2 11-09-2009 10:51 AM
Image Resolution for Display calicojack Troubleshooting and Beginner Help 9 10-25-2009 11:21 AM
Pentax k10d display problem help lol pwnstar Pentax DSLR Discussion 3 05-09-2008 08:27 PM



All times are GMT -7. The time now is 04:30 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top