Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-17-2017, 09:19 AM   #1
New Member




Join Date: Mar 2017
Posts: 7
Wind lever and others aren't working on Pentax P30T

Hello and I'm sorry to start this troubleshooting post.
Recently I've finished first film with P30T. So after the last shot was done I've cocked the wind lever almost to the end but since it was the end of the film nothing had happened, and I wasn't able to release shutter because pressing on the shutter release button does nothing. Then I pressed the release button at the bottom of the camera, rewinded it and pulled film out, but this release button has stucked and wind lever started to work oddlly - it moves to the end but does not advance anything, it just moves freely without any resistance. I've fixed (?) the release button by manually advancing film take up spool, but after that film sprocket spool goes locked and that's all. I've tried new batteries but it was useless, and now I have no idea what to do. Maybe you have any thoughts how to fix it?

03-17-2017, 09:48 AM - 1 Like   #2
Moderator
Not a Number's Avatar

Join Date: Mar 2012
Location: Venice, CA
Posts: 9,620
Open the film door and look for a little tab that sticks out from the door. On the camera body there will be a slot for the tab with another tab or lever in there. Make sure that tab is not stuck - the light seals often gets sticky and gums this tab up. When this tab moves it should reset the rewind button and frame counter.

Try setting the camera to manual and trying the shutter.
03-17-2017, 09:59 AM - 1 Like   #3
Site Supporter
Site Supporter
murrelet's Avatar

Join Date: Dec 2007
Location: Portland, OR, USA
Photos: Gallery | Albums
Posts: 505
Could it be related to this:

QuoteQuote:
The worst thing about this camera is a particularly nasty failure mode in which the film-advance lever shears off its spindle, making it impossible to wind on the film any further. If you're shooting and winding-on quickly, it's possible to get overenthusiastic - and if the end-of-the-roll "pause point" of the film advance is in the second half of the stroke where the thumb has maximum mechanical advantage, and the internal spindle is brought to rest by the film "end" while the advance lever is being driven over hard, that's where the shearing is going to happen. I think this is how I broke mine. (EDIT: after repair, this was found NOT to be the case. Although this failure mode has been described, there was in my case a skipping of the gears of some sort which was easily correctable.)
03-17-2017, 10:11 AM - 1 Like   #4
Veteran Member
Ontarian50's Avatar

Join Date: Mar 2015
Posts: 530
Give that wind lever a firm push to the end of its travel and let it snap back.

Sometimes when you get the end of a film, you end up winding the shutter 98% of the way. Getting that last 2% wound can require being a little aggressive. Pentaxes aren't the only cameras out there where this happens.

After that the rewind button will re-set on its own. Don't worry about it.

03-17-2017, 10:39 AM   #5
New Member




Join Date: Mar 2017
Posts: 7
Original Poster
Huge thanks to you guys, it seems that I was pretty rude with wind lever.

QuoteOriginally posted by Ontarian50 Quote
Sometimes when you get the end of a film, you end up winding the shutter 98% of the way. Getting that last 2% wound can require being a little aggressive. Pentaxes aren't the only cameras out there where this happens.
That's exactly what has happened to me. Just did it and now it works, so, ehm, this problem is lame enough.

QuoteOriginally posted by murrelet Quote
Could it be related to this
Thak you for this remark, now it's pretty clear how to operate with lever.
Also I've noticed it's not that hard to make two shots with overlapping on this camera, that's vexingly.
So this thread can be closed I think.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
button, camera, film, lever, moves, p30, p30t, pentax help, photography, release, release button, shutter, troubleshooting, wind, wind lever
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax P30 - Wind Lever Problem. nat.mitch Troubleshooting and Beginner Help 5 05-12-2021 02:57 AM
Super Program Wind Lever Stuck, LCD out, Shutter Closed Jake Schmidt Visitors' Center 4 06-19-2016 11:28 PM
shutter won't pop when i advance the wind lever noobfilmphotographer Troubleshooting and Beginner Help 9 03-31-2016 09:51 PM
P30 Wind Lever Doesn't Wind Complete Cycle - Any ideas? pengam Film SLRs and Compact Film Cameras 14 08-31-2015 06:08 AM
K1000 Film wind lever broke? n61870 Film SLRs and Compact Film Cameras 4 06-11-2015 06:24 AM



All times are GMT -7. The time now is 07:28 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top