Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-24-2022, 06:22 AM   #1
New Member




Join Date: Jul 2022
Posts: 4
Pentax LX Mirror/Shutter Stuck at 1/60 and 1/30

Hey guys,


I've just bought a Pentax LX a few days ago in pretty good conditions and from a later batch (SN beginning with 53), but noticed, that shutter speeds 1/30 and 1/60 cause really weird problems and are nearly unusable.


When I'm shooting on them in manual mode, the mirror and shutter get stuck and keep open until I'm slightly rotating the shutter wheel again. In automatic mode they are closed again, but it still seems, that they keep on opening way to long, like a 1/8.


Do you have any ideas how to fix this and is it part of the commonly known mirror stuck problem of the LX or something different?

I would really like to keep my configuartion of the LX, so I hope its fixable.


Thanks a lot for your help!

Gabor

07-24-2022, 08:26 AM   #2
Pentaxian
Aaron28's Avatar

Join Date: Jan 2015
Location: Huntsville, Al
Posts: 6,991
likely a lube issue
07-24-2022, 08:31 AM   #3
Loyal Site Supporter
Loyal Site Supporter




Join Date: Feb 2015
Posts: 238
My LX does that when the batteries are low, everything less than 1/90 is electronically timed. Are you using new batteries? If you're using new batteries, I would worry that it could be an electronic issue, but it could also just need to be CLAd. It also could be the sticky mirror syndrome which is an expensive fix. The mirror bumpers get sticky and the mirror sticks. This requires the mirror bumpers to be replaced and requires the mirror to be recalibrated.

Last edited by Dipsoid; 07-24-2022 at 08:44 AM.
07-24-2022, 09:05 AM   #4
New Member




Join Date: Jul 2022
Posts: 4
Original Poster
I've tried it with two types of batteries now, both of them brand new (Cr1/3 N and 2x LR44). The camera also doesn't indicate any low battery, light meter is working fine and all electronic shutters below 1/30 are working as well. It's just the two shutters 1/60 and 1/30. At 1/60 I sometimes works, but very irregular and on 1/30 the mirror and shutter is always stuck.

07-24-2022, 11:58 AM   #5
Pentaxian




Join Date: May 2011
Location: Santa Cruz, CA
Photos: Albums
Posts: 3,057
In manual mode, all the shutter speeds on the LX from X (1/75) to 1/2000 - as well as B, are all mechanically controlled. All speeds 1/60 and below are electronically controlled.
Are you saying that only 1/30 & 1/60 have a problem - while all the other slower shutter speeds are fine?
Is this while in manual selection mode and/or aperture priority?
07-25-2022, 01:20 AM   #6
New Member




Join Date: Jul 2022
Posts: 4
Original Poster
QuoteOriginally posted by LesDMess Quote
In manual mode, all the shutter speeds on the LX from X (1/75) to 1/2000 - as well as B, are all mechanically controlled. All speeds 1/60 and below are electronically controlled.
Are you saying that only 1/30 & 1/60 have a problem - while all the other slower shutter speeds are fine?
Is this while in manual selection mode and/or aperture priority?
Yes, I know that. It is just the 1/30 and 1/60 in manual selection mode, that aren't working and the mirror and shutter get stuck completely. Everything slower works fine. In Aperture Priority Mode both 1/30 and 1/60 are closing the mirror and shutter, but it feels like the exposure time is way too long for a 1/30, seems to be open more like a 1/8.
07-25-2022, 07:29 AM   #7
Pentaxian
womble's Avatar

Join Date: Apr 2010
Location: Hertfordshire
Photos: Gallery
Posts: 4,259
Sounds like time for a service if you can find anyone willing to service an LX these days

07-25-2022, 12:49 PM   #8
Site Supporter
Site Supporter
Eyewanders's Avatar

Join Date: Jan 2008
Location: Land of the Salish Sea
Photos: Gallery | Albums
Posts: 3,340
QuoteOriginally posted by GaBaum Quote
Hey guys,


I've just bought a Pentax LX a few days ago in pretty good conditions and from a later batch (SN beginning with 53), but noticed, that shutter speeds 1/30 and 1/60 cause really weird problems and are nearly unusable.


When I'm shooting on them in manual mode, the mirror and shutter get stuck and keep open until I'm slightly rotating the shutter wheel again. In automatic mode they are closed again, but it still seems, that they keep on opening way to long, like a 1/8.


Do you have any ideas how to fix this and is it part of the commonly known mirror stuck problem of the LX or something different?

I would really like to keep my configuartion of the LX, so I hope its fixable.


Thanks a lot for your help!

Gabor
This is quite similar to the erratic behavior my early model exhibits. I've learned to live with mine but have made it happen with far less frequency. CLA and two (very long) trips to Eric H over the course of two years did not resolve it.
Question: when this happens does the meter read a value that seems correct and is it steady, e.g. does it behave how you'd expect... or does it jump about when you move to those shutter speeds?
If so, does it moving (or even touching/applying pressure to the exposure-comp wheel or shutter wheel make the meter LEDs change in any drastic way? (Just trying to ascertain if your issue is in any way similar to mine).
07-25-2022, 03:27 PM   #9
Senior Member




Join Date: May 2021
Posts: 158
I bought a second LX that also had inconsistent manual speeds below 1/60, even after installing new batteries. I contacted a Pentax technician and he indicated that one possible cause was a faulty shutter speed control board. If this part is faulty the only solution is to find a replacement part from a working donor camera, since factory spare parts are no longer available. Obviously the problem can not be correctly diagnosed until the camera is disassembled and tested, which is not a cheap undertaking. I decided to return the camera to avoid an expensive service with no guarantees that the problem can be fixed.

A useful reference here:
https://harrowtechnical.co.uk/camera-faults/

Last edited by andrewd; 07-25-2022 at 03:34 PM.
07-27-2022, 09:51 AM - 2 Likes   #10
New Member




Join Date: Jul 2022
Posts: 4
Original Poster
I decided to return the camera after a long conversation with a Pentax technician, who suggested an faulty electronic shutter speed control board too.

Thanks to all your advices, I hope to have more luck with my next LX order
11-30-2022, 12:38 PM   #11
Junior Member




Join Date: Oct 2014
Location: Luquillo, Puerto Rico
Posts: 29
I just bought a late model LX with similar problems, hoping it was a sticky mirror problem, W/O batteries it seems to default to x synch speed only. With batteries, it seems to default to automatic shutter only, and it seems to return correct shutter speeds but it will not engage to manual speeds. I took a chance and it seems I bought a dud. Any suggestions?

---------- Post added 11-30-22 at 04:37 PM ----------

QuoteOriginally posted by RebelCharlie Quote
I just bought a late model LX with similar problems, hoping it was a sticky mirror problem, W/O batteries it seems to default to x synch speed only. With batteries, it seems to default to automatic shutter only, and it seems to return correct shutter speeds but it will not engage to manual speeds. I took a chance and it seems I bought a dud. Any suggestions?
Post update; I tried an experiment with one of my Sunpak 544 strobes, open back, no lens attached I fired at a white floor, at speeds 1/2000, 1/1000, 1/500, 1/250, 1/125, x and 1/60, I could see how the slot distance between the curtains was increasing up to X that showed full frame illumination, in the at 1/60 and below, the second curtain took 13 seconds to release. When pointed at a 60-watt light bulb it took 2 seconds. In other words, from x to 1/2000 manual speeds work fine, below that it defaults to auto. Then at 1/2 second speeds go crazy again and seem to default to 125 seconds, approximately.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
batteries, camera, chance, default, dud, film, lx, mirror, mirror stuck, mode, pentax, pentax lx, pentax lx mirror/shutter, post, problem, shutter, shutter stuck, slr, speeds, suggestions, troubleshooting
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-50: Shutter stuck closed mirror stuck in upper position after power failure aaron_r Pentax K-30 & K-50 13 07-05-2020 01:56 AM
Pentax LX mirror stuck up in AUTO only iht Film SLRs and Compact Film Cameras 26 09-29-2010 11:37 AM
6x7 MLU mirror and shutter stuck open mk07138 Pentax Medium Format 2 03-17-2009 03:07 PM



All times are GMT -7. The time now is 07:12 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top