Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-28-2006, 02:58 PM   #1
Junior Member




Join Date: Oct 2006
Posts: 36
My Takumar wont meter properly on P30

Today I went for some early morning shooting. slotting in my 28mm f3.5 Takumar (M42) with my P30, I was surprised that it was asking for 1/6 sec at f3.5 in broad daylight. I have the lens set to manual stop-down metering, and the camera responds to me turning the aperture ring (even suggesting 1" at f8). so i have no idea why.

putting on a regular K mount lens seems to solve this. the same scene, same conditions, the camera suggests in the vicinity of 1/125, etc

11-28-2006, 03:59 PM   #2
Veteran Member




Join Date: Sep 2006
Location: Mississippi, USA
Photos: Gallery
Posts: 572
Best guess reply :-)

I don't think the tak is making any contact with the pins on the front of the p30.
Without any contact the camera doesn't think a lense is attached. Mount your lense and look and see if you can see the pins on the camera body. If they aren't contacting the pins, you can still shoot, just no metering. The rear diameter of the tak is smaller than other screw mounts or k mounts.
11-28-2006, 10:39 PM   #3
Junior Member




Join Date: Oct 2006
Posts: 36
Original Poster
yeah, the adpater ring is definitely fully recessed into the body's K mount. i would have thought that the default on the camera is to assume that the lens is at wide open mode if theres no detection, guess it wasnt the case.

if i could figure out what the default stop is, then i guess its possible to compensate for what the meter is reading out...
11-29-2006, 01:39 PM   #4
Veteran Member




Join Date: Sep 2006
Location: Mississippi, USA
Photos: Gallery
Posts: 572
Mounted a Tak35/3.5 on my P3, cousin of your P30. Tak 35 made no contact with the pins, Tak metered as it should compared to a K mount.Readings were identical. I've got no idea why your Tak won't meter on your P30.
I think Mark Roberts site has a break down as to what the pins mean on the camera body. You may find your answer there.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, f3.5, lens, p30, takumar
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
pentax p30 tomb2112 Pentax Film SLR Discussion 12 02-23-2011 08:34 PM
MX - B not working properly pontusadefjord Pentax Film SLR Discussion 3 09-13-2010 11:01 AM
K-7 / fz-20 / p30 hcc Pentax DSLR Discussion 3 08-31-2010 02:28 PM
How to properly use a monopod dugrant153 Pentax Camera and Field Accessories 12 10-18-2009 07:53 PM
k1000 light meter not working properly sharko Pentax Film SLR Discussion 10 10-26-2008 11:58 AM



All times are GMT -7. The time now is 04:24 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top